since ‎06-07-2020
‎20-08-2020
GokulBakthavachalam
Level 1
Re: Unable to install the new Java helper class in AEM 6....
Avatar

GokulBakthavachalam

GokulBakthavachalam
- Adobe Experience Manager
Hi @ChitraMadan Below are the Impl class------------------------------------- Impl Class--------------------package com.arrowleathers.core.models.logo;import javax.annotation.PostConstruct;import org.apache.commons.lang3.StringUtils;import org.apache.sling.api.SlingHttpServletRequest;import org.apache.sling.api.resource.ValueMap;import org.apache.sling.models.annotations.Model;import org.apache.sling.models.annotations.injectorspecific.ScriptVariable;import org.slf4j.Logger;import org.slf4j.Logg...

Views

226

Likes

0

Replies

0
Re: Unable to install the new Java helper class in AEM 6....
Avatar

GokulBakthavachalam

GokulBakthavachalam
- Adobe Experience Manager
@Nikhil-Kumar Thanks for your reply. I don't see any errors in felix console . Also I am able to install the other java class files using the below configuration. But I am getting use api errors .If I remove this piece of code it is not installing the new class files. So confused with this . org.apache.slingmaven-sling-plugin2.2.0installhttp://${aem.host}:${aem.port}/system/consoleWebConsole Any help is highly appreciated.

Views

275

Likes

0

Replies

0
Re: Unable to install the new Java helper class in AEM 6....
Avatar

GokulBakthavachalam

GokulBakthavachalam
- Adobe Experience Manager
I tried to override the list component Impl class and the component is in active state also I can see the client lib folders are working fine .Only the new model is not installing in the bundles and other models are installed for other components .Please check the below versions in parent POM.xml and correct if anything is wrong.Also I have attached the core POM.xml file.POM.xml------------------------4.0.0arrow-leather-website-aemarrow-leather-website-aempom1.0-SNAPSHOTArrow Leathercoreui.appsiorg.apache.slingmaven-sling-plugin-->...

Views

230

Likes

0

Replies

0
Unable to install the new Java helper class in AEM 6.5.3 after upgrade from AEM 6.3
Avatar

GokulBakthavachalam

GokulBakthavachalam
- Adobe Experience Manager
Hi All, I am seeing issues while trying to install the Java helper class in AEM 6.5.3 version. This issues is in particular with the newly created helper classes in 6.5.3 version whereas the ones created in 6.3. version seems to be working without issues.Also, I am unable to read the page properties while doing enhancements in the clases in 6.5.3 version originally created in 6.3 version.I did check in the system console bundle but could not find the newly created models. Could this be related t...

Views

409

Like

1

Replies

7
Re: Header content is not loading in AEM publish instance...
Avatar

GokulBakthavachalam

GokulBakthavachalam
- Adobe Experience Manager Assets
I am facing this issues in AEM 6.5 only. You can compare the headers before and after login.After Login:Before Login:

Views

270

Likes

0

Replies

0
Re: Header content is not loading in AEM publish instance...
Avatar

GokulBakthavachalam

GokulBakthavachalam
- Adobe Experience Manager Assets
Hi diksha_mishra , I have removed the editor in publish mode. It is working when I login to the publish instance and my question is when I open the publish instance with my ip address instead of localhost the page is loaded without headers. I want to open the page by default without any login credentials.

Views

307

Likes

0

Replies

0
Re: Header content is not loading in AEM publish instance while accessing using IP and also not working in dispatcher
Avatar

GokulBakthavachalam

GokulBakthavachalam
- Adobe Experience Manager Assets
It was loading after I login to the url . I need to know how it can be loaded without login in dispatcher.

Views

384

Likes

0

Replies

0
Header content is not loading in AEM publish instance while accessing using IP and also not working in dispatcher
Avatar

GokulBakthavachalam

GokulBakthavachalam
- Adobe Experience Manager Assets
Hi Team, I tried accessing the pages in Author environment and the page header and footer content is loading properly while loading the page .http://localhost:4502/editor.html/content/we-retail/us/en.htmlIt is also loading properly in publish instance .http://localhost:4503/editor.html/content/we-retail/us/en.html But the header and footer is not loading if I try accessing it through ip instead of localhost.I faced this issue in my project then I tried for we-retail page and I can see the issue ...

Views

397

Likes

0

Replies

6
Likes given to
Likes from