SSL Exception consuming the REST Service

Avatar

Avatar
Validate 10
Level 2
chandran8596539
Level 2

Like

1 like

Total Posts

39 posts

Correct reply

0 solutions
Top badges earned
Validate 10
Validate 1
Boost 1
View profile

Avatar
Validate 10
Level 2
chandran8596539
Level 2

Like

1 like

Total Posts

39 posts

Correct reply

0 solutions
Top badges earned
Validate 10
Validate 1
Boost 1
View profile
chandran8596539
Level 2

13-12-2016

Am trying to consume the REST webservice from java bundle, am gettign the following exception

javax.net.ssl.SSLException: java.lang.RuntimeException: Unexpected error: java.security.InvalidAlgorithmParameterException: the trustAnchors parameter must be non-empty

            at sun.security.ssl.Alerts.getSSLException(Alerts.java:208)

            at sun.security.ssl.SSLSocketImpl.fatal(SSLSocketImpl.java:1884)

 

Does any one faced this issue ? 

Verified 'Apache Felix Jetty Based Http Service' OSGI config , truststore feild is empty, is this creating any issue ?

Accepted Solutions (1)

Accepted Solutions (1)

Avatar

Avatar
Validate 1000
Community Manager
jantzen_belliston-Adobe
Community Manager

Likes

339 likes

Total Posts

2,338 posts

Correct reply

819 solutions
Top badges earned
Validate 1000
Springboard
Validate 500
Validate 250
Validate 100
View profile

Avatar
Validate 1000
Community Manager
jantzen_belliston-Adobe
Community Manager

Likes

339 likes

Total Posts

2,338 posts

Correct reply

819 solutions
Top badges earned
Validate 1000
Springboard
Validate 500
Validate 250
Validate 100
View profile
jantzen_belliston-Adobe
Community Manager

13-12-2016

Hi,

Can you tell me which product you are trying to use the API for? Currently, your post is under the DTM section of this community. DTM does not have an API that can be used to make changes. Once I know which product you're trying to access, I can move your post to the correct section of the community.

 

Cheers,
Jantzen

Answers (2)

Answers (2)

Avatar

Avatar
Validate 1000
Community Manager
jantzen_belliston-Adobe
Community Manager

Likes

339 likes

Total Posts

2,338 posts

Correct reply

819 solutions
Top badges earned
Validate 1000
Springboard
Validate 500
Validate 250
Validate 100
View profile

Avatar
Validate 1000
Community Manager
jantzen_belliston-Adobe
Community Manager

Likes

339 likes

Total Posts

2,338 posts

Correct reply

819 solutions
Top badges earned
Validate 1000
Springboard
Validate 500
Validate 250
Validate 100
View profile
jantzen_belliston-Adobe
Community Manager

13-12-2016

No problem 🙂
 

I just wanted to ensure your question had the best visibility. Since you've already posted in the AEM forums, I'll just resolve this question here rather than move it. Thanks for stopping by the Activation community.

Avatar

Avatar
Validate 10
Level 2
chandran8596539
Level 2

Like

1 like

Total Posts

39 posts

Correct reply

0 solutions
Top badges earned
Validate 10
Validate 1
Boost 1
View profile

Avatar
Validate 10
Level 2
chandran8596539
Level 2

Like

1 like

Total Posts

39 posts

Correct reply

0 solutions
Top badges earned
Validate 10
Validate 1
Boost 1
View profile
chandran8596539
Level 2

13-12-2016

Sorry, didnt check where am posting my question. This is for AEM forum. No worries I posted in AEM forum. Thank you 🙂