Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
BedrockMission!

Learn more

View all

Sign in to view all badges

SOLVED

A4T implementation - with DTM?!

nii-ra
Level 3
Level 3

Hi there,

I am trying to implement Analytics4Target integration, and I found the following article on how to do it. https://marketing.adobe.com/resources/help/en_US/target/a4t/c_a4timplementation.html

However, the thing is we have DTM and seems like Marketing Cloud Service (Visitor ID service) is already setup there. Do I still need to setup Visitor ID Service mentioned in the link above? Will all the steps still apply in the above article, given the fact that we have DTM?

Thanks!

1 Accepted Solution
jantzen_belliston-Adobe
Correct answer by
Community Manager
Community Manager

Hi,

Please see the knowledge base article I just published this week. It goes over possible reasons the A4T integration might not be working.

Report Suites are not Available in Target after A4T Provisioning

The setting you reference is a company setting and is talked about in the article under the "Company Settings" section of the article.

Snippet from the KB article:

To access this setting, log in to Adobe Target as an admin user and do the following:

  1. Click Setup in the top navigation
  2. Click Preferences from the left navigation
  3. Choose "Select per activity" from the Marketing Cloud solution used for reporting dropdown

If you've verified your Analytics and Target permissions and the company settings are not appearing, we may need to check your provisioning. Can you confirm you requested provisioning at some point via adobe.com/go/audiences?

Cheers,
Jantzen

View solution in original post

10 Replies
ParitMittal
Level 10
Level 10

Hi ,

No you don't have to set up Marketing cloud Visitor ID service again if it's already done in DTM. However please note that as mentioned in the article ,This integration requires that you implement or migrate to Visitor ID Service 1.5 or later.
Please verify that Marketing Cloud Visitor ID Service implemented through DTM is 1.5 or later .

Also, This integration requires AppMeasurement for JavaScript  to be 1.4.1 or later or Analytics scode.js version H.27 or later .Please make sure your App measurement library in DTM is 1.4.1 or later.

Thanks & Regards

Parit Mittal

nii-ra
Level 3
Level 3

Thanks Parit! I confirmed and everything is good in DTM in terms of versions.

Based on that, I think most of the other steps in this doc (https://marketing.adobe.com/resources/help/en_US/target/a4t/c_a4timplementation.html) are not relevant. However, I am stuck in the last step.

     
Enable the options for using Analytics as the reporting source for Target.

In Target, click Setup > Preferences and choose either Select per activity or Adobe Analyticsto enable the options.

  • Select per activity lets you choose between Target and Analytics when creating each activity.
  • Adobe Analytics sets Analytics as the reporting source for all activities.

I don't see this option in my Target Premium interface. Does this still apply?

ParitMittal
Level 10
Level 10

Hi  , 

We are looking into this and will get back to you ASAP 

Thanks & Regards

Parit Mittal

ParitMittal
Level 10
Level 10

Hi , 

Do you have  web services access granted in the analytics user management admin ? If not , can you please grant web services access to you in analytics user management admin and then check if the option appears .

Thanks & Regards

Parit Mittal

nii-ra
Level 3
Level 3

Parit,

We tried it and we are still unable to see the options in the Preferences. Screenshot attached.

Thanks!

ParitMittal
Level 10
Level 10

Hi ,

Can you please check the out below user permission requirements and let us know whether the all the requirements are good from your end.

 https://marketing.adobe.com/resources/help/en_US/target/a4t/c_account_reqs.html

Thanks & Regards

Parit Mittal

nii-ra
Level 3
Level 3

Is there a way to confirm that my Web Services Access is in good shape? I have heard from my admin that he provided Web Services Access to me but when I go to Admin tab in Analytics, I do not see anything. How can I know that it is actually working? Please see the attached screenshot.

I can confirm everything else is good (Linked Accounts in Marketing Cloud, Access to report suites, etc). Thanks

ParitMittal
Level 10
Level 10

Hi ,

We have checked from our end and you have already been provided access to Web Services Access group for  "Orvis"  company.  Please find below snapshot for your reference.

CM EDIT: Removed screenshot as it included web services credentials and personal information.

Thanks & Regards

Parit Mittal

nii-ra
Level 3
Level 3

Thanks Parit. But why am I still not seeing these options despite having Web Services Access?

      
Enable the options for using Analytics as the reporting source for Target.

In Target, click Setup > Preferences and choose either Select per activity or Adobe Analyticsto enable the options.

  • Select per activity lets you choose between Target and Analytics when creating each activity.
  • Adobe Analytics sets Analytics as the reporting source for all activities.
jantzen_belliston-Adobe
Correct answer by
Community Manager
Community Manager

Hi,

Please see the knowledge base article I just published this week. It goes over possible reasons the A4T integration might not be working.

Report Suites are not Available in Target after A4T Provisioning

The setting you reference is a company setting and is talked about in the article under the "Company Settings" section of the article.

Snippet from the KB article:

To access this setting, log in to Adobe Target as an admin user and do the following:

  1. Click Setup in the top navigation
  2. Click Preferences from the left navigation
  3. Choose "Select per activity" from the Marketing Cloud solution used for reporting dropdown

If you've verified your Analytics and Target permissions and the company settings are not appearing, we may need to check your provisioning. Can you confirm you requested provisioning at some point via adobe.com/go/audiences?

Cheers,
Jantzen

View solution in original post