I have an Adobe Target at.js v2.x question, we are in the process of migrating from 1.x to 2.x and hoping to leverage preloading and triggerView for a VEC friendly implementation that scales.
The question I have is around the naming convention of the triggerViews - let me give an example:
Say we are an eCommerce website that has many different product detail pages (PDPs), we have 2 options when defining view names for each PDP..
- We keep it generic - i.e. single view name for all PDP `shop:product-detail`
- We make it granular - i.e. single view name per product `shop:product-detail:product-123`
Each has a pro and con, if we want to run a test across all PDP pages then #1 is most effective, otherwise if we wanted to test on a sub-set of PDP then #2 might be more effective.
Would be interested on how others have approached this?
Does the triggerView also allow a templated approach where I can apply modifications to many triggerViews that match a certain pattern - e.g. starts with `shop:product-detail`
(A third option comes to mind, where we could trigger both..)