Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

SOLVED

A4T - Don't See Target Activity

Avatar

Level 2

Hello community,

 

I'm struggling with something, and hope you can provide some clarity.

 

I've created an A/B activity using Analytics as the reporting source. We have a premium account with A4T integrated. However, after activating my test in our staging environment I don't see the activity in the TARGET ACTIVITY dropdown in the A4T Panel in Analytics.

 

Is the activity only accessible once data has been collected? I can understand if there's no data, but why can't I build the panel in advance of receiving data?

 

New-project-Analysis-Workspace-Adobe-Analytics (1).png

1 Accepted Solution

Avatar

Correct answer by
Employee Advisor

Hi @bkmills,

When you first create an A4T activity in Target, a back-end process has to run in order to list the new activity and experiences in the Target related dimensions in Analytics Workspace. This usually only takes a few hours after the activity is first saved, but could take a day in some cases. Keep in mind the activity data collection and reporting work immediately, it's just the friendly names of the activities that are going to take a little bit to show up at first.

Could this be your issue? Hope that helps. 

View solution in original post

5 Replies

Avatar

Correct answer by
Employee Advisor

Hi @bkmills,

When you first create an A4T activity in Target, a back-end process has to run in order to list the new activity and experiences in the Target related dimensions in Analytics Workspace. This usually only takes a few hours after the activity is first saved, but could take a day in some cases. Keep in mind the activity data collection and reporting work immediately, it's just the friendly names of the activities that are going to take a little bit to show up at first.

Could this be your issue? Hope that helps. 

Avatar

Level 2

Hi @Ryan_Roberts_,

 

This makes sense. We were having trouble with setting the report suite to Analytics when this activity was created. This resulted in changing the default reporting source to Analytics in the account settings, and why I thought it may have something to do with the Target Activity not appearing in the A4T panel.

 

Thanks for your help!

Avatar

Level 2

@Ryan_Roberts_ - Turns out, unbeknownst to me, our dev environment is not configured for A4T reporting. Because we were QAing an activity in our staging environment, there was no data being captured.

 

Switching to production, and using activity qa links, addressed the issue. Shortly after that, I was able to access the Target Activity in AA and build out the A4T panel.

 

Thanks for the explanation you provided. It was definitely useful!

Avatar

Level 2

Hi @Ryan_Roberts_,

 

In case of AEP Web SDK implementation for Analytics and Target both, we are only seeing numbers for "Analytics for Target" dimension but the other two dimensions "Target Activities" and "Target Activity > Experience" are showing only "Unspecified" (see below). Please let us know if there is any additional configuration required for A4T in case of Web SDK or any other possible causes.

 

DisaRas_0-1650276759256.png

 

 

Avatar

Community Advisor

The synchronization time is usually a few hours after an activity is created in Target and provided A4T integration was done atleast 24 hours ago. 

 

Hope this helps!