Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

Activity QA link not showing test changes

jasond23496956
Level 2
Level 2

A couple team members and I are having trouble getting the Activity QA link to generate a preview with the changes we've made for our tests. I've tried most of the suggestions(toggling off audience rules, clearing browser, going incognito,etc) I've read here and not working properly so far. We have AEM 6.4 for our site. If anyone has any insight on why we're not able to see any changes, it'd be greatly appreciated.

5 Replies
Shruthi_N
Employee
Employee

You can try using a debug query parameter to check if there are any selector issues . Using the below query parameters will output console statements with the actions that target is trying to apply and if it is successful or not.

If using at.js append the preview link with &mboxDebug=console .If on mbox.js append with &_AT_Debug=console .

It will look something like this,

1540781_pastedImage_1.png

jasond23496956
Level 2
Level 2

We're using at.js it looks like, where in the URL do I append &mboxDebug=console to?

My link currently looks like this

?at_preview_token=cO5wxjHphR5difyn5LzSNQ%3D%3D&at_preview_index=1_1&at_preview_listed_activities_only=true

Shruthi_N
Employee
Employee

You can append it to the end as follows:

?at_preview_token=cO5wxjHphR5difyn5LzSNQ%3D%3D&at_preview_index=1_1&at_preview_listed_acti vities_only=true&mboxDebug=console

jasond23496956
Level 2
Level 2

I've tried appending to the URL and receive the following in the console:

AT: [global mbox] auto-create disabled

AT: Settings Object

If I modify the url, i'll get this instead on settings.

target-console-link.jpg

It doesn't look like I'm receiving any errors that I know of. Do you have any other recommendations?

LJ_Jones
Level 4
Level 4

I've noticed that sometimes I get stuck in other previews that I was working on causing the current preview not to render correctly.  So I usually clear the preview and it often clears things up.  Then go back to the current preview.  To clear it you just need the blank url parameter ?at_preview_token= with nothing after the equals sign.  I also wrote some javascript that you can bookmark in your browser that will clear if for you.  Here's a link to the code for the bookmark. How to Clear Adobe Target Previews