Expand my Community achievements bar.

Dive into Adobe Summit 2024! Explore curated list of AEM sessions & labs, register, connect with experts, ask questions, engage, and share insights. Don't miss the excitement.
SOLVED

XML Source Tab not working, please test this form on LiveCycle

Avatar

Level 3

Hello,

I've recently posted this form to solve a few issues.

Now I have a new problem.

While in LiveCycle ES, I select the  XML Source Tab....

LiveCycle thinks for a bit but nothing happens!....

Does anyone know how to fix this problem?

I do not want to go back to an old form and redo all the work.

Thank You

Arnold

1 Accepted Solution

Avatar

Correct answer by
Former Community Member

This one is wierd .....I found a way to fix it but I cannot explain why it is doing what it is doing.

Simply add an xfa.layout.relayout() command to the Print button. Add that command before the print command. I think the issue is happening because you are doing all of this from Master Pages .....I want to move all of that to the Body page and see if the same thing happens.

Paul

View solution in original post

29 Replies

Avatar

Level 3

I did receive the message but the post in the morning had no attachment.

Did you post it into the forum?

Arnold

Avatar

Level 3

Hi Paul,

We started testing the form and the checkboxes matched up very well. Something odd has come up... After selecting a few boxes we would try to select none to clear the selections. The checkboxes clears up but after printing the avoidance text box retains value. Is there script that would clear the avoidance text field if "none" is selected?

Thank You,Arnold, we are very pleased with the results.

Avatar

Former Community Member

Seems to work fine for me .....tell me the exact steps you are doing to duplicate the problem.

Paul

Avatar

Level 3

Hi Paul,

I figured out what they were asking about.

The box is also used for text edit.

text is added to specify type of food or medication.

If a doctor or nurse decides to click none everything should clear.

But once you manually alter text or add free text it remains in the text box.

example:

Foods(add food here)

Foods: Carrots, Peas

Once none is selected after "Carrots, Peas" added it does not auto remove if checkbox "None" is selected.

Hope that explains it, I had to ask again what the problem was.

Thank You,

Arnold

Avatar

Correct answer by
Former Community Member

This one is wierd .....I found a way to fix it but I cannot explain why it is doing what it is doing.

Simply add an xfa.layout.relayout() command to the Print button. Add that command before the print command. I think the issue is happening because you are doing all of this from Master Pages .....I want to move all of that to the Body page and see if the same thing happens.

Paul

Avatar

Level 3

Good morning,

Ok, if that fixes the problem without compromising the layout then it's perfectly fine,

Thanks,

Arnold

Avatar

Level 3

Hi Paul I added the command,

And the command is preventing the Avoidance from printing at all.

Here is how I added it.

 topmostSubform.#pageSet[0].PageArea1.#subform[0].PrintButton1::click - (JavaScript, client)

xfa.layout.relayout()

xfa.host.print(1, "0", (xfa.host.numPages -1).toString(), 0, 0, 0, 0, 0);

 topmostSubform.#pageSet[0].PageArea1.#subform[0].PrintButton1::mouseUp - (JavaScript, client)

xfa.host.messageBox("Print 2 copies of form and keep a signed copy for the Medical Record");

When I added the command, the avoidance would not print at all.

Did I do something wrong?

Arnold

Avatar

Level 3

Hi Paul,

I found when I put the command on the exit command,clicking none would properly clear the avoidance text.

So I tested out something else. Here is what I found:

When clicking on the food or medicine box, I would type in the types of food or medicine to avoid.

The wording would return to the default "(List Food(s) here)" after selecting another checkbox.

This would mean I had to type in the food or medicine over again.....

So we fixed the None box to clear the avoidance that works fine.

But now when selecting food, typing in the food restores default when another checkbox is clicked. Any solutions?

Arnold.

The following has evaluated to null or missing: ==> liqladmin("SELECT id, value FROM metrics WHERE id = 'net_accepted_solutions' and user.id = '${acceptedAnswer.author.id}'").data.items [in template "analytics-container" at line 83, column 41] ---- Tip: It's the step after the last dot that caused this error, not those before it. ---- Tip: If the failing expression is known to be legally refer to something that's sometimes null or missing, either specify a default value like myOptionalVar!myDefault, or use <#if myOptionalVar??>when-present<#else>when-missing. (These only cover the last step of the expression; to cover the whole expression, use parenthesis: (myOptionalVar.foo)!myDefault, (myOptionalVar.foo)?? ---- ---- FTL stack trace ("~" means nesting-related): - Failed at: #assign answerAuthorNetSolutions = li... [in template "analytics-container" at line 83, column 5] ----