Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
BedrockMission!

Learn more

View all

Sign in to view all badges

SOLVED

Xml parsing error - " help please

fionak240180
Level 1
Level 1

I  have been using livecycle designer for some time but am quite new to xml.

I have added a regular button with the submit function to allow my form to be emailed and this works well.

However we would like to have the email pre-populate the subject line and body with a set of instructions for our users.

After lots of google and forum searches I have the line of xml code

submit format="pdf" textEncoding="UTF-16" xdpContent="pdf datasets xfdf" target="mailto:email@health.qld.gov.au" subject="Completed Travel Form for Approval - Traveller - Date"&amp body="(email body) "/>

but I am getting the following error  - XML parsing error:not well-formed (invalid token) (error code 4), line 10220, column 202 of file

which relates to the " after the word Date

Does anyone know how I can fix this?? and if this will do what I am trying to achieve?

Thanks

1 Accepted Solution
radzmar
Correct answer by
Level 10
Level 10

Hi,

the submit element does not support the subject attribute, there is only a target attribute that contains a string build after the mailto scheme.

Change you xml source into this.


<submit format="pdf" textEncoding="UTF-16" xdpContent="pdf datasets" target="mailto:email@health.qld.gov.au?subject=Completed Travel Form for Approval - Traveller - Date&amp;body=email body"/>


View solution in original post

3 Replies
radzmar
Correct answer by
Level 10
Level 10

Hi,

the submit element does not support the subject attribute, there is only a target attribute that contains a string build after the mailto scheme.

Change you xml source into this.


<submit format="pdf" textEncoding="UTF-16" xdpContent="pdf datasets" target="mailto:email@health.qld.gov.au?subject=Completed Travel Form for Approval - Traveller - Date&amp;body=email body"/>


View solution in original post

fionak240180
Level 1
Level 1

Hi,

Thanks for the reply, unfortunately the below has stopped the functionality of adding to the email, meaning my submit button no longer works at all.

fionak240180
Level 1
Level 1

Hi,

I please ignore my reply above.. I have tried your suggestion again and it has worked, which is awesome.. thank you.. only now I find I am unable to have the email populated with line breaks, but rather all in one long stream of text. I have tried a couple of options for adding this break with no success