Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
BedrockMission!

Learn More

View all

Sign in to view all badges

Trouble when coding LiveCycle to set up an email with .

Avatar

Avatar
Validate 1
Level 1
nicolasc5860247
Level 1

Likes

0 likes

Total Posts

3 posts

Correct Reply

0 solutions
Top badges earned
Validate 1
View profile

Avatar
Validate 1
Level 1
nicolasc5860247
Level 1

Likes

0 likes

Total Posts

3 posts

Correct Reply

0 solutions
Top badges earned
Validate 1
View profile
nicolasc5860247
Level 1

21-11-2018

Hi all

I have been using Adobe LiveCycle Designer E4 where I work on forms.

For one of the functions on that form, I need to be able to send an email to a designated person with the form as an attachment. This works without any problem.

The real issue comes when I want to add cc recipients to it. When implementing my code (XML), i have them in the desired cc, but I can not remove them from the to box.

I am using following code:

1626563_pastedImage_7.png

<submit format="pdf" textEncoding="UTF-16" target="mailto:abc@gmail.com; ?cc= cba@gmail.com ?subject=BLABLA" xdpContent="pdf datasets">

And this is the output I get:

1626566_pastedImage_11.png

When i do it with following code (emails are recognized):

1626573_pastedImage_1.png

<submit format="pdf" textEncoding="UTF-16" target="mailto:kristoff_XXX@tuifly.be; ?cc= nicolas_XXX@tuifly.be ?subject=BLABLA" xdpContent="pdf datasets">

I get:

1626568_pastedImage_13.png

Can somebody help me out?

Thank you!

NC

Accepted Solutions (0)

Answers (3)

Answers (3)

Avatar

Avatar
Validate 1
Level 1
nicolasc5860247
Level 1

Likes

0 likes

Total Posts

3 posts

Correct Reply

0 solutions
Top badges earned
Validate 1
View profile

Avatar
Validate 1
Level 1
nicolasc5860247
Level 1

Likes

0 likes

Total Posts

3 posts

Correct Reply

0 solutions
Top badges earned
Validate 1
View profile
nicolasc5860247
Level 1

21-11-2018

Hi radzmar

Thank you for your response!

I have already seen that type of code pass by in this forum but when I apply the exact same code as yours, Microsoft Outlook can not recognize the mail address and i get following error message:

1627418_pastedImage_1.png

So I think that Outlook is reading it as one big email address. In my previous code, the spaces and punctuation marks I added, helped that part of the problem. If i modify your code to the following:

1627421_pastedImage_6.png

<submit format="pdf" textEncoding="UTF-16" target="mailto:kristoff_XXX@tuifly.be; ?cc= nicolas_XXX@tuifly.be &amp;subject=BLABLA" xdpContent="pdf datasets">

I get the following:

1627422_pastedImage_8.png

Same initial problem but the Subject has been modified.

NC

Avatar

Avatar
Coach
MVP
radzmar
MVP

Likes

395 likes

Total Posts

2,686 posts

Correct Reply

491 solutions
Top badges earned
Coach
Ignite 3
Ignite 1
Validate 1
Give Back 50
View profile

Avatar
Coach
MVP
radzmar
MVP

Likes

395 likes

Total Posts

2,686 posts

Correct Reply

491 solutions
Top badges earned
Coach
Ignite 3
Ignite 1
Validate 1
Give Back 50
View profile
radzmar
MVP

21-11-2018

You mailTo syntax is incorrect, that's why you having the unwantend effects with the cc.

Change it this way to make it work correctly:

<submit format="pdf" textEncoding="UTF-16" target="mailto:kristoff_XXX@tuifly.be?cc=nicolas_XXX@tuifly.be&amp;subject=BLABLA" xdpContent="pdf datasets">

Avatar

Avatar
Establish
Level 2
kglad
Level 2

Likes

12 likes

Total Posts

45 posts

Correct Reply

2 solutions
Top badges earned
Establish
Give Back 5
Give Back 3
Give Back
Boost 5
View profile

Avatar
Establish
Level 2
kglad
Level 2

Likes

12 likes

Total Posts

45 posts

Correct Reply

2 solutions
Top badges earned
Establish
Give Back 5
Give Back 3
Give Back
Boost 5
View profile
kglad
Level 2

21-11-2018