Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
BedrockMission!

Learn more

View all

Sign in to view all badges

SOLVED

character duplicated and previous one removed.

MHWinter
Level 2
Level 2

A user of forms I developed reported that he repeatedly experienced a bug which I can't explain.

When types something in a text field, whichever character is before (line break or any character) is removed and the 1st character being keyed in is doubled.

He could take a video of the screen showing it happening.

The form was developed with Adobe LiveCycle Designer ES2

It is "Reader extended".

I don't know the details of the work environment of the user.

I could not reproduce the bug myself.

Any idea what the problem could be?

1 Accepted Solution
MHWinter
Correct answer by
Level 2
Level 2

To: Magus069 and MinusZero

Thanks for your help.

I have ruled out the use of PDF processors other than Adobe Acrobat or Reader because this has actually proved to seriously corrupt our forms.

From additional information I gathered from the user who experiences this weird form behavior, I now understand that:

1. the issue is not wide spread and it may actually user specific

2. however, his computer+Windows+PDF processor do not seem to be the issue:  Lenovo X1 Tablet / Win 10 Enterprise 2016 / Adobe Acrobat X

3. The form behavior issue is not limited to one field but seams to appear on any multi-line text field, of which I don't think any includes custom script

4. It seems to happen after clipboard paste operations (especially from Word), but it’s not a pinpoint fact, definitely doesn’t happen all the time

I am now trying to figure out when this started happening, whether it is something introduced by a specific version of the form.

I must say it is a pretty complex form: many pages long, lots of scripts so I am reluctant rebuild the form from scratch, especially considering the user sees that as an annoyance rather than a true impediment.

Thanks again

View solution in original post

6 Replies
MinusZero
Level 7
Level 7

I would be show all events on the field and see if there is anything there that shouldnt be, particularly the change event.

MHWinter
Level 2
Level 2

It happens in a field that contains no script and is not called by any script in the form. Just a plain text fields.

MinusZero
Level 7
Level 7

You could perhaps try loading the form into LCD, save it and then reader extend it again and see if it still happens.

Might need to rebuild it otherwise? Not sure why else it would do that.

Magus069
Level 10
Level 10

Hi there,

Just to make sure, sometimes any other software than Adobe Reader may cause bugs like these when using xfa PDF forms. Ensure that the user is using the latest version of Adobe Reader or any version above the minimal mentioned version for the PDF form.

I've already ran through real weird stuff coming from users only because they use another software to read PDF.

I hope this will help.

MHWinter
Correct answer by
Level 2
Level 2

To: Magus069 and MinusZero

Thanks for your help.

I have ruled out the use of PDF processors other than Adobe Acrobat or Reader because this has actually proved to seriously corrupt our forms.

From additional information I gathered from the user who experiences this weird form behavior, I now understand that:

1. the issue is not wide spread and it may actually user specific

2. however, his computer+Windows+PDF processor do not seem to be the issue:  Lenovo X1 Tablet / Win 10 Enterprise 2016 / Adobe Acrobat X

3. The form behavior issue is not limited to one field but seams to appear on any multi-line text field, of which I don't think any includes custom script

4. It seems to happen after clipboard paste operations (especially from Word), but it’s not a pinpoint fact, definitely doesn’t happen all the time

I am now trying to figure out when this started happening, whether it is something introduced by a specific version of the form.

I must say it is a pretty complex form: many pages long, lots of scripts so I am reluctant rebuild the form from scratch, especially considering the user sees that as an annoyance rather than a true impediment.

Thanks again

View solution in original post

Magus069
Level 10
Level 10

Not sure if this could be the reason, but you might want to make sure that your fields are Plain Text Only instead of Rich Text under Field Format.