Lagging Form

Avatar

20-01-2009

I have this form which basically serving the purpose of multiple forms.. probably like 20 or so.. When I made the initial it works quickly when I add the other to the file is becomes sluggish..



The XML view shows about 24,000 lines.. Not sure if that is causing it..



Is there something I can use to see what functions are triggering at runtime to help me figure out what is wrong?

Replies

Avatar

Avatar
Boost 500
Level 10
pguerett
Level 10

Likes

612 likes

Total Posts

7,689 posts

Correct reply

692 solutions
Top badges earned
Boost 500
Boost 50
Boost 5
Boost 3
Boost 250
View profile

Avatar
Boost 500
Level 10
pguerett
Level 10

Likes

612 likes

Total Posts

7,689 posts

Correct reply

692 solutions
Top badges earned
Boost 500
Boost 50
Boost 5
Boost 3
Boost 250
View profile
pguerett
Level 10

20-01-2009

24,000 lines soounds like a lot....is there a single line repeated over and over?



Avatar

Avatar
Level 2
foleyb77
Level 2

Likes

0 likes

Total Posts

24 posts

Correct reply

0 solutions
View profile

Avatar
Level 2
foleyb77
Level 2

Likes

0 likes

Total Posts

24 posts

Correct reply

0 solutions
View profile
foleyb77
Level 2

20-01-2009

I am having the same problem with a one page form, it has some simple scripting in it but it takes on average 5 to 7 seconds to tab to the next field in adobe reader and even in the preview through lcd. I had a huge array with over 5000 elements but after I removed that it still takes the same amount of time to tab between fields.

Avatar

Avatar
Level 2
foleyb77
Level 2

Likes

0 likes

Total Posts

24 posts

Correct reply

0 solutions
View profile

Avatar
Level 2
foleyb77
Level 2

Likes

0 likes

Total Posts

24 posts

Correct reply

0 solutions
View profile
foleyb77
Level 2

20-01-2009

I found the XML source option under the "View" menu. I have 10409 lines of code in my form, half of it is the big array.

Avatar

Avatar
Level 2
foleyb77
Level 2

Likes

0 likes

Total Posts

24 posts

Correct reply

0 solutions
View profile

Avatar
Level 2
foleyb77
Level 2

Likes

0 likes

Total Posts

24 posts

Correct reply

0 solutions
View profile
foleyb77
Level 2

20-01-2009

From the XML Source...<br /><br />I did find this one line of code that is repeated in every field between the border tags.<br /><br /><?templateDesigner StyleID aped2?><br /><br /><field name="DefCitizenship" w="38.1mm" h="10.876mm"><br /><ui><br /><textEdit hScrollPolicy="off"><br /><border><br /><?templateDesigner StyleID aped2?><br /></border>

Avatar

20-01-2009

No, all the lines are unique.. It's a multi-form.. so it has about 15 (subforms) in the form but the presence changes based on a dropdown list (invisible to visible). I could understand the original load was taking a little time but everytime I interact with any object it lags. Is there something I can do to test it out?



Thank in advance,

Avatar

Avatar
Level 2
foleyb77
Level 2

Likes

0 likes

Total Posts

24 posts

Correct reply

0 solutions
View profile

Avatar
Level 2
foleyb77
Level 2

Likes

0 likes

Total Posts

24 posts

Correct reply

0 solutions
View profile
foleyb77
Level 2

20-01-2009

Paul,



Could you tell me more about this repeating line.






Is this the reason for the lag between fields? If so how do I remove the cause?

Avatar

Avatar
Boost 500
Level 10
pguerett
Level 10

Likes

612 likes

Total Posts

7,689 posts

Correct reply

692 solutions
Top badges earned
Boost 500
Boost 50
Boost 5
Boost 3
Boost 250
View profile

Avatar
Boost 500
Level 10
pguerett
Level 10

Likes

612 likes

Total Posts

7,689 posts

Correct reply

692 solutions
Top badges earned
Boost 500
Boost 50
Boost 5
Boost 3
Boost 250
View profile
pguerett
Level 10

20-01-2009

Can you send the forms to livecycle8@gmail.com and I will have a look.

Avatar

12-02-2009

I had the same issue i.e. repeating


Once i manually deleted those repeating lines, my form went back to normal.



It seems like livecycle designer's bug to generate repeating lines.

Avatar

Avatar
Boost 500
Level 10
pguerett
Level 10

Likes

612 likes

Total Posts

7,689 posts

Correct reply

692 solutions
Top badges earned
Boost 500
Boost 50
Boost 5
Boost 3
Boost 250
View profile

Avatar
Boost 500
Level 10
pguerett
Level 10

Likes

612 likes

Total Posts

7,689 posts

Correct reply

692 solutions
Top badges earned
Boost 500
Boost 50
Boost 5
Boost 3
Boost 250
View profile
pguerett
Level 10

12-02-2009

It is a confirmed bug and will be fixed in a future release. Your corrective action of remove the lines is correct but in some cases there are too many to deal with. I have a style sheet that can be applied to delete all of those lines and all is OK again.