Highlighted

Lagging Form

Avatar

20-01-2009

I have this form which basically serving the purpose of multiple forms.. probably like 20 or so.. When I made the initial it works quickly when I add the other to the file is becomes sluggish..



The XML view shows about 24,000 lines.. Not sure if that is causing it..



Is there something I can use to see what functions are triggering at runtime to help me figure out what is wrong?

Replies

Highlighted

Avatar

Avatar

pguerett

Total Posts

(val/1000)?string[".0"]}K

Likes

611

Correct Answer

692

Avatar

pguerett

Total Posts

(val/1000)?string[".0"]}K

Likes

611

Correct Answer

692
pguerett

20-01-2009

24,000 lines soounds like a lot....is there a single line repeated over and over?



Highlighted

Avatar

Avatar

foleyb77

Avatar

foleyb77

foleyb77

20-01-2009

I am having the same problem with a one page form, it has some simple scripting in it but it takes on average 5 to 7 seconds to tab to the next field in adobe reader and even in the preview through lcd. I had a huge array with over 5000 elements but after I removed that it still takes the same amount of time to tab between fields.
Highlighted

Avatar

Avatar

foleyb77

Avatar

foleyb77

foleyb77

20-01-2009

I found the XML source option under the "View" menu. I have 10409 lines of code in my form, half of it is the big array.
Highlighted

Avatar

Avatar

foleyb77

Avatar

foleyb77

foleyb77

20-01-2009

From the XML Source...<br /><br />I did find this one line of code that is repeated in every field between the border tags.<br /><br /><?templateDesigner StyleID aped2?><br /><br /><field name="DefCitizenship" w="38.1mm" h="10.876mm"><br /><ui><br /><textEdit hScrollPolicy="off"><br /><border><br /><?templateDesigner StyleID aped2?><br /></border>
Highlighted

Avatar

20-01-2009

No, all the lines are unique.. It's a multi-form.. so it has about 15 (subforms) in the form but the presence changes based on a dropdown list (invisible to visible). I could understand the original load was taking a little time but everytime I interact with any object it lags. Is there something I can do to test it out?



Thank in advance,
Highlighted

Avatar

Avatar

foleyb77

Avatar

foleyb77

foleyb77

20-01-2009

Paul,



Could you tell me more about this repeating line.






Is this the reason for the lag between fields? If so how do I remove the cause?
Highlighted

Avatar

Avatar

pguerett

Total Posts

(val/1000)?string[".0"]}K

Likes

611

Correct Answer

692

Avatar

pguerett

Total Posts

(val/1000)?string[".0"]}K

Likes

611

Correct Answer

692
pguerett

20-01-2009

Can you send the forms to livecycle8@gmail.com and I will have a look.
Highlighted

Avatar

12-02-2009

I had the same issue i.e. repeating


Once i manually deleted those repeating lines, my form went back to normal.



It seems like livecycle designer's bug to generate repeating lines.
Highlighted

Avatar

Avatar

pguerett

Total Posts

(val/1000)?string[".0"]}K

Likes

611

Correct Answer

692

Avatar

pguerett

Total Posts

(val/1000)?string[".0"]}K

Likes

611

Correct Answer

692
pguerett

12-02-2009

It is a confirmed bug and will be fixed in a future release. Your corrective action of remove the lines is correct but in some cases there are too many to deal with. I have a style sheet that can be applied to delete all of those lines and all is OK again.