Highlighted

JBoss Starts but Stops Immediately

JoshDBoyle-DVzR

09-12-2008

All



I am trying to do a turnkey installation of LiveCycle 8.2.1 with JBoss yet when I run the Configuration Manager, and at the point at which JBoss gets started, the Configuration Manageer stops stating that it failed to start JBoss.



When I go into Windows Services and manually try to start JBoss, it starts but immediately stops.



Any ideas?

Replies

Highlighted

Mark_Lindberg

11-12-2008

Are you able to launch JBoss from the .bat file in the JBoss/Bin directory?

Try that, You may need to adjust the size parameters for JAVA_OPTS.

I have a laptop with 2 Gig of memory, and ended up with these settings;

set JAVA_OPTS=%JAVA_OPTS% -XX:PermSize=256m -XX:MaxPermSize=256m -XX:NewSize=250m -XX:MaxNewSize=250m -XX:SurvivorRatio=6 -Xms512m -Xmx512m.



Once you get JBoss to run from the .Bat file, you will need to apply the settings for PermSize, etc. to the JBoss service by editing the settings in your registry.



HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Services\JBoss for Adobe LiveCycle ES\Parameters



Good Luck

Mark
Highlighted

Avatar

Guest

22-01-2009

I had same exact problem. It was JDK version I was using. I uninstalled/reinstalled the service with different JDK and it worked.



Uninstall/Reinstall the service using the JBossInstallService.BAT inside JBOSS directory of installation. You will need to make a uninstall .bat file. Use the InstallJbossService.bat file, copy it, and change the parameter -install to -uninstall. That will uninstall service. Then make sure your JAVA_HOME is JDK that is compliant.