Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
BedrockMission!

Learn More

View all

Sign in to view all badges

upstream is using revision x

Avatar

Avatar
Boost 50
Level 5
joew68937582
Level 5

Likes

121 likes

Total Posts

7 posts

Correct Reply

0 solutions
Top badges earned
Boost 50
Boost 5
Boost 3
Boost 25
Boost 100
View profile

Avatar
Boost 50
Level 5
joew68937582
Level 5

Likes

121 likes

Total Posts

7 posts

Correct Reply

0 solutions
Top badges earned
Boost 50
Boost 5
Boost 3
Boost 25
Boost 100
View profile
joew68937582
Level 5

20-02-2019

I ran into some odd behavior today and wanted to report it as potentially needing a fix.

I created a new library and made sure I had it selected as my working library. I then added a second condition to an existing rule. When I clicked the "Save to Library and Build" button the build failed. The reason given was that revision x was already in the upstream. I checked the upstream and sure enough, the upstream contained revision x and my attempted build contained revision x (latest). I then looked at the rule and selected "Compare Revisions" in the left pane it showed revision x without my change, and in the right pane it showed latest with my change. At a loss I deleted the new condition from the rule, then recreated it and the build succeeded.

I needed to add the same condition to a second rule, and again ran into the same issue. This time I deleted the new condition and successfully rebuilt the library. I then added the condition a second time and the build succeeded.