Highlighted

User Sync Problem with Satisfied Component

Avatar

Avatar

Tom_Fought

Avatar

Tom_Fought

Tom_Fought

15-02-2018

I have 3 environments using User Synchronization.

2 of the environments are working normally.

The one that is not working appears to be due to the org.apache.sling.distribution.trigger.impl.ScheduledDistributionTriggerFactory component being in a Satisfied state, needs to be active. This component is active in the other 2 environments.

I am looking for some direction in determining why this is. What I know is the Reference resolverFactory and Reference scheduler are both Satisfied, however they do not have a Bound Service ID associated with them.

Reference resolverFactory["Satisfied","Service Name: org.apache.sling.api.resource.ResourceResolverFactory","Cardinality: 1..1","Policy: static","Policy Option: reluctant"]
Reference scheduler

["Satisfied","Service Name: org.apache.sling.commons.scheduler.Scheduler","Cardinality: 1..1","Policy: static","Policy Option: reluctant"]

Working environments look like this for the component:

Reference resolverFactory["Satisfied","Service Name: org.apache.sling.api.resource.ResourceResolverFactory","Cardinality: 1..1","Policy: static","Policy Option: reluctant","Bound Service ID 1497 (Apache Sling Resource Resolver Factory)"]
Reference scheduler["Satisfied","Service Name: org.apache.sling.commons.scheduler.Scheduler","Cardinality: 1..1","Policy: static","Policy Option: reluctant","Bound Service ID 1158

So my question is, how can I get the satisfied component to have References with a Bound Service ID?

Replies

Highlighted

Avatar

Avatar

smacdonald2008

Total Posts

12.7K

Likes

1.4K

Correct Answer

2.3K

Avatar

smacdonald2008

Total Posts

12.7K

Likes

1.4K

Correct Answer

2.3K
smacdonald2008

15-02-2018

Are all three versions the same AEM instance. Something has to explain the difference in how the bundle is behaving. There is a bundle missing from the instance where its not in active state. Looks like - Bound Service ID 1497

Highlighted

Avatar

Avatar

Tom_Fought

Avatar

Tom_Fought

Tom_Fought

15-02-2018

Thanks for replying Scott. There was an extra "(" in a configuration. Not sure how it got there, but there it is.