since ‎22-07-2014
‎24-01-2020
Tom_Fought
Level 2
What is the roadmap for AEM after AEM 6.5 Tom_Fought - Adobe Experience Manager
I have heard that AEM 6.5 is the last on-premise version of AEM. Future versions will be cloud based only. I haven't found anything on the Adobe site about this. Would any one be able to provide some info or links? Thanks.
2534
Views
0
Likes
1
Answers and Comments
Re: Inconsistent Rewriting of links /content/... into https://... off publishers Tom_Fought - Adobe Experience Manager
We had CSS causing the link rewriter to skip paths to be transformed.
1295
Views
0
Likes
0
Replies
Inconsistent Rewriting of links /content/... into https://... off publishers Tom_Fought - Adobe Experience Manager
I have a content path in our primary domain which is has /content/... paths not being rewritten properly when the page is being rendered off the publishers.The same content path can be rendered property or not on different pages.I have worked through the link checker options.If I disable rewriting in the Day CQ Link Checker Transformer then links for this content path always start with /content. Re-enabling the inconsistent behavior returns.I removed all Day CQ Link Checker Service special patte...
1384
Views
0
Likes
2
Replies
Moving a Forum Component within a template or to a new page Tom_Fought - Adobe Experience Manager
From our experience with Adobe Social, the social component path in the CRX is stored with the content in the Cloud. We have a need to move social components within a template on a page or within a template on an entirely new page.Is there a best practice to follow when attempting to move social Cloud content components within AEM?
478
Views
0
Likes
0
Replies
Re: PropertiesUtil.toMap not in uber-jar-6.5.0 Tom_Fought - Adobe Experience Manager
That fixed it! thanks.
616
Views
0
Likes
0
Answers
PropertiesUtil.toMap not in uber-jar-6.5.0 Tom_Fought - Adobe Experience Manager
I am upgrading our code base to use uber-jar-6.5.0.We have many references to PropertiesUtil.toMap, but that method is not in the jar.What am I missing?
670
Views
1
Like
2
Answers and Comments
Re: TouchUI component not updating on page when added, modified, or deleted Tom_Fought - Adobe Experience Manager
We are just starting to work with Touch UI and found this issue occurring. So no idea when it started in relation to any change.
3106
Views
0
Likes
4
Replies
Re: TouchUI component not updating on page when added, modified, or deleted Tom_Fought - Adobe Experience Manager
This has been marked "Assumed Answered" yet I still have the problem.Even though the OOTB AEM works as specified, my instance is not working and I am looking for leads to resolve the issue.When I discover the solution I will post it here.
3106
Views
0
Likes
1
Replies
Re: TouchUI component not updating on page when added, modified, or deleted Tom_Fought - Adobe Experience Manager
Thanks for further ideas on this.I created a clean 6.2 and 6.4 authoring environment. Loaded the touch ui component into the environments and proved the refresh works properly for add, delete, and modify. Guessing it must have something to do with our templates and possible jquery/javascript conflicts.
3106
Views
0
Likes
2
Replies
Re: TouchUI component not updating on page when added, modified, or deleted Tom_Fought - Adobe Experience Manager
Quick check with the OOTB text component and text/image component. Seeing same behavior.
3106
Views
0
Likes
2
Replies
TouchUI component not updating on page when added, modified, or deleted Tom_Fought - Adobe Experience Manager
Looking for some direction here.I have created a Touch UI component that works normally for editing the component properties, but:does not show up when I drag it onto the page, but it is there after page refreshdoes not disappear when I delete it from the page, but it is gone after page refreshdoes not update content on the page after modification, but the content is updated after a page refresh.What am I missing here?Thanks for your assistance.
3615
Views
0
Likes
13
Replies
PowerPoint media handler not invoked by workflow Tom_Fought - Adobe Experience Manager
AEM 6.2 SP1 CFP18I am uploading ".pps" files to the dam in the author. The file uploads fine and is accessible however an error is being generated:com.day.cq.dam.handler.standard.msoffice.MSOfficeHandler Failed to read metadata: nullcom.day.cq.workflow.compatibility.CQWorkflowProcessRunner Process execution resulted in an error: org.apache.poi.hpsf.wellknown.PropertyIDMap.(IF)VIn the docs, there is a PowerPoint media handler. It may have been run, I am curious why msofficehandler was invoked.See...
372
Views
0
Likes
0
Answers and Comments
Re: Custom LiveAction NPE when processing page with deleted component Tom_Fought - Adobe Experience Manager
Find out anything Scott?
615
Views
0
Likes
0
Answers
Custom LiveAction NPE when processing page with deleted component Tom_Fought - Adobe Experience Manager
I have gotten no help from Adobe Tech Support on this issue. They are pushing me off to Adobe Consulting.We have a simple custom LiveAction that works fine when components are added and pages are rolled out.If you delete a component and roll out the page an NPE is generated. Looking at the stack trace it appears to happen in Adobe code. See below.But Adobe Tech Support says it is in our custom code.If I totally gut the custom Live Action and implement methods with well know return values and exe...
878
Views
0
Likes
3
Answers and Comments
Call OOTB liveactions from a custom liveaction Tom_Fought - Adobe Experience Manager
Is it possible to invoke OOTB liveactions, such as contentUpdate, from a custom liveaction.We have a requirement to filter the creation of livecopies based on tagging and language translation.Is this possible?Thanks
467
Views
0
Likes
2
Answers and Comments
Disable/Remove Rollout Page and all sub-pages Tom_Fought - Adobe Experience Manager
We want to temporarily disable the Rollout page and sub-pages from the rollout dialog. This shows up in 2 places.Has anyone done this before and can provide direction? I haven't been able to locate the dialog in /libs.ThanksTom
1063
Views
0
Likes
1
Answers and Comments
Re: Publisher copied from another environment has some author presentation Tom_Fought - Adobe Experience Manager
Can't be sure. I haven't seen that documentation.I know that the system support team did the backup and restore for me.I just tried starting up the hot backup for the publisher in the original environment and the publisher is acting normally.In the destination environment it is not acting normally.
605
Views
0
Likes
0
Answers
Re: Publisher copied from another environment has some author presentation Tom_Fought - Adobe Experience Manager
Just to add, this happens on every page.
603
Views
0
Likes
0
Answers
Publisher copied from another environment has some author presentation Tom_Fought - Adobe Experience Manager
Looking to see if anyone else has had this problem. I copied a publisher hot backup from one environment to another.Started up the publisher, verified the run modes are actually set for publisher through /system/console/status-slingsettingsI have 2 components that are showing up with dashed lines like they can be edited but they can not be edited.Also the sidekick is appearing.I see this in the html for the page and I don't know how or why it is being included. I was looking through the felix co...
985
Views
0
Likes
3
Answers and Comments
Re: User Sync Problem with Satisfied Component Tom_Fought - Adobe Experience Manager
Thanks for replying Scott. There was an extra "(" in a configuration. Not sure how it got there, but there it is.
893
Views
0
Likes
0
Replies
User Sync Problem with Satisfied Component Tom_Fought - Adobe Experience Manager
I have 3 environments using User Synchronization.2 of the environments are working normally.The one that is not working appears to be due to the org.apache.sling.distribution.trigger.impl.ScheduledDistributionTriggerFactory component being in a Satisfied state, needs to be active. This component is active in the other 2 environments.I am looking for some direction in determining why this is. What I know is the Reference resolverFactory and Reference scheduler are both Satisfied, however they do ...
1109
Views
0
Likes
2
Replies
Re: @Reference annotation not working Tom_Fought - Adobe Experience Manager
Thanks for all your assistance. This has help significantly!
927
Views
1
Like
0
Answers
Re: @Reference annotation not working Tom_Fought - Adobe Experience Manager
I have taken the time to work the ReadServiceImpl code directly into the event listener for additional testing. Adding the ResourceResolverFactory injection successfully into the listener with that test.FormSubmitEventListener Class which calls ReadServiceImpl=====================================================================================package org.oclc.cq.listeners;import org.apache.felix.scr.annotations.*;import org.apache.sling.api.resource.Resource;import org.apache.sling.api.resource....
823
Views
0
Likes
0
Answers
Re: How to add Spell Check to RTE used for Social Forum component? Tom_Fought - Adobe Experience Manager
Please provide some direction on finding the forum component RTE in the CRX. It is not down the path in the article and I have been unable to locate it /libs/social.Thanks
612
Views
0
Likes
0
Answers
Re: @Reference annotation not working Tom_Fought - Adobe Experience Manager
I have logging setup in all related classes. I know I am accessing the my class. No need for debugger in that regard.Yes. I am utilizing the class from within a TestComponentImpl method.
792
Views
0
Likes
0
Answers
Re: @Reference annotation not working Tom_Fought - Adobe Experience Manager
One curiosity I discovered, I added an activate method and logged the resource resolver in the activate and it appeared non-null.In the same test, the value for the resource resolver in the main method was null. Not sure what to make of that.
875
Views
0
Likes
0
Answers
Re: @Reference annotation not working Tom_Fought - Adobe Experience Manager
I started to, but there are dependencies that are not satisfied for our primary bundle. So at the moment I have suspended that approach.
787
Views
0
Likes
0
Answers
How to add Spell Check to RTE used for Social Forum component? Tom_Fought - Adobe Experience Manager
Is there a way to add spell checking to the RTE for social forum component?Thanks
767
Views
0
Likes
3
Answers and Comments
Re: @Reference annotation not working Tom_Fought - Adobe Experience Manager
Can you give me an idea of what you are looking for in the logs?
796
Views
0
Likes
0
Answers
Re: @Reference annotation not working Tom_Fought - Adobe Experience Manager
Yes. The component status is active and the resource resolver factory is satisfied.Reference resolverFactory["Satisfied","Service Name: org.apache.sling.api.resource.ResourceResolverFactory","Cardinality: 1..1","Policy: static","Policy Option: reluctant","Bound Service ID 981 (Apache Sling Resource Resolver Factory)"]
787
Views
0
Likes
0
Answers