Expand my Community achievements bar.

Applications for the 2024-2025 Adobe Experience Manager Champion Program are open!

Upgrade SLF4J API Bundle version from 1.7.32 to 2.0.0 or higher version

Avatar

Level 2

I would like to install pdfservices-sdk-4.0.0.jar in my local AEM instance and it is asking to upgrade slf4j api to 2.0.0 version or higher. I tried to install/upgrade the slf4j-api bundle from slf4j-api-1.7.32.jar to slf4j-api-2.0.9.jar in my AEM system/console. But it is unable to upgrade the version and other bundles are having dependency with the 1.7.32 version. Because of this it is breaking the environment. 

 

Is there any solution to upgrade the bundle with higher version and all other bundles will refer to the newer version of slf4j api.

 

Or is it a good idea to make use/copy paste the available classes from pdfservices-sdk-4.0.0.jar into our maven project so that we can skip the use of dependency into our custom project.

Appreciate your suggestions. Thanks!!!

6 Replies

Avatar

Community Advisor

can you try with lower version of PDF services SDK - which is compatible with slf4j version

 

like pdfservices-sdk-3.5.1.jar is good with slf4j 1.7.26

Avatar

Level 2

Tried this approach by uploading the necessary dependency bundles and pdfservices-sdk-3.5.1.jar bundle came to active state but i think we have limited functionalities available in pdfservices-sdk-3.5.1.jar bundle compared to higher version of it.

Avatar

Community Advisor

Hi @Minion_J 

It is not recommended to upgrade the version of a bundle that has dependencies on other bundles, as it can break the environment. Instead, you can try to install the newer version of the slf4j-api bundle as a separate bundle and update the dependencies of the pdfservices-sdk-4.0.0.jar to use the newer version of the slf4j-api bundle.

  1. Download the slf4j-api-2.0.9.jar file and place it in the crx-quickstart/install folder of your AEM instance Locally.

  2. In the AEM system/console, go to the "Bundles" tab and find the newly installed slf4j-api-2.0.9.jar bundle.

  3. Note the bundle ID of the slf4j-api-2.0.9.jar bundle.

  4. In the AEM system/console, go to the "Configuration" tab and find the configuration for the pdfservices-sdk-4.0.0.jar bundle.

  5. Edit the configuration and update the "Imported Packages" section to include the newer version of the slf4j-api bundle.
     For example, you can add 

    org.slf4j;version="[2.0,3)"

    This will tell the pdfservices-sdk-4.0.0.jar bundle to use any version of the slf4j-api bundle that is 2.0 or higher, but less than 3.0.

  6. Save the configuration and restart the pdfservices-sdk-4.0.0.jar bundle.



Avatar

Level 2

Tried this approach it is breaking the AEM instance in the similar way of how I tried earlier of installing the bundle in system/console.

Avatar

Administrator

@Minion_J Did you find the suggestions from users helpful? Please let us know if more information is required. Otherwise, please mark the answer as correct for posterity. If you have found out solution yourself, please share it with the community.



Kautuk Sahni

Avatar

Level 2

Due to lower version of slf4j 1.7.26 bundle dependencies with AEM environment I was unable to make use of pdfservices-sdk-4.0.0.jar.

 

Instead, Adobe has suggested to use AEM Forms package which provide us PDF Generator service to convert the non-PDF documents into PDF documents.

 

https://experienceleague.adobe.com/docs/experience-manager-65/content/forms/use-document-services/ae...