Highlighted

The contextHub option in the toolbar is not available when selecting preview mode on the page

shwetakhatana

09-01-2019

I am using personalization on a page of my custom website having experience fragments, so i did all the process to achieve personalization, did targeting on that page, but after finishing targeting, when i am clicking on the preview mode, the contexthub option on the top left corner is not present to test the targeting applied on that page.

1663606_pastedImage_0.png

Replies

Highlighted

shwetakhatana

09-01-2019

Hi scott, I am practicing this on aem 6.4 and i have followed this article several times and it works well with we-retail, i dnt have any issue with it. But when i am using any other project other then that, first of all i am not getting the targeting mode (I have added the segments path(/conf/xelhire/settings/wcm/segments) and contexthub path (/libs/settings/cloudsettings/legacy/contexthub) for the project in the sites console so the mode is visible after adding them), secondly after targeting when i want to test the personalization I dont get the contexthub option at the top of the page on Preview mode so i am not able to see the persona,location option that comes on clicking the contexthub option.

So basically i am stuck on testing my personalization now.

Also I have tried downloading and installing the packages for the summit toys project that u referred in the issueContexthub Tool bar issue in AEM 6.3  ​, when I open the summit toys site also the targeting mode does not appear (see the screenshot below), which might be followed by the issue of contexthub option not coming as well just like i am facing currently. targeting mode not coming might be because the contexhub path is set to /etc/cloudsettings/default/contexthub (which might not be correct as there is no default under etc/cloudsettings).

1664206_pastedImage_1.png