Expand my Community achievements bar.

Enhance your AEM Assets & Boost Your Development: [AEM Gems | June 19, 2024] Improving the Developer Experience with New APIs and Events
SOLVED

The analyser found the following errors for author and publish, aemanalyser-maven-plugin

Avatar

Level 7

I am getting a strange error under aemanalyser-maven-plugin. I have ran my maven build tool with -X, and I found only 1 unuseful comment:

[api-regions-exportsimports] importing package(s) com.mywebsite.core.models.test in start level 21 but no bundle is exporting these for that start level.
What in the world is happening?

1 Accepted Solution

Avatar

Correct answer by
Employee Advisor

Ok,

Can you check if your bundle is included in the container (all) package?

Also, what is the version of the archetype and aem-analyser-plugin? You can check with the latest plugin version 

 

View solution in original post

5 Replies

Avatar

Employee Advisor

Hi @AEMWizard ,

 

You get this error when the plugin detects that your jar is unavailable during runtime (same as cloud manager), you need to embed this in your project.

This means your compilation would be successful but during the runtime, your code will not be able to find this bundle because it is not present in your bundle list.

 

Looks like related to this:-

https://experienceleaguecommunities.adobe.com/t5/adobe-experience-manager/getting-error-while-buildi... 

 

If you are trying to embed third party jar, then you can refer to this article

https://myaemlearnings.blogspot.com/2021/08/embedding-third-party-dependencyosgi.html 

 

Hope that helps!

 

Regards,

Nitesh

Avatar

Level 7

@nitesh_kumar , thanks for the reply, but this is an internal class, just a simple model interface, with the impementation in > internal/model/myClassImpl.

 

It's so odd how this error is being thrown.

Avatar

Correct answer by
Employee Advisor

Ok,

Can you check if your bundle is included in the container (all) package?

Also, what is the version of the archetype and aem-analyser-plugin? You can check with the latest plugin version 

 

Avatar

Level 1

Hello, did you solve this issue?, I'm having a similar error.