Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

SOLVED

Tagging issue in AEM 6.4

Avatar

Level 2

Hi All,

We have migrated 6.2 to 6.4. As we all know Tag folder structure in 6.2 is etc/tags where else in 6.4 it should store in content/cq:tags. When i try to create tags in 6.4, it is not falling under content folder. Instead it is still falling under etc/tags.

Thanks in advance. kindly let us know, what we are missing here.

NOTE: using acs-commons 3.9.0 and service pack 6.4.2

Let me know in case of any additional information required.

1 Accepted Solution

Avatar

Correct answer by
Level 3

Hi rajkumark10

Tag Manager API Supports either older location (/etc/tags) or newer location at a time. At the start of the component, It detects if this is an upgraded system i.e. /etc/tags exists. Then the TagManager runs in BC mode, i.e. it uses /etc/tags as base path, If not, it uses new location '/content/cq:tags'. In BC mode, TagManager (tag pickers) shows the tags from /etc/tags and not from /content/cq:tags.

To make TagManager to use new location (i.e. /content/cq:tags.) the system should not have tags under /etc/tags.

In case of upgraded instances where tags are present under old location (i.e. '/etc/tags') are supported by tagmanager API and classic/touch UI. Once references to old tag base path (i.e. '/etc/tags') are replaced by using tagId or new tag location (i.e. "/content/cq:tags"), you can move tags to the new location (i.e. '/content/cq:tags') in CRX followed by component restart.Also, may I know why are you still creating tags under /etc/ and not in /content? I would suggest you to migrate your old tags to the new location and also create new tags using the new location only.

View solution in original post

8 Replies

Avatar

Level 10

When you create a tag in AEM 6.4 - you see the path in which the tag is stored.

ATag.png

Here you see the proper path:

ATag1.png

If you are not seeing tags stored in the path - that is specified in Tag Path when you create the tag, there is an issue with your AEM instance. As this is not a fresh AEM 6.4 instance - but rather an upgraded server - i am wondering if there is an upgrade bug responsible for this behavior. 

Avatar

Level 2

Hi,

Thanks for the update. Here is what happening. I am trying in my local, where i have started an new instance and try to launch

http://localhost:4502/aem/tags but it is redirecting to below URL. it clearly states that, it is creating under etc/tags.

http://localhost:4502/libs/cq/tagging/gui/content/tags.html/etc/tags 

I tried giving Tag Path, still it is not created under that path. Please help me with this.

Avatar

Correct answer by
Level 3

Hi rajkumark10

Tag Manager API Supports either older location (/etc/tags) or newer location at a time. At the start of the component, It detects if this is an upgraded system i.e. /etc/tags exists. Then the TagManager runs in BC mode, i.e. it uses /etc/tags as base path, If not, it uses new location '/content/cq:tags'. In BC mode, TagManager (tag pickers) shows the tags from /etc/tags and not from /content/cq:tags.

To make TagManager to use new location (i.e. /content/cq:tags.) the system should not have tags under /etc/tags.

In case of upgraded instances where tags are present under old location (i.e. '/etc/tags') are supported by tagmanager API and classic/touch UI. Once references to old tag base path (i.e. '/etc/tags') are replaced by using tagId or new tag location (i.e. "/content/cq:tags"), you can move tags to the new location (i.e. '/content/cq:tags') in CRX followed by component restart.Also, may I know why are you still creating tags under /etc/ and not in /content? I would suggest you to migrate your old tags to the new location and also create new tags using the new location only.

Avatar

Level 2

Hi vaibhavsharma

Thanks for the input, We have tried both the way mentioned below and still it is not working. I have given details below what i have followed. Please let me know what i am missing.

1. Creating tag with Tag path "Content/cq:tags", But it is creating tag under etc/tags only

2. Deleted/Removed all nodes under etc/tags and tried to create tags, it is not giving any error and also it is not creating any tags under content/cq:tags.

Kindly help me, what i am missing here.

Avatar

Level 2

Hi vaibhavsharma​ and smacdonald2008

Both of your inputs helped me a lot. Found the root cause of the above issue. It is because, In some place old etc/tags path has been configured in code. I have tried starting new instance without our code and it is working as you both explained above

once again thank you for quick response

Avatar

Level 4

Hi, I am facing the same issue. I have an AEM 6.5 instance. I can see tags coming from /etc/tags instead of /content/cq:tags. I rename /etc/tags to /etc/tags1 still tagging UI doesn't start picking tags from content and it shows all blank screen even though I have lot of tags under /content/cq:tags.

I need the tagging to work with /content/cq:tags because I am planning to translate the tags and only in /content/cq:tags I can add languages property because this property is not allowed on /etc/tags.

Can you suggest something on this.

Avatar

Level 6

I am also facing this issue.

1. moved tags from /etc/tags to /content/cq:tags

2. restarted tagging bundle

but still I see tag picker not picking tags form /content/cq:tags and tag console is not showing any tags