Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

Strange error sometimes after install a large package (embedded ACS common)

John_Ky
Level 2
Level 2

Hi,

Any body got this issue(attached image) when go to localhost:4502/editor.html/somepage

5 Replies
stevec2515680
Level 4
Level 4

This means that something that was included in the package is broken. Could be anything. For example - you may have errors in the Java logic of the OSGi bundle. You need to post the log file. That will provide more information about what is wrong. 

kautuk_sahni
Community Manager
Community Manager

Hi 

This could be the case that something that got missing or broken while creating a package or while installing.

But to debug this in detail, please share the the AEM error.log (500 is server side problem, so you can not get much of the information at browser console, so please share the server error log).

Thanks and Regards

Kautuk Sahni

John_Ky
Level 2
Level 2

Thanks Steve Cavekautuksahni

The strange is that if I install only my package or only acs-aem-commons-content-3.1.0.zip, the system will be OK. 

But when I install my package and then install acs-aem-commons-content-3.1.0.zip (order of installation doesn't impact) then the issue happened.

Or If I embed the acs-aem-commons-content-3.1.0.zip in my package, error also happen.

Note: The issue is on AEM 6.2 with acs-aem 3.1

(AEM 6.1 with acs-aem 2.x works well).

John_Ky
Level 2
Level 2

Hi,

The issue can be resolved for now. Please refer the following link:

https://github.com/Adobe-Consulting-Services/acs-aem-commons/issues/739

"""

@thanhnk it sounds like you need to increase the "Number of Calls per Request" property of the Sling Main Servlet. This can happen if your project is especially large. It could just be that the component added by ACS AEM Commons pushes you over the default limit.