Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

SOLVED

problem with vault plugin on CQ 5.4

Avatar

Level 2

Hi, I need to exclude from the package some resources with a specific prefix (test). In the pom.xml I tried with:

 

<filters>
     <filter>                      

            /etc/workflow/launcher/config/test*

    </filter>

</filters>

 

but it was wrong.

What's the way?

Thanks

1 Accepted Solution

Avatar

Correct answer by
Level 5

Hello,

For that you have to do something like in your /META-INF/vault/filter.xml,

<filter root="/etc/workflow/launcher/config">

       <exclude pattern="/etc/workflow/launcher/config/test"/>

    </filter>

And

<f1

            jcr:primaryType="nt:unstructured"

             root="/etc/workflow/launcher/config"

            rules="[exclude:/etc/workflow/launcher/config/test]"/>

in your /META-INF/vault/definition/.content.xml

Yogesh

View solution in original post

0 Replies

Avatar

Correct answer by
Level 5

Hello,

For that you have to do something like in your /META-INF/vault/filter.xml,

<filter root="/etc/workflow/launcher/config">

       <exclude pattern="/etc/workflow/launcher/config/test"/>

    </filter>

And

<f1

            jcr:primaryType="nt:unstructured"

             root="/etc/workflow/launcher/config"

            rules="[exclude:/etc/workflow/launcher/config/test]"/>

in your /META-INF/vault/definition/.content.xml

Yogesh

Avatar

Level 2

Hi!

In this case:

<?xml version="1.0" encoding="UTF-8"?>
<workspaceFilter version="1.0">
    <filter root="/apps/xxx-cms" />
    <filter root="/etc/designs/xxx-cms" />
    <filter root="/etc/workflow/launcher/config">
        <include pattern="/etc/workflow/launcher/config/ecom_.*" />
    </filter>
    <filter root="/etc/workflow/models/xxx" />
    <filter root="/etc/workflow/scripts/xxx" />
</workspaceFilter>

only files that start with ecom_ prefix should be deployed in CRX but it doesn't work (other files are deployed with a different prefix). What's the right pattern in this case?

 

Thanks