Expand my Community achievements bar.

Dive into Adobe Summit 2024! Explore curated list of AEM sessions & labs, register, connect with experts, ask questions, engage, and share insights. Don't miss the excitement.
SOLVED

page.js:387 Uncaught ReferenceError: _ is not defined

Avatar

Level 6

Hi,

We have migrated AEM Version from 6.3 to 6.5 SP10.

It was fine in DEV environment.

But When we deployed to Higher environment, we are getting below error in author whenever we will open page in edit mode.

The same error is coming in all the pages including we retail pages as well.

Path: /libs/cq/gui/components/authoring/editors/clientlibs/sites/page

 

page.js:387 Uncaught ReferenceError: _ is not defined
at page.js:387:339

akhilr48142671_0-1647869986623.png

Can someone please help. It is environment specific,.

1 Accepted Solution

Avatar

Correct answer by
Community Advisor

Hi @akhilraj 

 

I have 6.5.10 in my machine it is working perfectly fine for me.

  • By any chance are you overwriting anything under /libs?
  • Can you check again in a fresh instance?

Thanks

View solution in original post

4 Replies

Avatar

Correct answer by
Community Advisor

Hi @akhilraj 

 

I have 6.5.10 in my machine it is working perfectly fine for me.

  • By any chance are you overwriting anything under /libs?
  • Can you check again in a fresh instance?

Thanks

Avatar

Level 6

Thanks Jeevan.

Issue was with upgrade only, we tried in fresh instance and it is working fine.

 

Avatar

Employee Advisor

Tried to replicate with minification but didn't get this issue with my local AEM 6.5.10(we.retail).

No error message, with and without minification.