Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

Not able to Activate any content using activate later

nikunjk71293848
Level 3
Level 3

Hi,

Activate later functionality for activating my content doesn't seem to work. I have used the same in one of my custom workflow and the result is same. Content is not activated with future date.

 

Error stack trace that is populated is:

10.08.2016 13:15:02.140 *ERROR* [JobHandler: /etc/workflow/instances/2016-08-10/model_12114258102655171:/content/cpw/en_GB/home/products/philips/shb-3060-wireless-headphones] com.day.cq.replication.Agent.publish5 Error while building replication content com.day.cq.replication.ReplicationException: Version 1.25 not found for path /content/cpw/en_GB/home/products/philips/shb-3060-wireless-headphones
10.08.2016 13:15:02.140 *ERROR* [JobHandler: /etc/workflow/instances/2016-08-10/model_12114258102655171:/content/cpw/en_GB/home/products/philips/shb-3060-wireless-headphones] com.day.cq.replication.impl.ReplicatorImpl Error while building replication content.
com.day.cq.replication.ReplicationException: Version 1.25 not found for path /content/cpw/en_GB/home/products/philips/shb-3060-wireless-headphones
    at com.day.cq.replication.impl.content.durbo.DurboContentBuilder.create(DurboContentBuilder.java:295)
    at com.day.cq.replication.impl.content.durbo.DurboContentBuilder.create(DurboContentBuilder.java:140)
    at com.day.cq.replication.impl.ServiceTrackerImpl$ContentBuilderWrapper.create(ServiceTrackerImpl.java:250)
    at com.day.cq.replication.impl.AgentImpl.buildContent(AgentImpl.java:348)
    at com.day.cq.replication.impl.AgentImpl.buildContent(AgentImpl.java:324)
    at com.day.cq.replication.impl.ReplicatorImpl.buildContents(ReplicatorImpl.java:498)
    at com.day.cq.replication.impl.ReplicatorImpl.replicate(ReplicatorImpl.java:376)
    at com.day.cq.wcm.workflow.process.ReplicatePageProcess.execute(ReplicatePageProcess.java:191)
    at com.day.cq.workflow.compatibility.CQWorkflowProcessRunner.execute(CQWorkflowProcessRunner.java:93)
    at com.adobe.granite.workflow.core.job.HandlerBase.executeProcess(HandlerBase.java:215)
    at com.adobe.granite.workflow.core.job.JobHandler.process(JobHandler.java:145)
    at org.apache.sling.event.jobs.JobUtil$1.run(JobUtil.java:366)
    at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142)
    at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617)
    at java.lang.Thread.run(Thread.java:745)

 

Process used in custom workflow is:

com.day.cq.wcm.workflow.process.ActivatePageProcess

 

AEM version used: AEM 6.0 sp2

Pre-requisite: Made sure admin access is used.

 

Please help me with both: Out of the box activate later functionality as well as with process com.day.cq.wcm.workflow.process.ActivatePageProcess 

0 Replies
smacdonald2008
Level 10
Level 10

Can you activate content from siteadmin? 

antoniom5495929
Level 7
Level 7

If the standard activation works, have you try to use the on / off property?

nikunjk71293848
Level 3
Level 3

Can you please elaborate more on on/off property.

Are you talking about following page property- "Check if approval needed for actiavtion"? If yes, then yes this switch was enabled.

nikunjk71293848
Level 3
Level 3

Hi,

I have tried using on/off property as well. But due to some reason on property deactivates already activated page till the specified on time. 

 

Scenario: I have one abc.html which is already activated, i have modified this page and then specified on time for 10mins later. After activating this page; in between those 10mins, page remains deactivated and then again activates back after specified on time.

Please help

antoniom5495929
Level 7
Level 7

Hi,

the behaviour is correct, just because the on off property are used to determine when the page could be available. So, if the on time is "in the future" and the page is already activated, it is deactivated and re-activated at the on time.

What you can try is to put the ON property value "on the past". Even if when i've time i can check you workflow in order to understand where is the problem related to Acitvate/deactivate later functionality.

antoniom5495929
Level 7
Level 7
        I mean the page properties that could be use to schedule the activation or deactivation of it. Refer to this page: https://docs.adobe.com/docs/en/aem/6-0/author/page-authoring/editing-page-properties.html
nikunjk71293848
Level 3
Level 3

Thanks, that seems to be working for me.

However that has fixed my out of the box activate later issue. I still need help for custom workflow which makes use of Activate Page/Asset component. (Process: com.day.cq.wcm.workflow.process.ActivatePageProcess) I can still observe same error in my stack trace.

antoniom5495929
Level 7
Level 7
        Could you attach the workflow that you are using?
nikunjk71293848
Level 3
Level 3

I am using attached workflow (attaching image as zip is not supported). And the process fails in extreme left split, after check product rollout pages.

nikunjk71293848
Level 3
Level 3

In addition to above workflow, i have also tried using basic workflow ie just by addition of activate page component (please refer image below); but due to some reason this workflow also doesn't seem to work.