Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

[AEM Gems Webinar] Accelerating Experience Manager as a Cloud Service development with Rapid Development Environments
Adobe Summit 2023 | Complete list of AEM Sessions & Labs
SOLVED

Move page wizard sometimes fails with error message

Avatar

Level 5

hi folks,

Sometimes the  move page wizard fails ( usually when we change the page name and URL while staying in the same part of containment tree.)

There is a spinner for a while, then there is a dialog that says "failed to load".

This is an intermittent problem, many times it works fine.

 

I've looked in the logs when the error occurs and the only ERROR message I can see is the following

 

GET /content/versionhistory.thumb.48.48.png HTTP /1.1 ] org.apache.jsp.libs.cq.Page.thumb_png_jsp resource has no content . path=/content/versionhistory.thumb.48.48.png referrer is null

 

Does this mean anything ?

 

thanks

Fiona

 

 

1 Accepted Solution

Avatar

Correct answer by
Employee

 

There are some known issue reported to our engineering wherein moving the page in the same folder does not work in touch UI [next button is inactive].

 

Engineering team has fixed the issue in 6.5.4(CQ-4282307 | Page Move and Rename not working in Touch UI for a large set of content) via internal JIRA IDs CQ-4282943, CQ-4282307.

 

As a workaround, you can increase the size property of /libs/wcm/core/content/sites/movepagewizard/destination/field from 40 to 2000 and test this in a lower environment.

View solution in original post

2 Replies

Avatar

Correct answer by
Employee

 

There are some known issue reported to our engineering wherein moving the page in the same folder does not work in touch UI [next button is inactive].

 

Engineering team has fixed the issue in 6.5.4(CQ-4282307 | Page Move and Rename not working in Touch UI for a large set of content) via internal JIRA IDs CQ-4282943, CQ-4282307.

 

As a workaround, you can increase the size property of /libs/wcm/core/content/sites/movepagewizard/destination/field from 40 to 2000 and test this in a lower environment.

Avatar

Level 5
Thanks. I will try that as soon as I can. How do I change that size value though ? thanks Fiona

Avatar

Employee

You can overlay the node /libs/wcm/core/content/sites/movepagewizard/destination/field and update the "size" property to 2000.

 

Capture.JPG

Avatar

Level 4

Hi @fionas76543059 

 

Was facing same error in log while moving page 

 

GET /content/versionhistory.thumb.48.48.png HTTP /1.1 ] org.apache.jsp.libs.cq.Page.thumb_png_jsp resource has no content . path=/content/versionhistory.thumb.48.48.png referrer is null

 

and saw that /content/versionhistory empty node was there and as per https://helpx.adobe.com/experience-manager/6-3/sites/developing/using/pagediff.html versions as of AEM 6.3.3.2, versions are being stored in /tmp/versionhistory folder.

Deleted /content/versionhistory node and exception is not coming.

 

 

Avatar

Level 5
Thanks. Our customer is using the old "classic" Move pages now as he thinks it is better.