Unable to move(rename) asset in same folder in AEM

Avatar

Avatar
Validate 1
Level 2
saibul
Level 2

Likes

6 likes

Total Posts

52 posts

Correct reply

3 solutions
Top badges earned
Validate 1
Ignite 1
Give Back
Boost 5
Boost 3
View profile

Avatar
Validate 1
Level 2
saibul
Level 2

Likes

6 likes

Total Posts

52 posts

Correct reply

3 solutions
Top badges earned
Validate 1
Ignite 1
Give Back
Boost 5
Boost 3
View profile
saibul
Level 2

15-06-2020

Unable to move(rename) asset to the same folder, the move button is disabled when I select the same folder as destination. It is working when I try to move to another folder but the filename is not changing what I had given in the "Title after move" and "Name after move" fields.

 

Server Details

OS: RHEL 7.6 (Maipo)
Server: AEM-6.5.1 SP-6.5.1
Oak: 1.10.2
Dispatcher: build 4.2.3/apache2.4-linux-x86-64

Accepted Solutions (1)

Accepted Solutions (1)

Avatar

Avatar
Affirm 50
MVP
Vaibhavi
MVP

Likes

216 likes

Total Posts

181 posts

Correct reply

61 solutions
Top badges earned
Affirm 50
Validate 1
Ignite 1
Give Back 5
Give Back 3
View profile

Avatar
Affirm 50
MVP
Vaibhavi
MVP

Likes

216 likes

Total Posts

181 posts

Correct reply

61 solutions
Top badges earned
Affirm 50
Validate 1
Ignite 1
Give Back 5
Give Back 3
View profile
Vaibhavi
MVP

15-06-2020

Hi @saibul 

Move functionality within same folder doesn't  allow. It is a known issue. 

You can go with below work around 

  • Navigate to the path in crx
  • Copy n paste to required destination
  • Change the title by editing the node property to required one. 

Answers (3)

Answers (3)

Avatar

Avatar
Validate 1
MVP
Theo_Pendle
MVP

Likes

238 likes

Total Posts

251 posts

Correct reply

105 solutions
Top badges earned
Validate 1
Ignite 5
Ignite 3
Ignite 10
Ignite 1
View profile

Avatar
Validate 1
MVP
Theo_Pendle
MVP

Likes

238 likes

Total Posts

251 posts

Correct reply

105 solutions
Top badges earned
Validate 1
Ignite 5
Ignite 3
Ignite 10
Ignite 1
View profile
Theo_Pendle
MVP

15-06-2020

Hi @saibul,

The answer is to install AEM 6.5 SP 5. You can see this issue has been solved by reading the release notes here: https://docs.adobe.com/content/help/en/experience-manager-65/release-notes/service-pack/sp-release-n...

Here is the relevant section:

When you use the Move command to rename an Experience Manager Sites page, the page title is not updated (NPR-33264).

Hope that helps 🙂

Avatar

Avatar
Give Back 5
Employee
vanegi
Employee

Likes

392 likes

Total Posts

378 posts

Correct reply

148 solutions
Top badges earned
Give Back 5
Give Back 3
Give Back 10
Give Back
Boost 50
View profile

Avatar
Give Back 5
Employee
vanegi
Employee

Likes

392 likes

Total Posts

378 posts

Correct reply

148 solutions
Top badges earned
Give Back 5
Give Back 3
Give Back 10
Give Back
Boost 50
View profile
vanegi
Employee

15-06-2020

This is a known issue reported to our engineering team (CQ-4282307 | Page Move and Rename not working in Touch UI for a large set of content) via internal JIRA IDs CQ-4282943 wherein moving the page in the same folder does not work in touch UI [next button is inactive].

 

Engineering has fixed the issue in 6.5.4 version already. As a temporarily workaround, you can increase the size property of /libs/wcm/core/content/sites/movepagewizard/destination/field from 40 to 2000, you can try the same on a lower environment & test thoroughly.

 

 

Avatar

Avatar
Contributor
Employee
hamidk92094312
Employee

Likes

103 likes

Total Posts

240 posts

Correct reply

38 solutions
Top badges earned
Contributor
Shape 1
Ignite 1
Give Back 50
Give Back 5
View profile

Avatar
Contributor
Employee
hamidk92094312
Employee

Likes

103 likes

Total Posts

240 posts

Correct reply

38 solutions
Top badges earned
Contributor
Shape 1
Ignite 1
Give Back 50
Give Back 5
View profile
hamidk92094312
Employee

15-06-2020

There are some known issue with Move feature so can you install the latest service pack and try ? I am able to move and rename without any issues in 6.5.4