Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

logs not getting updated when running AEM inside windows

Avatar

Level 7

as above.

So it's my first time using Windows as a local development machine. I've always used Macs before my latest role. But my issue is that none of the files inside /crx-quickstart/log is getting updated.

as an example:

 

        if I open up a page for editing, the cmd.exe will be very busy with logging. But if I check the files inside /log, none of them has increased in size. When using AEM inside a Mac, I know access.log and error.log will be very busy getting updates.

 

Any ideas on what's happening? Thanks

 

--------

 

Things I tried:

 

  1. I tried running java -Xmx4096m -jar cq-author-p4502.jar
  2. I tried using the start scripts inside crx-quickstart/bin
  3. I tried numbers 1 and 2 but using cmd.exe (run-as admin)
  4. I tried numbers 1 and 2 but using powershell (run-as admin)
  5. As a test, I deleteg all the *.log inside /crx-quickstart/logs and restarted AEM. all the files are showing up as zero bytes. (I tried opening the file using nano in Windows terminal and there's nothing there.)

2022-08-09 16_18_42-Classifieds _ Headphone Reviews and Discussion - Head-Fi.org.png

4 Replies

Avatar

Community Advisor

Hi @jayv25585659 ,

I believe it is nothing regarding the platform, can you try opening the files in Notepad++ and check?

Avatar

Level 7

I opened error.log using nano (a console text editor similar to vi) inside Windows terminal and the file is empty.

Avatar

Level 6

there is nothing related to Operating system windows/linux. Close file explorer,

Open  <aem-installed>/crx-quickstart\logs , refresh and open logs in notepad++ or any other app and reload if required.