HTTP ERROR 503 AuthenticationSupport service missing. Cannot authenticate request.

Avatar

Avatar
Validate 1
Level 1
sams16001423
Level 1

Like

1 like

Total Posts

10 posts

Correct reply

1 solution
Top badges earned
Validate 1
Affirm 1
View profile

Avatar
Validate 1
Level 1
sams16001423
Level 1

Like

1 like

Total Posts

10 posts

Correct reply

1 solution
Top badges earned
Validate 1
Affirm 1
View profile
sams16001423
Level 1

10-07-2021

Hi All,

 

I'm facing below issue when I run aem jar with the command java -jar aem-author-p4502.jar   

sams16001423_3-1625976142700.png

 

sams16001423_4-1625976201946.png

 

after running below command's : -

java -jar aem-author-p4502.jar -Xmx1024m -XX:MaxPermSize=256m

 

sams16001423_6-1625976289537.png

 

java -Xmx4096m -jar aem-author-p4502.jar -v -x crx2oak -xargs -- --load-profile segment-no-ds -

 

sams16001423_8-1625976489641.png 

 

 

I have updated start.bat file aswell : -

::* default JVM options
if not defined CQ_JVM_OPTS set CQ_JVM_OPTS=-Xmx1024m -XX:MaxPermSize=256m -Djava.awt.headless=true
::* add the required JPMS modules, if needed
java --add-modules java.se.ee --version > nul 2>&1
if %errorlevel% EQU 0 set CQ_JVM_OPTS=--add-modules java.se.ee %CQ_JVM_OPTS%

 

please let me know if anyone is aware of this issue.

 

Thanks in advance.

 

 

 

 

 

 

Accepted Solutions (1)

Accepted Solutions (1)

Avatar

Avatar
Boost 250
MVP
ChitraMadan
MVP

Likes

273 likes

Total Posts

165 posts

Correct reply

68 solutions
Top badges earned
Boost 250
Establish
Ignite 1
Give Back 5
Give Back 3
View profile

Avatar
Boost 250
MVP
ChitraMadan
MVP

Likes

273 likes

Total Posts

165 posts

Correct reply

68 solutions
Top badges earned
Boost 250
Establish
Ignite 1
Give Back 5
Give Back 3
View profile
ChitraMadan
MVP

12-07-2021

Hi @sams16001423 ,

 

You can try below options:

 

1) Try to delete below 2 files and restart the instance:

 

/author/crx-quickstart/repository/segmentstore/repo.lock

/author/crx-quickstart/launchpad/felix/cache.lock

 

If this also don't work,

 

2) Stop the instance, delete the index folder and restart again, which will build your indexes again and might take some time to start.Wait for indexing to be completed.You can enable debug logs and check indexing logs in error.log

 

Answers (2)

Answers (2)

Avatar

Avatar
Validate 1
Level 1
sams16001423
Level 1

Like

1 like

Total Posts

10 posts

Correct reply

1 solution
Top badges earned
Validate 1
Affirm 1
View profile

Avatar
Validate 1
Level 1
sams16001423
Level 1

Like

1 like

Total Posts

10 posts

Correct reply

1 solution
Top badges earned
Validate 1
Affirm 1
View profile
sams16001423
Level 1

12-07-2021

@Bimmi_Soi  Yes, I'm using Java 11 & issue still exist . only if delete quickstart file then it will work but i don't want to do that every time.

Avatar

Avatar
Affirm 25
Level 5
Bimmi_Soi
Level 5

Likes

79 likes

Total Posts

83 posts

Correct reply

28 solutions
Top badges earned
Affirm 25
Contributor
Applaud 5
Boost 50
Ignite 1
View profile

Avatar
Affirm 25
Level 5
Bimmi_Soi
Level 5

Likes

79 likes

Total Posts

83 posts

Correct reply

28 solutions
Top badges earned
Affirm 25
Contributor
Applaud 5
Boost 50
Ignite 1
View profile
Bimmi_Soi
Level 5

12-07-2021

Hi @sams16001423 ,

 

What I believe is you are trying to run AEM as a cloud service author instance.

Before running the command can you check that you have java 11 installed in your system as thats a prerequisite.

then I think there should be no problem executing the below command.

 

java -jar aem-author-p4502.jar

 

Hope this helps!!

Thanks