Expand my Community achievements bar.

Enhance your AEM Assets & Boost Your Development: [AEM Gems | June 19, 2024] Improving the Developer Experience with New APIs and Events
SOLVED

Upgrade to AEM SDK Version 2023.4.11835.20230414T234523Z-230200 the custom bundle does not start

Avatar

Level 2

Hi all,

I updated my pom.xml with the latest aem-sdk version:

<aem.sdk.api>2023.4.11873.20230421T153841Z-230200</aem.sdk.api>

and my custom bundle does not start anymore
I am getting the following errors on system/console/bundles 

Imported Packagescom.adobe.aem.wcm.seo.sitemap,version=[1.1,2) from com.adobe.cq.wcm.com.adobe.aem.wcm.seo (230)
com.adobe.cq.dam.cfm,version=[1.12,2) from com.adobe.dam.cq-dam-cfm-api (363)
com.adobe.cq.export.json,version=[2.0,3) from com.adobe.cq.export.json (234)
com.adobe.cq.sightly,version=[3.2,4) from com.adobe.cq.sightly.cq-wcm-sightly-extension (466)
com.adobe.cq.wcm.core.components.models,version=[12.27,13) -- Cannot be resolved
com.adobe.granite.ui.components.ds,version=[1.3,2) from com.adobe.granite.ui.commons (326)
com.day.cq.commons,version=[6.0,7) from com.day.cq.cq-commons (351)
com.day.cq.commons.inherit,version=[5.7,6) from com.day.cq.cq-commons (351)
com.day.cq.dam.api,version=[1.37,2) from com.day.cq.dam.cq-dam-api (358)
com.day.cq.dam.commons.util,version=[1.67,2) from com.day.cq.dam.cq-dam-commons (371)
com.day.cq.replication,version=[6.12,7) -- Cannot be resolved
com.day.cq.search,version=[1.5,2) from com.day.cq.cq-search (437)
com.day.cq.search.result,version=[1.2,2) from com.day.cq.cq-search (437)
com.day.cq.tagging,version=[5.9,6) from com.day.cq.cq-tagging (447)
com.day.cq.wcm.api,version=[1.29,2) from com.day.cq.wcm.cq-wcm-api (450)

 
The current core components version dependency is

<dependency>
<groupId>com.adobe.cq</groupId>
<artifactId>core.wcm.components.core</artifactId>
<version>2.17.0</version>
</dependency>

 but if I use the latest one 2.22.10 the situation is even worse:

Imported Packagescom.adobe.aem.wcm.seo.sitemap,version=[1.1,2) from com.adobe.cq.wcm.com.adobe.aem.wcm.seo (230)
com.adobe.cq.dam.cfm,version=[1.12,2) from com.adobe.dam.cq-dam-cfm-api (363)
com.adobe.cq.export.json,version=[2.0,3) from com.adobe.cq.export.json (234)
com.adobe.cq.sightly,version=[3.2,4) from com.adobe.cq.sightly.cq-wcm-sightly-extension (466)
com.adobe.cq.wcm.core.components.commons.link,version=[1.2,2) from com.adobe.cq.core.wcm.components.core (342)
com.adobe.cq.wcm.core.components.internal.resource -- Cannot be resolved
com.adobe.cq.wcm.core.components.models,version=[12.27,13) -- Cannot be resolved
com.adobe.cq.wcm.core.components.util,version=[1.5,2) -- Cannot be resolved
com.adobe.granite.ui.components.ds,version=[1.3,2) from com.adobe.granite.ui.commons (326)
com.day.cq.commons,version=[6.0,7) from com.day.cq.cq-commons (351)
com.day.cq.commons.inherit,version=[5.7,6) from com.day.cq.cq-commons (351)
com.day.cq.dam.api,version=[1.37,2) from com.day.cq.dam.cq-dam-api (358)
com.day.cq.dam.commons.util,version=[1.67,2) from com.day.cq.dam.cq-dam-commons (371)
com.day.cq.replication,version=[6.12,7) -- Cannot be resolved
com.day.cq.search,version=[1.5,2) from com.day.cq.cq-search (437)
com.day.cq.search.result,version=[1.2,2) from com.day.cq.cq-search (437)
com.day.cq.tagging,version=[5.9,6) from com.day.cq.cq-tagging (447)
com.day.cq.wcm.api,version=[1.29,2) from com.day.cq.wcm.cq-wcm-api (450)
com.day.cq.wcm.api.designer,version=[5.9,6) from com.day.cq.wcm.cq-wcm-api (450)



What should I do to resolve the issue?

Thanks

1 Accepted Solution

Avatar

Correct answer by
Level 2

Hi @arunpatidar ,

it seems the issues has been fixed with the AEM SDK 2023.5.11983.20230511T173830Z-230200.

The core components dependencies are directly included in the 

<dependency>
<groupId>com.adobe.aem</groupId>
<artifactId>aem-sdk-api</artifactId>
<version>2023.5.11983.20230511T173830Z-230200</version>
<scope>provided</scope>
</dependency>

and fixing the redundancy by removing the dependency

core.wcm.components.core

 the bundle starts correctly

 

 

View solution in original post

6 Replies

Avatar

Community Advisor

Core components ships with AEM SDK. please check what is the version of core component installed in AEM and use that version.

The core components are in the /libs/ path.



Arun Patidar

Avatar

Level 2

Hi @arunpatidar ,

the AEM SDK 2023.4.11873.20230421T153841Z-230200 has 

 

Symbolic Namecom.adobe.cq.core.wcm.components.core
Version2.21.2


But even setting in the pom.xml

<dependency>
<groupId>com.adobe.cq</groupId>
<artifactId>core.wcm.components.core</artifactId>
<version>2.21.2</version>
</dependency>

 the result is the same:

Imported Packagescom.adobe.aem.wcm.seo.sitemap,version=[1.1,2) from com.adobe.cq.wcm.com.adobe.aem.wcm.seo (230)
com.adobe.cq.dam.cfm,version=[1.12,2) from com.adobe.dam.cq-dam-cfm-api (363)
com.adobe.cq.export.json,version=[2.0,3) from com.adobe.cq.export.json (234)
com.adobe.cq.sightly,version=[3.2,4) from com.adobe.cq.sightly.cq-wcm-sightly-extension (466)
com.adobe.cq.wcm.core.components.commons.link,version=[1.2,2) from com.adobe.cq.core.wcm.components.core (342)
com.adobe.cq.wcm.core.components.internal.resource -- Cannot be resolved
com.adobe.cq.wcm.core.components.models,version=[12.27,13) -- Cannot be resolved
com.adobe.cq.wcm.core.components.util,version=[1.5,2) -- Cannot be resolved
com.adobe.granite.ui.components.ds,version=[1.3,2) from com.adobe.granite.ui.commons (326)
com.day.cq.commons,version=[6.0,7) from com.day.cq.cq-commons (351)
com.day.cq.commons.inherit,version=[5.7,6) from com.day.cq.cq-commons (351)
com.day.cq.dam.api,version=[1.37,2) from com.day.cq.dam.cq-dam-api (358)
com.day.cq.dam.commons.util,version=[1.67,2) from com.day.cq.dam.cq-dam-commons (371)
com.day.cq.replication,version=[6.12,7) -- Cannot be resolved
com.day.cq.search,version=[1.5,2) from com.day.cq.cq-search (437)
com.day.cq.search.result,version=[1.2,2) from com.day.cq.cq-search (437)



Avatar

Community Advisor

Then it could be issue with the latest AEM SDK.



Arun Patidar

Avatar

Correct answer by
Level 2

Hi @arunpatidar ,

it seems the issues has been fixed with the AEM SDK 2023.5.11983.20230511T173830Z-230200.

The core components dependencies are directly included in the 

<dependency>
<groupId>com.adobe.aem</groupId>
<artifactId>aem-sdk-api</artifactId>
<version>2023.5.11983.20230511T173830Z-230200</version>
<scope>provided</scope>
</dependency>

and fixing the redundancy by removing the dependency

core.wcm.components.core

 the bundle starts correctly

 

 

Avatar

Community Advisor

As the SDK ships in with the core components jar, you need to specify any other specific version in the POM. This error may appear if there's a redundancy in the version at OSGi.
please make sure that there is only core components is being installed

 

Avatar

Level 2

Hi @B_Sravan ,

I already tried different ways, also to exclude the core components dependency from the pom and I get the following error:

 

com.adobe.aem.wcm.seo.sitemap,version=[1.1,2) from com.adobe.cq.wcm.com.adobe.aem.wcm.seo (230)
com.adobe.cq.sightly,version=[3.2,4) from com.adobe.cq.sightly.cq-wcm-sightly-extension (466)
com.adobe.granite.ui.components.ds,version=[1.3,2) from com.adobe.granite.ui.commons (326)
com.day.cq.commons,version=[6.0,7) from com.day.cq.cq-commons (351)
com.day.cq.commons.inherit,version=[5.7,6) from com.day.cq.cq-commons (351)
com.day.cq.dam.api,version=[1.37,2) from com.day.cq.dam.cq-dam-api (358)
com.day.cq.dam.commons.util,version=[1.67,2) from com.day.cq.dam.cq-dam-commons (371)
com.day.cq.replication,version=[6.12,7) -- Cannot be resolved
com.day.cq.search,version=[1.5,2) from com.day.cq.cq-search (437)
com.day.cq.search.result,version=[1.2,2) from com.day.cq.cq-search (437)
com.day.cq.tagging,version=[5.9,6) from com.day.cq.cq-tagging (447)

 

 

With any other higher or lower core components version I get the error I posted before this message:

com.adobe.aem.wcm.seo.sitemap,version=[1.1,2) from com.adobe.cq.wcm.com.adobe.aem.wcm.seo (230)
com.adobe.cq.dam.cfm,version=[1.12,2) from com.adobe.dam.cq-dam-cfm-api (363)
com.adobe.cq.export.json,version=[2.0,3) from com.adobe.cq.export.json (234)
com.adobe.cq.sightly,version=[3.2,4) from com.adobe.cq.sightly.cq-wcm-sightly-extension (466)
com.adobe.cq.wcm.core.components.commons.link,version=[1.2,2) from com.adobe.cq.core.wcm.components.core (342)
com.adobe.cq.wcm.core.components.internal.resource -- Cannot be resolved
com.adobe.cq.wcm.core.components.models,version=[12.27,13) -- Cannot be resolved
com.adobe.cq.wcm.core.components.util,version=[1.5,2) -- Cannot be resolved
com.adobe.granite.ui.components.ds,version=[1.3,2) from com.adobe.granite.ui.commons (326)
com.day.cq.commons,version=[6.0,7) from com.day.cq.cq-commons (351)
com.day.cq.commons.inherit,version=[5.7,6) from com.day.cq.cq-commons (351)
com.day.cq.dam.api,version=[1.37,2) from com.day.cq.dam.cq-dam-api (358)
com.day.cq.dam.commons.util,version=[1.67,2) from com.day.cq.dam.cq-dam-commons (371)
com.day.cq.replication,version=[6.12,7) -- Cannot be resolved
com.day.cq.search,version=[1.5,2) from com.day.cq.cq-search (437)
com.day.cq.search.result,version=[1.2,2) from com.day.cq.cq-search (437)
com.day.cq.tagging,version=[5.9,6) from com.day.cq.cq-tagging (447)
com.day.cq.wcm.api,version=[1.29,2) from com.day.cq.wcm.cq-wcm-api (450)