Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

SOLVED

HTTP/1.1 401 Unauthorized - AEM Brand portal access

Avatar

Level 5

I have configured brand portal cloud service, replication agent in AEM.

I am seeing following unauthorized access when I do test connection.

2018-11-02 11:34:49 - >> POST /bin/receive HTTP/1.0

2018-11-02 11:34:49 - >> Action: Test

2018-11-02 11:34:49 - >> Path: /content

2018-11-02 11:34:49 - >> Handle: /content

2018-11-02 11:34:49 - >> Referer: about:blank

2018-11-02 11:34:49 - >> Content-Length: 0

2018-11-02 11:34:49 - >> Content-Type: application/octet-stream

2018-11-02 11:34:49 - --

2018-11-02 11:34:49 - << HTTP/1.1 401 Unauthorized

Do I need to give any specific permissions to specific users ?

1 Accepted Solution

Avatar

Correct answer by
Administrator
  1. Make sure /content/projects node exists (Brand Portal configuration needs access to Projects).
  2. Delete all the brand portal configuration below http://host:port/miscadmin#/etc/cloudservices/mediaportal/<*>
  3. Delete the user id mac-<tenantid>-replication from http://host:port/useradmin
  4. Delete the replication agents starting with mp_replication_agent* at http://host:port/miscadmin#/etc/replication/agents.author
  5. Delete the OSGI config  http://host:port/apps/system/config/com.adobe.granite.auth.oauth.accesstoken.provider-*.config
  6. Reconfigure Brand Portal integration again with right values for "Client ID", "Tenant URL".  If you make a mistake again in entering "Client ID", "Tenant URL” please repeat the steps 1 to 5.

View solution in original post

1 Reply

Avatar

Correct answer by
Administrator
  1. Make sure /content/projects node exists (Brand Portal configuration needs access to Projects).
  2. Delete all the brand portal configuration below http://host:port/miscadmin#/etc/cloudservices/mediaportal/<*>
  3. Delete the user id mac-<tenantid>-replication from http://host:port/useradmin
  4. Delete the replication agents starting with mp_replication_agent* at http://host:port/miscadmin#/etc/replication/agents.author
  5. Delete the OSGI config  http://host:port/apps/system/config/com.adobe.granite.auth.oauth.accesstoken.provider-*.config
  6. Reconfigure Brand Portal integration again with right values for "Client ID", "Tenant URL".  If you make a mistake again in entering "Client ID", "Tenant URL” please repeat the steps 1 to 5.