Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

Experience fragment able to edit only sometimes

SagarVerliani
Level 2
Level 2

Hi All,

 

We have created editable template for experience fragment and also, we created template type and page component for it.

Now, when we check in production and stage the xf template type is missing or deleted.

But experience fragment is editable in Prod and not on Stage. Also sometimes it is not editable in Prod also.

So do we know that if template type is deleted and the template would still be editable ?


6 Replies
bangar50
Level 7
Level 7

Hi @SagarVerliani ,

       If  Template type is missing or deleted then it gives such type of issue.

Template type should be there then you can able to edit the template.

Regards,

Sanjay

 

SagarVerliani
Level 2
Level 2

Hi Sanjay,

 

I did not understood your reply. I tried reproducing in my local, the page was still editable and no error was thrown at template when template type is deleted.

SivaPrasadReddyS
Level 8
Level 8

Hi Sagar,

 

Sometime back, i had similar issues, where i was not able to edit experience fragments and I had to update core components version to 2.8.0 and it resolved (AEM6.5.9). May be you can try upgrading core components incase if you're using older version of core components and see if that resolves issue. 

 

Note: Please test this on your local before trying something on Stage/prod 🙂 

 

 

 

Thanks 

 

SagarVerliani
Level 2
Level 2

Hi Siva,

 

Do you think this is fine? as in our environment would need update?

SagarVerliani_0-1635237270976.png

 

SivaPrasadReddyS
Level 8
Level 8

Hi @SagarVerliani 

I've tried with 2.8.0 and it worked for me in my local.

SivaPrasadReddyS_0-1635798172534.png

So I would expect 2.10.0 works for you as well. do you see any issues with 2.10 version?

 

Thanks

Hemalatha
Level 3
Level 3

hi @SagarVerliani ,

the xf template type is missing or deleted - if this happens intermittently and working fine in local check the merge mode for those template policies under /conf folder. Based on the mode set for the package, the content will get overwritten/ merged/ deleted. which might causing this issue. Check the pom.xml related to that folder.

  1. replace : This is the normal behavior. Existing content is replaced completely by the imported content, i.e. is overridden or deleted accordingly.
  2. merge : Existing content is not modified, i.e. only new content is added and none is deleted or modified.
  3. update : Existing content is updated, new content is added and none is deleted.

Kindly check,

https://jackrabbit.apache.org/filevault/filter.html