Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

SOLVED

Dependency on com.day.cq:parent:pom:82 in 6.5.6 uber-jar

Jakub_G
Level 2
Level 2

I'm unable to build projects after switching from uber-jar 6.5.5 to uber-jar 6.5.6. Maven is unable to find com.day.cq:parent:pom:82 artifact declared in 6.5.6 pom

 

<parent>
  <groupId>com.day.cq</groupId>
  <artifactId>parent</artifactId>
  <version>82</version>
</parent>

 

This section was no present in 6.5.5 uber-jar. Was correct uber-jar pom uploaded?

The same issue might apply to 6.4.8.2

1 Accepted Solution
hamidk92094312
Correct answer by
Employee
Employee

Pom issue is resolved now and uber jar is posted with new dependency as follows:

<dependency>

      <groupId>com.adobe.aem</groupId>

      <artifactId>uber-jar</artifactId>

      <version>6.5.6-1.0</version>

       <scope>provided</scope>

</dependency>

View solution in original post

2 Replies
hamidk92094312
Employee
Employee

Uber jars are publicly available on maven central, it is the issue with uploaded pom which has incorrect dependency which Adobe is working to fix.

hamidk92094312
Correct answer by
Employee
Employee

Pom issue is resolved now and uber jar is posted with new dependency as follows:

<dependency>

      <groupId>com.adobe.aem</groupId>

      <artifactId>uber-jar</artifactId>

      <version>6.5.6-1.0</version>

       <scope>provided</scope>

</dependency>

View solution in original post

koenve
Level 3
Level 3

Hey

 

Created a support case with Adobe customer care, and they pointed out that the way you're referencing the uber jar has changed. As outlined on the SP6 release notes, the new way to include the uber-jar is: 

 

<dependency>
<groupId>com.adobe.aem</groupId>
<artifactId>uber-jar</artifactId>
<version>6.5.6-1.0</version> 
</dependency>

 

Hope this helps!

 

With kind regards

 

Koen