Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

Custom LiveAction NPE when processing page with deleted component

Avatar

Level 4

I have gotten no help from Adobe Tech Support on this issue. They are pushing me off to Adobe Consulting.

We have a simple custom LiveAction that works fine when components are added and pages are rolled out.

If you delete a component and roll out the page an NPE is generated. Looking at the stack trace it appears to happen in Adobe code. See below.

But Adobe Tech Support says it is in our custom code.

If I totally gut the custom Live Action and implement methods with well know return values and execute methods that are empty the NPE occurs in exactly the same spot.

I am concerned there is something wrong with our CRX and I have told support this but again not getting the attention of the tech support.

The NPE is always on line 172 in LegacyLiveActionRegistration when processing a page with a deleted component.

I am looking for any insight that you might be able to provide. Thanks!

  1. 2.06.2018 14:22:02.324 *ERROR* [10.200.16.25 [1528827722223] POST /bin/wcmcommand HTTP/1.1] com.day.cq.wcm.msm.impl.RolloutManagerImpl Failed to roll-out LiveRelationship from /content/marketing/stag
    ing/en_us/tomtest/test-events-tag/jcr:content/par/text_f5e0 to /content/marketing/publish/en_us/tomtest/test-events-tag/jcr:content/par/text_f5e0: {}
    java.lang.NullPointerException: null
    at com.day.cq.wcm.msm.impl.actions.LegacyLiveActionRegistration$LegacyLiveAction.execute(LegacyLiveActionRegistration.java:172)
    at com.day.cq.wcm.msm.impl.RolloutManagerImpl.rolloutResource(RolloutManagerImpl.java:804)
    at com.day.cq.wcm.msm.impl.RolloutManagerImpl.rolloutResource(RolloutManagerImpl.java:825)
    at com.day.cq.wcm.msm.impl.RolloutManagerImpl.rolloutResource(RolloutManagerImpl.java:825)
    at com.day.cq.wcm.msm.impl.RolloutManagerImpl.rolloutPage(RolloutManagerImpl.java:707)
    at com.day.cq.wcm.msm.impl.RolloutManagerImpl.rolloutPageRelations(RolloutManagerImpl.java:600)
    at com.day.cq.wcm.msm.impl.RolloutManagerImpl.rollout(RolloutManagerImpl.java:502)
    at com.day.cq.wcm.msm.impl.commands.RolloutCommand.performCommand(RolloutCommand.java:176)
    at com.day.cq.wcm.core.impl.commands.WCMCommandService$CommandHolder.performCommand(WCMCommandService.java:178)
3 Replies

Avatar

Level 10

This sounds like a bug to me as opposed to a config issue on your end. I'm checking.

Avatar

Level 10

Can you do a video showing the OOTB API is throwing an exception. If you show its a bug with the API - then support has to deal with it.