Expand my Community achievements bar.

Applications for the 2024-2025 Adobe Experience Manager Champion Program are open!

Core AEM bundles restarting when custom bundles are deployed

Avatar

Level 2

 

 

AEM 6.5.17 

on-prem. 

 

We're having trouble where our project, Core AEM bundles and AEM is restarting when custom bundles are deployed  on every deployment . We're not certain when this bug was introduced or how to solve it.

 

 

Topics

Topics help categorize Community content and increase your ability to discover relevant content.

13 Replies

Avatar

Community Advisor

Are there any dependencies between Custom Bundles and Core AEM bundles - check your pom.xml file dependencies

Avatar

Level 2

I have verified the pom.xml files and I did not see any core AEM  bundles list in my pom.xml files.

 

Avatar

Community Advisor

By Core AEM bundles , did you mean Core Components Bundle !? Every time you install your project if there is core component dependency, those bundles also will be installed and your bundles refresh. Till then the site can go down. But if you give it sometime , it will install and will be back up and running. 

Avatar

Community Advisor

Hi @hari_krishnac22 ,

On each bundle deployment AEM takes time to resolve its dependencies and then activate the bundle.
Until then you would see a blank page, this shouldn't restart your AEM instance.
This is expected behavior.

Thanks
Tarun

Avatar

Community Advisor

local host may have corrupted or some other issue - please check the error logs for more details.

is it happening with other instances also ? like DEV or QA or can you try with any other developer localhost or try with vanilla installation.

Avatar

Level 2

Yes , Have set up fresh local AEM installation , Yes its happening in all the environments like DEV, UAT, Stage, Prod. once we deployed the custom bundles AEM is restarting.

 

its happening in other developers machines also. 

Avatar

Community Advisor

Can you please check the Build Logs and Error Logs for more details.

Avatar

Community Advisor

in error logs check for the build start details, if there is any information on restart.

Avatar

Administrator

@hari_krishnac22 Did you find the suggestions from users helpful? Please let us know if more information is required. Otherwise, please mark the answer as correct for posterity. If you have found out solution yourself, please share it with the community.



Kautuk Sahni

Avatar

Level 2

Hello Kautuk,

Still did not get any solution. More information is required on this.waiting for more inputs also.