Content is present in crx/de but it is not appearing on page in Classic UI

Avatar

Avatar
Validate 1
Level 2
rasikawanjari
Level 2

Likes

6 likes

Total Posts

22 posts

Correct reply

0 solutions
Top badges earned
Validate 1
Boost 5
Boost 3
Boost 1
View profile

Avatar
Validate 1
Level 2
rasikawanjari
Level 2

Likes

6 likes

Total Posts

22 posts

Correct reply

0 solutions
Top badges earned
Validate 1
Boost 5
Boost 3
Boost 1
View profile
rasikawanjari
Level 2

13-05-2019

After adding new Component in page and authoring, content is present in the content node of  crx/de but it is not appearing on page in Classic UI

Replies

Avatar

Avatar
Give Back 50
Employee
berliant
Employee

Likes

207 likes

Total Posts

315 posts

Correct reply

98 solutions
Top badges earned
Give Back 50
Give Back 5
Give Back 3
Give Back 25
Give Back 10
View profile

Avatar
Give Back 50
Employee
berliant
Employee

Likes

207 likes

Total Posts

315 posts

Correct reply

98 solutions
Top badges earned
Give Back 50
Give Back 5
Give Back 3
Give Back 25
Give Back 10
View profile
berliant
Employee

13-05-2019

Does it work in TouchUI? Do you see any error in browser's debug console when loading the page?

Make sure that the component's node with the page includes sling:resourceType property.

Avatar

Avatar
Validate 1
Level 2
rasikawanjari
Level 2

Likes

6 likes

Total Posts

22 posts

Correct reply

0 solutions
Top badges earned
Validate 1
Boost 5
Boost 3
Boost 1
View profile

Avatar
Validate 1
Level 2
rasikawanjari
Level 2

Likes

6 likes

Total Posts

22 posts

Correct reply

0 solutions
Top badges earned
Validate 1
Boost 5
Boost 3
Boost 1
View profile
rasikawanjari
Level 2

13-05-2019

Yes, component's node with the page includes sling:resourceType property but still, content is not appearing on page. I added the component manually in the apps folder of Publisher instance as it was not present earlier, is this the reason for content not appearing by its own.

Avatar

Avatar
Validate 10
Level 3
ankurk67503819
Level 3

Likes

15 likes

Total Posts

89 posts

Correct reply

1 solution
Top badges earned
Validate 10
Validate 1
Boost 10
Boost 5
Boost 3
View profile

Avatar
Validate 10
Level 3
ankurk67503819
Level 3

Likes

15 likes

Total Posts

89 posts

Correct reply

1 solution
Top badges earned
Validate 10
Validate 1
Boost 10
Boost 5
Boost 3
View profile
ankurk67503819
Level 3

13-05-2019

Is it not coming in author or publish?

1. Check whether sling:resourcetype property value on content node is correctly mapped to apps folder path .

2. If its correct then check if component which you are trying to include is having the same name of jsp or html as its node name

Ex-

/apps

  /project

   /components

    /testcomponent

       testcomponent.html

       Cq:dialog