How to check dependency version in uber jar

Avatar

Avatar
Validate 10
Level 3
ankurk67503819
Level 3

Likes

15 likes

Total Posts

89 posts

Correct reply

1 solution
Top badges earned
Validate 10
Validate 1
Boost 10
Boost 5
Boost 3
View profile

Avatar
Validate 10
Level 3
ankurk67503819
Level 3

Likes

15 likes

Total Posts

89 posts

Correct reply

1 solution
Top badges earned
Validate 10
Validate 1
Boost 10
Boost 5
Boost 3
View profile
ankurk67503819
Level 3

12-05-2019

Hi Team,

How can we check the version of a jar file embedded inside uber jar in aem.

For example if i want to check the version of zxing jar  present in uber jar how can we check that?

And if we want to use the upgraded version of zxing library can we use that & how to update the version?

Regards

Replies

Avatar

Avatar
Springboard
Level 5
BrijeshYadav
Level 5

Likes

59 likes

Total Posts

102 posts

Correct reply

19 solutions
Top badges earned
Springboard
Validate 1
Ignite 5
Ignite 3
Ignite 1
View profile

Avatar
Springboard
Level 5
BrijeshYadav
Level 5

Likes

59 likes

Total Posts

102 posts

Correct reply

19 solutions
Top badges earned
Springboard
Validate 1
Ignite 5
Ignite 3
Ignite 1
View profile
BrijeshYadav
Level 5

13-05-2019

You can find version information in MANIFEST.MF

1751954_pastedImage_0.png

Avatar

Avatar
Validate 10
Level 3
ankurk67503819
Level 3

Likes

15 likes

Total Posts

89 posts

Correct reply

1 solution
Top badges earned
Validate 10
Validate 1
Boost 10
Boost 5
Boost 3
View profile

Avatar
Validate 10
Level 3
ankurk67503819
Level 3

Likes

15 likes

Total Posts

89 posts

Correct reply

1 solution
Top badges earned
Validate 10
Validate 1
Boost 10
Boost 5
Boost 3
View profile
ankurk67503819
Level 3

13-05-2019

But here the version is 5.9.6 but thats not the zing library version thats the version of the bundle from where its being exported.

Also my other query is can we upgrade the zxing library version.

Avatar

Avatar
Springboard
Level 5
BrijeshYadav
Level 5

Likes

59 likes

Total Posts

102 posts

Correct reply

19 solutions
Top badges earned
Springboard
Validate 1
Ignite 5
Ignite 3
Ignite 1
View profile

Avatar
Springboard
Level 5
BrijeshYadav
Level 5

Likes

59 likes

Total Posts

102 posts

Correct reply

19 solutions
Top badges earned
Springboard
Validate 1
Ignite 5
Ignite 3
Ignite 1
View profile
BrijeshYadav
Level 5

13-05-2019

Yes, com.google.zxing is part of cq-wcm-mobile-qrcode bundle.

You can add desired dependency version to your bundle pom file in order to override UberJar