Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
BedrockMission!

Learn More

View all

Sign in to view all badges

Component Rollout- option not available

Avatar

Avatar
Boost 1
Level 1
hariharans15808
Level 1

Like

1 like

Total Posts

2 posts

Correct Reply

0 solutions
Top badges earned
Boost 1
View profile

Avatar
Boost 1
Level 1
hariharans15808
Level 1

Like

1 like

Total Posts

2 posts

Correct Reply

0 solutions
Top badges earned
Boost 1
View profile
hariharans15808
Level 1

16-04-2019

Hi All,

Kindly help me with the below issue for Component Rollout in AEM 6.4

I have MSM setup for the site. And i am not able to do a component level roll out as the icon is not available. If a new component is created the icon is available.

Is there any procedure or series of events to be followed to achieve the Rollout for components and for the icon to be available in the editor.html view of the page.

Note: Page Rollouts are working fine.

Replies

Avatar

Avatar
Coach
Employee
jbrar
Employee

Likes

377 likes

Total Posts

867 posts

Correct Reply

283 solutions
Top badges earned
Coach
Establish
Give Back 50
Give Back 5
Give Back 3
View profile

Avatar
Coach
Employee
jbrar
Employee

Likes

377 likes

Total Posts

867 posts

Correct Reply

283 solutions
Top badges earned
Coach
Establish
Give Back 50
Give Back 5
Give Back 3
View profile
jbrar
Employee

16-04-2019

There might be something wrong with the BP-livecopy relationship at the component level. Setup a DEBUG logger on "com.day.cq.wcm.msm" to check more info on the blueprint and live copy relationship.

Avatar

Avatar
Boost 1
Level 1
hariharans15808
Level 1

Like

1 like

Total Posts

2 posts

Correct Reply

0 solutions
Top badges earned
Boost 1
View profile

Avatar
Boost 1
Level 1
hariharans15808
Level 1

Like

1 like

Total Posts

2 posts

Correct Reply

0 solutions
Top badges earned
Boost 1
View profile
hariharans15808
Level 1

17-04-2019

In the log , all the component's log seem similar.

Details: the Component with the Rollout icon(1) and the component without the Rollout Icon(2) have the same logs as below.

(1)GET /content/CognizantDotcom/language-masters/en_us/industries.html HTTP/1.1]  com.day.cq.wcm.msm.impl.LiveRelationshipManagerImpl no relation for /content/CognizantDotcom/language-masters/en_us/industries/jcr:content/root/responsivegrid_774549146/title found.

(2)GET /content/CognizantDotcom/language-masters/en_us/industries.html

HTTP/1.1] com.day.cq.wcm.msm.impl.LiveRelationshipManagerImpl no relation for /content/CognizantDotcom/language-masters/en_us/industries/jcr:content/root/responsivegrid_774549146/accordion found.

Does it have something to do with the component?

Avatar

Avatar
Give Back
Level 1
ChandraShiggaon
Level 1

Likes

0 likes

Total Posts

1 post

Correct Reply

0 solutions
Top badges earned
Give Back
View profile

Avatar
Give Back
Level 1
ChandraShiggaon
Level 1

Likes

0 likes

Total Posts

1 post

Correct Reply

0 solutions
Top badges earned
Give Back
View profile
ChandraShiggaon
Level 1

01-09-2020

I had same issue. Found the reason on why it was happening.

Until the below line is 'true' we do not get 'rollout' option at component level.

<div data-sly-test="${!wcmmode.disabled && condition2}" class="cq-placeholder" data-emptytext="${component.title}"></div>

Avatar

Avatar
Give Back
Level 1
mirizarry
Level 1

Likes

0 likes

Total Posts

1 post

Correct Reply

0 solutions
Top badges earned
Give Back
View profile

Avatar
Give Back
Level 1
mirizarry
Level 1

Likes

0 likes

Total Posts

1 post

Correct Reply

0 solutions
Top badges earned
Give Back
View profile
mirizarry
Level 1

23-11-2020

Where is this line of code located? Thanks in advance!