Highlighted

Cannot edit OSGI on Publish instance of AEM 6.3

jxpi

21-03-2018

When I open OSGI ConfigMgr as Admin, I cannot get the edit screen to pop up on any of teh configuration items including:

- Apache Sling Web Console Security Provider

- Day CQ Mail Service

On Author, I have no issues.

No errors are present in the Logs that point to an issue with teh OSGI.

Any ideas?

Thank you

John Pedrick

Replies

Highlighted
Highlighted

jxpi

22-03-2018

No errors on the error log or on the console. It worked when I first installed, but for some reason it does not work now.

Highlighted

jxpi

22-03-2018

I think I found the issue:

I assigned a URL to the Publish servers. When accessing the configMgr using the URL I experience the issue. However, if I access the Publish server using the IP Address, I can edit the configs.

Is there a setting or something that needs to be implemented to allow the OSGI to recognize the URL?

I dont remember setting this for AEM 6.1

Thank you

John Pedrick

Highlighted

jxpi

22-03-2018

Actually, the issue is not resolved.

I still need to access the server using a URL and make configuration changes. Need to understand why this is not working.

Highlighted

Kunwar

Employee

22-03-2018

If you have an ELB in the architecture layer, You might need to check that. I've customer setting or stripping some headers which are either restricted on Apache (dispatcher) which cause this.

Try going up each layer and hopefully you'd be able to resolve this.