Expand my Community achievements bar.

Enhance your AEM Assets & Boost Your Development: [AEM Gems | June 19, 2024] Improving the Developer Experience with New APIs and Events

Asset Share Commons setup Issue

Avatar

Level 4

Hi,
when i am trying to setup the asset share commons latest 3.8.4 on RDE environment through adobe CLI it shows below error

Logs:
> The analyser found the following errors for author and publish :
> The analyser found the following warnings for author and publish :
> [configuration-api] Configuration org.apache.sling.commons.log.LogManager.factory.config~asset-share-commons: Property org.apache.sling.commons.log.pattern - Property is not allowed (asset-share-commons:asset-share-commons.all:3.8.4|asset-share-commons:asset-share-commons.ui.config:3.8.4)
> [api-regions-exportsimports] com.adobe.aem.commons:assetshare.core:3.8.4: Bundle assetshare.core:3.8.4 is importing package(s) Package com.day.cq.wcm.api;version=[1.30,2) in start level 20 but no visible bundle is exporting these for that start level in the required version range. (asset-share-commons:asset-share-commons.all:3.8.4)
› Error: [RDECLI:INSTALL_STAGED] Install command was staged, analysers detected missing packages that can be fixed with another deployment on top of this one. Please check logs. If this is expected, you can
› ignore exit code 40
› Code: INSTALL_STAGED



Topics

Topics help categorize Community content and increase your ability to discover relevant content.

8 Replies

Avatar

Community Advisor

@abhishekanand_ Did you find the suggestions from users helpful? Please let us know if more information is required. Otherwise, please mark the answer as correct for posterity. If you have found out solution yourself, please share it with the community



Esteban Bustamante

Avatar

Community Advisor

@abhishekanand_ 

 

Whats the version of you RDE? Is it compatible with asset-share-commons.

From logs it seems like the asset-share-commons is dependent on a higher version of "com.day.cq.wcm.api" which is not available in RDE.

 

Please upgrade RDE and try. 


Aanchal Sikka

Avatar

Level 4

Hi @aanchal-sikka 
Thanks for the reply!
the version of "com.day.cq.wcm.api" was incompatible with RDE as it was higher, so now i am using another version of asset-share-commons this seems to fix my "com.day.cq.wcm.api" issue but that another issue still persists. 
below is the error:
> The analyser found the following warnings for author and publish :
> [configuration-api] Configuration org.apache.sling.commons.log.LogManager.factory.config-asset-share-commons: Property org.apache.sling.commons.log.pattern - Property is not allowed (com.project:projcet.al
1:1.0.0-SNAPSHOT | asset-share-commons: asset-share-commons.all: 3.5.0|asset-share-commons: asset-share-commons.ui.config:3.5.0)

due to this i am receving a NPE which is causing my publish instance be down org.apache.sling.engine.impl.SlingRequestProcessorImpl service: Uncaught SlingException
java.lang.NullPointerException: null

Avatar

Community Advisor

@abhishekanand_ 

 

Can you please confirm if you are using the cloud version of asset-share-commons?


Aanchal Sikka

Avatar

Level 4

@aanchal-sikka 

 

<version>3.5.0</version>

Previously, I attempted to use the latest version (3.8.4); however, because of the compatibility issue with com.day.cq.wcm.api, I opted to switch to an older version after reviewing the release notes.