Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

SOLVED

AEM Server is not starting

saibul
Level 4
Level 4

AEM - 6.5.5

Type - Author

The server was working fine fine. Two days back I installed SP-6.5.10, after installing the server the server was working fine.

Yesterday, I stopped the server and clear the logs from logs folder and I try to restart the AEM server but, it is not starting.

Not sure due to SP-6.5.10 it is not starting. After installing SP the server was working last two days fine.

It would be great if some give your opinions.

 

only stdout.log is created not other logs found in the logs folder

 

--------logs from stdout.log-------------

 

22.10.2021 13:46:56.994 *INFO * [main] Setting sling.home=crx-quickstart (command line)
22.10.2021 13:46:56.997 *INFO * [main] Starting Apache Sling in /apps/crx/author/crx-quickstart
22.10.2021 13:46:56.999 *INFO * [main] Sling Extension Lib Home : /apps/crx/author/crx-quickstart/launchpad/ext
22.10.2021 13:46:57.001 *INFO * [main] Checking launcher JAR in folder /apps/crx/author/crx-quickstart/launchpad
22.10.2021 13:46:57.009 *INFO * [main] Existing launcher is up to date, using it: 6.0.2.2_6_36 (org.apache.sling.launchpad.base.jar)
22.10.2021 13:46:57.009 *INFO * [main] Loading launcher class org.apache.sling.launchpad.base.app.MainDelegate from org.apache.sling.launchpad.base.jar
22.10.2021 13:46:57.010 *INFO * [main] External Libs Home (ext) is null or does not exists.
22.10.2021 13:46:57.018 *INFO * [Apache Sling Control Listener@/127.0.0.1:39378] Apache Sling Control Listener started
22.10.2021 13:46:57.019 *INFO * [main] Setting sling.properties=conf/sling.properties
22.10.2021 13:46:57.019 *INFO * [main] Setting sling.home=crx-quickstart
22.10.2021 13:46:57.019 *INFO * [main] Setting sling.launchpad=/apps/crx/author/crx-quickstart/launchpad
22.10.2021 13:46:57.019 *INFO * [main] Setting org.osgi.service.http.port=4502
22.10.2021 13:46:57.019 *INFO * [main] Starting launcher ...
22.10.2021 13:46:57.026 *INFO * [main] HTTP server port: 4502
22.10.2021 13:46:57.655 *ERROR* [FelixStartLevel] ERROR: Bundle '1' Error starting slinginstall:org.apache.sling.settings-1.3.8.jar (org.osgi.framework.BundleException: Unable to resolve org.apache.sling.settings [1](R 1.1): missing requirement [org.apache.sling.settings [1](R 1.1)] osgi.wiring.package; (&(osgi.wiring.package=org.slf4j)(version>=1.7.0)(!(version>=2.0.0))) [caused by: Unable to resolve slf4j.api [2](R 2.1): missing requirement [slf4j.api [2](R 2.1)] osgi.wiring.package; (&(osgi.wiring.package=org.slf4j.impl)(version>=1.6.0)) [caused by: Unable to resolve org.apache.sling.commons.log [3](R 3.1): missing requirement [org.apache.sling.commons.log [3](R 3.1)] osgi.wiring.package; (osgi.wiring.package=javax.xml.namespace)]] Unresolved requirements: [[org.apache.sling.settings [1](R 1.1)] osgi.wiring.package; (&(osgi.wiring.package=org.slf4j)(version>=1.7.0)(!(version>=2.0.0)))])
org.osgi.framework.BundleException: Unable to resolve org.apache.sling.settings [1](R 1.1): missing requirement [org.apache.sling.settings [1](R 1.1)] osgi.wiring.package; (&(osgi.wiring.package=org.slf4j)(version>=1.7.0)(!(version>=2.0.0))) [caused by: Unable to resolve slf4j.api [2](R 2.1): missing requirement [slf4j.api [2](R 2.1)] osgi.wiring.package; (&(osgi.wiring.package=org.slf4j.impl)(version>=1.6.0)) [caused by: Unable to resolve org.apache.sling.commons.log [3](R 3.1): missing requirement [org.apache.sling.commons.log [3](R 3.1)] osgi.wiring.package; (osgi.wiring.package=javax.xml.namespace)]] Unresolved requirements: [[org.apache.sling.settings [1](R 1.1)] osgi.wiring.package; (&(osgi.wiring.package=org.slf4j)(version>=1.7.0)(!(version>=2.0.0)))]
at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:4368)
at org.apache.felix.framework.Felix.startBundle(Felix.java:2281)
at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1539)
at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:308)
at java.lang.Thread.run(Thread.java:748)
22.10.2021 13:46:57.657 *ERROR* [FelixStartLevel] ERROR: Bundle '2' Error starting slinginstall:slf4j-api-1.7.21.jar (org.osgi.framework.BundleException: Unable to resolve slf4j.api [2](R 2.1): missing requirement [slf4j.api [2](R 2.1)] osgi.wiring.package; (&(osgi.wiring.package=org.slf4j.impl)(version>=1.6.0)) [caused by: Unable to resolve org.apache.sling.commons.log [3](R 3.1): missing requirement [org.apache.sling.commons.log [3](R 3.1)] osgi.wiring.package; (osgi.wiring.package=javax.xml.namespace)] Unresolved requirements: [[slf4j.api [2](R 2.1)] osgi.wiring.package; (&(osgi.wiring.package=org.slf4j.impl)(version>=1.6.0))])
org.osgi.framework.BundleException: Unable to resolve slf4j.api [2](R 2.1): missing requirement [slf4j.api [2](R 2.1)] osgi.wiring.package; (&(osgi.wiring.package=org.slf4j.impl)(version>=1.6.0)) [caused by: Unable to resolve org.apache.sling.commons.log [3](R 3.1): missing requirement [org.apache.sling.commons.log [3](R 3.1)] osgi.wiring.package; (osgi.wiring.package=javax.xml.namespace)] Unresolved requirements: [[slf4j.api [2](R 2.1)] osgi.wiring.package; (&(osgi.wiring.package=org.slf4j.impl)(version>=1.6.0))]
at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:4368)
at org.apache.felix.framework.Felix.startBundle(Felix.java:2281)
at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1539)
at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:308)
at java.lang.Thread.run(Thread.java:748)
22.10.2021 13:46:57.659 *ERROR* [FelixStartLevel] ERROR: Bundle '3' Error starting slinginstall:org.apache.sling.commons.log-5.0.0.jar (org.osgi.framework.BundleException: Unable to resolve org.apache.sling.commons.log [3](R 3.1): missing requirement [org.apache.sling.commons.log [3](R 3.1)] osgi.wiring.package; (osgi.wiring.package=javax.xml.namespace) Unresolved requirements: [[org.apache.sling.commons.log [3](R 3.1)] osgi.wiring.package; (osgi.wiring.package=javax.xml.namespace)])
org.osgi.framework.BundleException: Unable to resolve org.apache.sling.commons.log [3](R 3.1): missing requirement [org.apache.sling.commons.log [3](R 3.1)] osgi.wiring.package; (osgi.wiring.package=javax.xml.namespace) Unresolved requirements: [[org.apache.sling.commons.log [3](R 3.1)] osgi.wiring.package; (osgi.wiring.package=javax.xml.namespace)]
at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:4368)
at org.apache.felix.framework.Felix.startBundle(Felix.java:2281)
at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1539)
at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:308)
at java.lang.Thread.run(Thread.java:748)
22.10.2021 13:46:57.663 *ERROR* [FelixStartLevel] ERROR: Bundle '4' Error starting slinginstall:org.apache.sling.launchpad.installer-1.2.2.jar (org.osgi.framework.BundleException: Unable to resolve org.apache.sling.launchpad.installer [4](R 4.0): missing requirement [org.apache.sling.launchpad.installer [4](R 4.0)] osgi.wiring.package; (&(osgi.wiring.package=org.slf4j)(version>=1.5.0)(!(version>=2.0.0))) [caused by: Unable to resolve slf4j.api [2](R 2.1): missing requirement [slf4j.api [2](R 2.1)] osgi.wiring.package; (&(osgi.wiring.package=org.slf4j.impl)(version>=1.6.0)) [caused by: Unable to resolve org.apache.sling.commons.log [3](R 3.1): missing requirement [org.apache.sling.commons.log [3](R 3.1)] osgi.wiring.package; (osgi.wiring.package=javax.xml.namespace)]] Unresolved requirements: [[org.apache.sling.launchpad.installer [4](R 4.0)] osgi.wiring.package; (&(osgi.wiring.package=org.slf4j)(version>=1.5.0)(!(version>=2.0.0)))])
org.osgi.framework.BundleException: Unable to resolve org.apache.sling.launchpad.installer [4](R 4.0): missing requirement [org.apache.sling.launchpad.installer [4](R 4.0)] osgi.wiring.package; (&(osgi.wiring.package=org.slf4j)(version>=1.5.0)(!(version>=2.0.0))) [caused by: Unable to resolve slf4j.api [2](R 2.1): missing requirement [slf4j.api [2](R 2.1)] osgi.wiring.package; (&(osgi.wiring.package=org.slf4j.impl)(version>=1.6.0)) [caused by: Unable to resolve org.apache.sling.commons.log [3](R 3.1): missing requirement [org.apache.sling.commons.log [3](R 3.1)] osgi.wiring.package; (osgi.wiring.package=javax.xml.namespace)]] Unresolved requirements: [[org.apache.sling.launchpad.installer [4](R 4.0)] osgi.wiring.package; (&(osgi.wiring.package=org.slf4j)(version>=1.5.0)(!(version>=2.0.0)))]
at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:4368)
at org.apache.felix.framework.Felix.startBundle(Felix.java:2281)
at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1539)
at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:308)
at java.lang.Thread.run(Thread.java:748)
22.10.2021 13:46:57.665 *ERROR* [FelixStartLevel] ERROR: Bundle '5' Error starting slinginstall:com.adobe.granite.crypto-3.4.8.jar (org.osgi.framework.BundleException: Unable to resolve com.adobe.granite.crypto [5](R 5.1): missing requirement [com.adobe.granite.crypto [5](R 5.1)] osgi.wiring.package; (&(osgi.wiring.package=org.slf4j)(version>=1.7.6)(!(version>=2.0.0))) [caused by: Unable to resolve slf4j.api [2](R 2.1): missing requirement [slf4j.api [2](R 2.1)] osgi.wiring.package; (&(osgi.wiring.package=org.slf4j.impl)(version>=1.6.0)) [caused by: Unable to resolve org.apache.sling.commons.log [3](R 3.1): missing requirement [org.apache.sling.commons.log [3](R 3.1)] osgi.wiring.package; (osgi.wiring.package=javax.xml.namespace)]] Unresolved requirements: [[com.adobe.granite.crypto [5](R 5.1)] osgi.wiring.package; (&(osgi.wiring.package=org.slf4j)(version>=1.7.6)(!(version>=2.0.0)))])
org.osgi.framework.BundleException: Unable to resolve com.adobe.granite.crypto [5](R 5.1): missing requirement [com.adobe.granite.crypto [5](R 5.1)] osgi.wiring.package; (&(osgi.wiring.package=org.slf4j)(version>=1.7.6)(!(version>=2.0.0))) [caused by: Unable to resolve slf4j.api [2](R 2.1): missing requirement [slf4j.api [2](R 2.1)] osgi.wiring.package; (&(osgi.wiring.package=org.slf4j.impl)(version>=1.6.0)) [caused by: Unable to resolve org.apache.sling.commons.log [3](R 3.1): missing requirement [org.apache.sling.commons.log [3](R 3.1)] osgi.wiring.package; (osgi.wiring.package=javax.xml.namespace)]] Unresolved requirements: [[com.adobe.granite.crypto [5](R 5.1)] osgi.wiring.package; (&(osgi.wiring.package=org.slf4j)(version>=1.7.6)(!(version>=2.0.0)))]
at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:4368)
at org.apache.felix.framework.Felix.startBundle(Felix.java:2281)
at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1539)
at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:308)
at java.lang.Thread.run(Thread.java:748)
22.10.2021 13:46:57.668 *ERROR* [FelixStartLevel] ERROR: Bundle '8' Error starting slinginstall:org.apache.sling.installer.provider.file-1.1.0.jar (org.osgi.framework.BundleException: Unable to resolve org.apache.sling.installer.provider.file [8](R 8.0): missing requirement [org.apache.sling.installer.provider.file [8](R 8.0)] osgi.wiring.package; (&(osgi.wiring.package=org.slf4j)(version>=1.5.0)(!(version>=2.0.0))) [caused by: Unable to resolve slf4j.api [2](R 2.1): missing requirement [slf4j.api [2](R 2.1)] osgi.wiring.package; (&(osgi.wiring.package=org.slf4j.impl)(version>=1.6.0)) [caused by: Unable to resolve org.apache.sling.commons.log [3](R 3.1): missing requirement [org.apache.sling.commons.log [3](R 3.1)] osgi.wiring.package; (osgi.wiring.package=javax.xml.namespace)]] Unresolved requirements: [[org.apache.sling.installer.provider.file [8](R 8.0)] osgi.wiring.package; (&(osgi.wiring.package=org.slf4j)(version>=1.5.0)(!(version>=2.0.0)))])
org.osgi.framework.BundleException: Unable to resolve org.apache.sling.installer.provider.file [8](R 8.0): missing requirement [org.apache.sling.installer.provider.file [8](R 8.0)] osgi.wiring.package; (&(osgi.wiring.package=org.slf4j)(version>=1.5.0)(!(version>=2.0.0))) [caused by: Unable to resolve slf4j.api [2](R 2.1): missing requirement [slf4j.api [2](R 2.1)] osgi.wiring.package; (&(osgi.wiring.package=org.slf4j.impl)(version>=1.6.0)) [caused by: Unable to resolve org.apache.sling.commons.log [3](R 3.1): missing requirement [org.apache.sling.commons.log [3](R 3.1)] osgi.wiring.package; (osgi.wiring.package=javax.xml.namespace)]] Unresolved requirements: [[org.apache.sling.installer.provider.file [8](R 8.0)] osgi.wiring.package; (&(osgi.wiring.package=org.slf4j)(version>=1.5.0)(!(version>=2.0.0)))]
at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:4368)
at org.apache.felix.framework.Felix.startBundle(Felix.java:2281)
at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1539)
at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:308)
at java.lang.Thread.run(Thread.java:748)

 

1 Accepted Solution
saibul
Correct answer by
Level 4
Level 4

I fixed the issue.

1. taken back of crx-quickstart folder for safer side

2. directly ran the server using "java -jar  aem-6.5.0-author-p4502.jar" and it started correctly.

3. uninstalled the sp-6.5.10

4. stopped the server

5. started the server using service and it started.

View solution in original post

3 Replies
saibul
Level 4
Level 4

 

----This is the tail of the log---

org.osgi.framework.BundleException: Unable to resolve com.day.cq.cq-upgrades-executor [145](R 145.1): missing requirement [com.day.cq.cq-upgrades-executor [145](R 145.1)] osgi.wiring.package; (&(osgi.wiring.package=javax.jcr)(version>=2.0.0)(!(version>=3.0.0))) [caused by: Unable to resolve org.apache.sling.jcr.jcr-wrapper [118](R 118.0): missing requirement [org.apache.sling.jcr.jcr-wrapper [118](R 118.0)] osgi.wiring.package; (osgi.wiring.package=org.xml.sax)] Unresolved requirements: [[com.day.cq.cq-upgrades-executor [145](R 145.1)] osgi.wiring.package; (&(osgi.wiring.package=javax.jcr)(version>=2.0.0)(!(version>=3.0.0)))]
at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:4368)
at org.apache.felix.framework.Felix.startBundle(Felix.java:2281)
at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1539)
at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:308)
at java.lang.Thread.run(Thread.java:748)
22.10.2021 13:46:58.433 *ERROR* [FelixStartLevel] ERROR: Bundle '146' Error starting launchpad:resources/install/25/pre-upgrade-tasks-1.0.44.jar (org.osgi.framework.BundleException: Unable to resolve com.day.cq.pre-upgrade-tasks [146](R 146.0): missing requirement [com.day.cq.pre-upgrade-tasks [146](R 146.0)] osgi.wiring.package; (&(osgi.wiring.package=com.adobe.granite.jmx.annotation)(version>=1.0.0)(!(version>=2.0.0))) [caused by: Unable to resolve com.adobe.granite.jmx [105](R 105.1): missing requirement [com.adobe.granite.jmx [105](R 105.1)] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.service.component)(version>=1.2.1)(!(version>=2.0.0))) [caused by: Unable to resolve org.apache.felix.scr [32](R 32.2): missing requirement [org.apache.felix.scr [32](R 32.2)] osgi.wiring.package; (osgi.wiring.package=javax.xml.parsers)]] Unresolved requirements: [[com.day.cq.pre-upgrade-tasks [146](R 146.0)] osgi.wiring.package; (&(osgi.wiring.package=com.adobe.granite.jmx.annotation)(version>=1.0.0)(!(version>=2.0.0)))])
org.osgi.framework.BundleException: Unable to resolve com.day.cq.pre-upgrade-tasks [146](R 146.0): missing requirement [com.day.cq.pre-upgrade-tasks [146](R 146.0)] osgi.wiring.package; (&(osgi.wiring.package=com.adobe.granite.jmx.annotation)(version>=1.0.0)(!(version>=2.0.0))) [caused by: Unable to resolve com.adobe.granite.jmx [105](R 105.1): missing requirement [com.adobe.granite.jmx [105](R 105.1)] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.service.component)(version>=1.2.1)(!(version>=2.0.0))) [caused by: Unable to resolve org.apache.felix.scr [32](R 32.2): missing requirement [org.apache.felix.scr [32](R 32.2)] osgi.wiring.package; (osgi.wiring.package=javax.xml.parsers)]] Unresolved requirements: [[com.day.cq.pre-upgrade-tasks [146](R 146.0)] osgi.wiring.package; (&(osgi.wiring.package=com.adobe.granite.jmx.annotation)(version>=1.0.0)(!(version>=2.0.0)))]
at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:4368)
at org.apache.felix.framework.Felix.startBundle(Felix.java:2281)
at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1539)
at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:308)
at java.lang.Thread.run(Thread.java:748)
22.10.2021 13:46:58.434 *ERROR* [FelixStartLevel] ERROR: Bundle '147' Error starting launchpad:resources/install/30/org.apache.sling.startupfilter.disabler-0.0.1-Rev1758544.jar (org.osgi.framework.BundleException: Unable to resolve org.apache.sling.startupfilter.disabler [147](R 147.0): missing requirement [org.apache.sling.startupfilter.disabler [147](R 147.0)] osgi.wiring.package; (&(osgi.wiring.package=org.apache.sling.startupfilter)(version>=1.0.0)(!(version>=2.0.0))) [caused by: Unable to resolve org.apache.sling.startupfilter [53](R 53.1): missing requirement [org.apache.sling.startupfilter [53](R 53.1)] osgi.implementation; (&(osgi.implementation=osgi.http)(version>=1.0)(!(version>=2.0))) [caused by: Unable to resolve org.apache.felix.http.jetty [40](R 40.3): missing requirement [org.apache.felix.http.jetty [40](R 40.3)] osgi.wiring.package; (osgi.wiring.package=javax.xml.parsers)]] Unresolved requirements: [[org.apache.sling.startupfilter.disabler [147](R 147.0)] osgi.wiring.package; (&(osgi.wiring.package=org.apache.sling.startupfilter)(version>=1.0.0)(!(version>=2.0.0)))])
org.osgi.framework.BundleException: Unable to resolve org.apache.sling.startupfilter.disabler [147](R 147.0): missing requirement [org.apache.sling.startupfilter.disabler [147](R 147.0)] osgi.wiring.package; (&(osgi.wiring.package=org.apache.sling.startupfilter)(version>=1.0.0)(!(version>=2.0.0))) [caused by: Unable to resolve org.apache.sling.startupfilter [53](R 53.1): missing requirement [org.apache.sling.startupfilter [53](R 53.1)] osgi.implementation; (&(osgi.implementation=osgi.http)(version>=1.0)(!(version>=2.0))) [caused by: Unable to resolve org.apache.felix.http.jetty [40](R 40.3): missing requirement [org.apache.felix.http.jetty [40](R 40.3)] osgi.wiring.package; (osgi.wiring.package=javax.xml.parsers)]] Unresolved requirements: [[org.apache.sling.startupfilter.disabler [147](R 147.0)] osgi.wiring.package; (&(osgi.wiring.package=org.apache.sling.startupfilter)(version>=1.0.0)(!(version>=2.0.0)))]
at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:4368)
at org.apache.felix.framework.Felix.startBundle(Felix.java:2281)
at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1539)
at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:308)
at java.lang.Thread.run(Thread.java:748)
22.10.2021 13:46:58.434 *INFO * [main] Startup completed

saibul
Correct answer by
Level 4
Level 4

I fixed the issue.

1. taken back of crx-quickstart folder for safer side

2. directly ran the server using "java -jar  aem-6.5.0-author-p4502.jar" and it started correctly.

3. uninstalled the sp-6.5.10

4. stopped the server

5. started the server using service and it started.

View solution in original post

saibul
Level 4
Level 4

I don't think sp-6.5.10 caused the issue, but I got my server up at the first place to do something next.