Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
BedrockMission!

Learn More

View all

Sign in to view all badges

saibul
Community profile saibul Level 2
Job title here
Location here
8 BADGES
Level 2

Level 2

Learn more
Joined the community 27-08-2019 6:40:46 AM
Offline
Top badges earned by saibul
Customize the badges you want to showcase on your profile
Re: How to get jwt token from AEM which SAML with MS Azur...
Avatar
Validate 1
Level 2
saibul
Level 2

Likes

6 likes

Total Posts

44 posts

Correct Reply

3 solutions
Top badges earned
Validate 1
Ignite 1
Give Back
Boost 5
Boost 3
View profile
saibul
- Adobe Experience Manager
Thanks, I will check

Views

36

Likes

0

Replies

0
How to get jwt token from AEM which SAML with MS Azure AD
Avatar
Validate 1
Level 2
saibul
Level 2

Likes

6 likes

Total Posts

44 posts

Correct Reply

3 solutions
Top badges earned
Validate 1
Ignite 1
Give Back
Boost 5
Boost 3
View profile
saibul
- Adobe Experience Manager
AEM 6.5.5. Our site is integrated with SAML authentication with MS Azure AD, So it will automatically sign-on when we hit the particular page path. It is working fine as expected.Now we want to call another application API from AEM page that expects JWT token, that application also used MS Azure AD for authentication.Is there a way to get JWT token from AEM?

Views

66

Likes

0

Replies

2
upgrade core.wcm.components 2.7.0 to lateset
Avatar
Validate 1
Level 2
saibul
Level 2

Likes

6 likes

Total Posts

44 posts

Correct Reply

3 solutions
Top badges earned
Validate 1
Ignite 1
Give Back
Boost 5
Boost 3
View profile
saibul
- Adobe Experience Manager
Server: AEM-6.5.1 SP-6.5.5 Currently we have "core.wcm.components 2.7.0" installed and planning to upgrade this core.wcm.components alone. Can we directly update to the latest version 2.13.4Or we need to update to intermediate and then the latest. Thanks in advance for your recommendations.

Views

169

Likes

0

Replies

2
Adding new Publish and Dispatcher to Load Balancer
Avatar
Validate 1
Level 2
saibul
Level 2

Likes

6 likes

Total Posts

44 posts

Correct Reply

3 solutions
Top badges earned
Validate 1
Ignite 1
Give Back
Boost 5
Boost 3
View profile
saibul
- Adobe Experience Manager
Previously we had 1 publish and 1 dispatcher in staging, Now we have added one more publish(2) and dispatcher(2).We have 2 dispatchers connected with load-balancer now. Out of 6 sites, we have 2 sites are login-based sites. Planning to go with “/stickyConnections” for the authenticated site so that the dispatchers will serve from the same dispatcher & publisher.In one of our sites, the logged-in user will create a favorite(collection of image path) and the favorite is stored under the /home/user...

Views

161

Likes

0

Replies

1
Re: AEM SAML Authentication not working on new site
Avatar
Validate 1
Level 2
saibul
Level 2

Likes

6 likes

Total Posts

44 posts

Correct Reply

3 solutions
Top badges earned
Validate 1
Ignite 1
Give Back
Boost 5
Boost 3
View profile
saibul
- Adobe Experience Manager
Thanks Pawan for your time, It works now after adding the path in "Authentication Requirements" field of "Apache Sling Authentication Service" config. Still I didn't understand how the existing site doing the SSO, because I didn't see existing site path in this config. Would the existing site path be configured some where else?

Views

221

Likes

0

Replies

0
Re: AEM SAML Authentication not working on new site
Avatar
Validate 1
Level 2
saibul
Level 2

Likes

6 likes

Total Posts

44 posts

Correct Reply

3 solutions
Top badges earned
Validate 1
Ignite 1
Give Back
Boost 5
Boost 3
View profile
saibul
- Adobe Experience Manager
Also found in the below blog that this is the default behavior of publish and we need to add the path in (org.apache.sling.engine.impl.auth.SlingAuthenticator.xml) confighttps://www.bounteous.com/insights/2018/09/24/single-sign-sso-integration-okta-aem-63/#troubleshooting When I check my SlingAuthenticator.xml there is no existing site path entry in the config.

Views

234

Likes

0

Replies

0
Re: AEM SAML Authentication not working on new site
Avatar
Validate 1
Level 2
saibul
Level 2

Likes

6 likes

Total Posts

44 posts

Correct Reply

3 solutions
Top badges earned
Validate 1
Ignite 1
Give Back
Boost 5
Boost 3
View profile
saibul
- Adobe Experience Manager
same subdomain. moving forward it will be a new subdomain. Even I replace the new site path in the existing site SAML2.0 Authentication Handler config. Still no luck

Views

238

Likes

0

Replies

0
Re: AEM SAML Authentication not working on new site
Avatar
Validate 1
Level 2
saibul
Level 2

Likes

6 likes

Total Posts

44 posts

Correct Reply

3 solutions
Top badges earned
Validate 1
Ignite 1
Give Back
Boost 5
Boost 3
View profile
saibul
- Adobe Experience Manager
Also there is no logs captured. I configured the log for com.adobe.granite.auth.saml package as well.

Views

258

Likes

0

Replies

0
AEM SAML Authentication not working on new site
Avatar
Validate 1
Level 2
saibul
Level 2

Likes

6 likes

Total Posts

44 posts

Correct Reply

3 solutions
Top badges earned
Validate 1
Ignite 1
Give Back
Boost 5
Boost 3
View profile
saibul
- Adobe Experience Manager
We created a new site and configured the SAML in configMgr.The path of the new site is "/content/site2/us/en/voice". The new site path and serviceProviderEntityId are added to the new SAML config. We don't want to configure "Authentication Requirement" or "Closed User Group" in the new site properties path as we want all the AD users should access the new site.In the new site when hit the URL it just renders the page instead of redirecting to idp. SAML integration with AzureAD is working in the ...

Views

264

Likes

0

Replies

5
Re: Design time path not found for model with ID: /var/wo...
Avatar
Validate 1
Level 2
saibul
Level 2

Likes

6 likes

Total Posts

44 posts

Correct Reply

3 solutions
Top badges earned
Validate 1
Ignite 1
Give Back
Boost 5
Boost 3
View profile
saibul
- Adobe Experience Manager
You are right. Also I noticed workflow model metadata node has "cq:generatingPage" property which has value from "\conf" node path. Iam not sure how come this OOTP workflow have design path in conf instead of libs. I just removed the property then it worked.

Views

282

Likes

0

Replies

0
Design time path not found for model with ID: /var/workflow/models/request_for_deactivation
Avatar
Validate 1
Level 2
saibul
Level 2

Likes

6 likes

Total Posts

44 posts

Correct Reply

3 solutions
Top badges earned
Validate 1
Ignite 1
Give Back
Boost 5
Boost 3
View profile
saibul
- Adobe Experience Manager
We are getting below error log when accessing workflow models from touch UI console and the model UI is blank.This is OOTB workflow, not sure how to resolve this issue. 10.11.2020 06:48:34.518 *WARN* [204.153.122.4 [1604990914422] GET /libs/cq/workflow/admin/console/content/models.html HTTP/1.1] libs.cq.workflow.admin.console.components.item.workflowmodel.card.card$jsp Design time path not found for model with ID: /var/workflow/models/request_for_deactivation10.11.2020 06:48:34.521 *ERROR* [204....

Views

363

Likes

0

Replies

4
Re: Can restrict triggering a workflow if already an inst...
Avatar
Validate 1
Level 2
saibul
Level 2

Likes

6 likes

Total Posts

44 posts

Correct Reply

3 solutions
Top badges earned
Validate 1
Ignite 1
Give Back
Boost 5
Boost 3
View profile
saibul
- Adobe Experience Manager
Thanks vanegi

Views

213

Likes

0

Replies

0
Can restrict triggering a workflow if already an instance is running
Avatar
Validate 1
Level 2
saibul
Level 2

Likes

6 likes

Total Posts

44 posts

Correct Reply

3 solutions
Top badges earned
Validate 1
Ignite 1
Give Back
Boost 5
Boost 3
View profile
saibul
- Adobe Experience Manager
Server: AEM 6.5.5 We have a requirement like triggering a custom workflow programmatically on scheduled basis at the same time the scheduler should not trigger a new workflow instance until the existing instance is complete or terminated. Do we have any config or property to manage this or we need to maintain some configs on our own. Appreciate your suggestions.

Views

273

Likes

0

Replies

3
Re: Service accounts are not listing in AEM Publish under...
Avatar
Validate 1
Level 2
saibul
Level 2

Likes

6 likes

Total Posts

44 posts

Correct Reply

3 solutions
Top badges earned
Validate 1
Ignite 1
Give Back
Boost 5
Boost 3
View profile
saibul
- Adobe Experience Manager
The service account created using com.adobe.acs.commons.users.impl.EnsureServiceUser-custom-service-user.xml config. The account is not showing in prod publish alone and it shows in all lower environments both author and publish. The user is showing under /home/users/system node in crxde in impacted system. Since the account is not showing in useradmin I am not able to view the permission and manage it.

Views

186

Likes

0

Replies

0
Re: Service accounts are not listing in AEM Publish under useradmin
Avatar
Validate 1
Level 2
saibul
Level 2

Likes

6 likes

Total Posts

44 posts

Correct Reply

3 solutions
Top badges earned
Validate 1
Ignite 1
Give Back
Boost 5
Boost 3
View profile
saibul
- Adobe Experience Manager
-

Views

220

Likes

0

Replies

0
Re: Service accounts are not listing in AEM Publish under...
Avatar
Validate 1
Level 2
saibul
Level 2

Likes

6 likes

Total Posts

44 posts

Correct Reply

3 solutions
Top badges earned
Validate 1
Ignite 1
Give Back
Boost 5
Boost 3
View profile
saibul
- Adobe Experience Manager
There is no log captured. The service account created using com.adobe.acs.commons.users.impl.EnsureServiceUser-custom-service-user.xml config. The account is not showing in prod publish alone and it shows in all lower environments both author and publish. The user is showing under /home/users/system node in crxde in impacted system. Since the account is not showing in useradmin I am not able to view the permission and manage it. Any solutions to bring it in the UI

Views

189

Likes

0

Replies

0
Service accounts are not listing in AEM Publish under useradmin
Avatar
Validate 1
Level 2
saibul
Level 2

Likes

6 likes

Total Posts

44 posts

Correct Reply

3 solutions
Top badges earned
Validate 1
Ignite 1
Give Back
Boost 5
Boost 3
View profile
saibul
- Adobe Experience Manager
AEM - 6.5.5 Service accounts are not listing in AEM Publish under useradmin. But it listing in author environments. Thanks in advance if anyone could help with this.

Views

276

Likes

0

Replies

6
Always catching in to Typed / Bookmarked in Referrer Reports
Avatar
Validate 1
Level 2
saibul
Level 2

Likes

6 likes

Total Posts

44 posts

Correct Reply

3 solutions
Top badges earned
Validate 1
Ignite 1
Give Back
Boost 5
Boost 3
View profile
saibul
- Adobe Analytics
OS: RHEL 7.6 (Maipo)Server: AEM-6.5.1 SP-6.5.1Adobe Launch---------------------------------------------When we try to take below Referrer reports always the counts are showing under Typed / Bookmarked.Reports/Traffic Sources/Referring Domains,Reports/Traffic Sources/Referrer TypesReports/Traffic Sources/ReferrerIn some of the blogs they mentions if(search-engine) -> else if() -> else if() -> else { "Typed / Bookmarked" ). Agreed, but what I missed here to get the actual values. if I need to set ...

Views

206

Likes

0

Replies

2
Re: Disabling "Disable Rewriting" in "Day CQ Link Checker...
Avatar
Validate 1
Level 2
saibul
Level 2

Likes

6 likes

Total Posts

44 posts

Correct Reply

3 solutions
Top badges earned
Validate 1
Ignite 1
Give Back
Boost 5
Boost 3
View profile
saibul
- Adobe Experience Manager
Adobe confirmed that it is a bug and they replied the below in the support ticket.After I discussed this issue internally, I came to know that there is already a bug created for the engineering team until the engineering team fix this issue, here is the workaround team shared with me which I tested myself: 1. To prevent this issue happening till we get fix from engineering- Overlay or modify /libs/cq/gui/components/siteadmin/admin/properties/form/form.jsp to not escape the action. Have [B] inste...

Views

234

Like

1

Replies

0
Custom header in pdf using fmdita(XML Documentation Add-on)
Avatar
Validate 1
Level 2
saibul
Level 2

Likes

6 likes

Total Posts

44 posts

Correct Reply

3 solutions
Top badges earned
Validate 1
Ignite 1
Give Back
Boost 5
Boost 3
View profile
saibul
- Adobe Experience Manager
AEM - 6.5com.adobe.fmdita-6.5-3.6.170-add-on We have two requirements1. Need to have company name, logo and caption in pdf first page alone.2. Need to have company name, logo and caption in header in all the pdf pages.Do we need to have achieve this using custom pdf plugin? And which files needs to be changes to achieve these.

Views

243

Likes

0

Replies

0
Re: where I can download fmdita package
Avatar
Validate 1
Level 2
saibul
Level 2

Likes

6 likes

Total Posts

44 posts

Correct Reply

3 solutions
Top badges earned
Validate 1
Ignite 1
Give Back
Boost 5
Boost 3
View profile
saibul
- Adobe Experience Manager
It is under "Feature" menu

Views

239

Like

1

Replies

0
Re: where I can download fmdita package
Avatar
Validate 1
Level 2
saibul
Level 2

Likes

6 likes

Total Posts

44 posts

Correct Reply

3 solutions
Top badges earned
Validate 1
Ignite 1
Give Back
Boost 5
Boost 3
View profile
saibul
- Adobe Experience Manager
That is the path trying to identify and I have adobe admin console access

Views

240

Likes

0

Replies

0
where I can download fmdita package
Avatar
Validate 1
Level 2
saibul
Level 2

Likes

6 likes

Total Posts

44 posts

Correct Reply

3 solutions
Top badges earned
Validate 1
Ignite 1
Give Back
Boost 5
Boost 3
View profile
saibul
- Adobe Experience Manager
where I can download fmdita package to use "XML Documentation Add-on" functionality.previously it was in the name of "com.adobe.fmdita-6.3.x.x.xzip", but when I search in adobe admin console I could not find the one. Is it renamed to new name. AEM 6.5

Views

351

Likes

0

Replies

6
Re: Disabling "Disable Rewriting" in "Day CQ Link Checker...
Avatar
Validate 1
Level 2
saibul
Level 2

Likes

6 likes

Total Posts

44 posts

Correct Reply

3 solutions
Top badges earned
Validate 1
Ignite 1
Give Back
Boost 5
Boost 3
View profile
saibul
- Adobe Experience Manager
Thanks @vanegi, but in my system the moment I check the "linkcheckertransformer.disableRewriting" checkbox and save in configMgr sceen, I could upload Image in thumbnail tab but it is not viewing what I uploaded.

Views

270

Likes

0

Replies

0
Re: Disabling "Disable Rewriting" in "Day CQ Link Checker...
Avatar
Validate 1
Level 2
saibul
Level 2

Likes

6 likes

Total Posts

44 posts

Correct Reply

3 solutions
Top badges earned
Validate 1
Ignite 1
Give Back
Boost 5
Boost 3
View profile
saibul
- Adobe Experience Manager
@vanegi, able to recreate the issue from my previous comment?

Views

288

Likes

0

Replies

0
Re: Disabling "Disable Rewriting" in "Day CQ Link Checker...
Avatar
Validate 1
Level 2
saibul
Level 2

Likes

6 likes

Total Posts

44 posts

Correct Reply

3 solutions
Top badges earned
Validate 1
Ignite 1
Give Back
Boost 5
Boost 3
View profile
saibul
- Adobe Experience Manager
Could you Upload Image in Thumbnail tab of page properties screen? after making true/false in linkcheckertransformer.disableRewriting property in said config.

Views

307

Likes

0

Replies

0
Disabling "Disable Rewriting" in "Day CQ Link Checker Transformer" config causing  thumbnail issue
Avatar
Validate 1
Level 2
saibul
Level 2

Likes

6 likes

Total Posts

44 posts

Correct Reply

3 solutions
Top badges earned
Validate 1
Ignite 1
Give Back
Boost 5
Boost 3
View profile
saibul
- Adobe Experience Manager
OS: RHEL 7.6 (Maipo)Server: AEM-6.5.1 SP-6.5.1Oak: 1.10.2Dispatcher: build 4.2.3/apache2.4-linux-x86-64 I just disabled the disableRewriting & disableChecking by setting value to true. After setting this property the importing thumbnail image in page properties stopped working. # Configuration created by Apache Sling JCR Installerlinkcheckertransformer.strictExtensionCheck=B"false"linkcheckertransformer.rewriteElements=["a:href","area:href","form:action","img:src","link:href","script:src"]linkch...

Views

381

Likes

0

Replies

6
Unable to move(rename) asset in same folder in AEM
Avatar
Validate 1
Level 2
saibul
Level 2

Likes

6 likes

Total Posts

44 posts

Correct Reply

3 solutions
Top badges earned
Validate 1
Ignite 1
Give Back
Boost 5
Boost 3
View profile
saibul
- Adobe Experience Manager
Unable to move(rename) asset to the same folder, the move button is disabled when I select the same folder as destination. It is working when I try to move to another folder but the filename is not changing what I had given in the "Title after move" and "Name after move" fields. Server DetailsOS: RHEL 7.6 (Maipo)Server: AEM-6.5.1 SP-6.5.1Oak: 1.10.2Dispatcher: build 4.2.3/apache2.4-linux-x86-64

Views

942

Likes

0

Replies

4
Re: AEM 6.3 tarMK cold standby configuration keeps unregistering
Avatar
Validate 1
Level 2
saibul
Level 2

Likes

6 likes

Total Posts

44 posts

Correct Reply

3 solutions
Top badges earned
Validate 1
Ignite 1
Give Back
Boost 5
Boost 3
View profile
saibul
- Adobe Experience Manager
Iam facing the same issue. what was the solution applied to resolve this issue

Views

1.4K

Likes

0

Replies

0
Need to restrict the Publish or QuickPublish in Assets based on condition
Avatar
Validate 1
Level 2
saibul
Level 2

Likes

6 likes

Total Posts

44 posts

Correct Reply

3 solutions
Top badges earned
Validate 1
Ignite 1
Give Back
Boost 5
Boost 3
View profile
saibul
- Adobe Experience Manager Assets
AEM 6.5.0 We have a requirement like assets to be published only when the asset has a particular value in properties.Let say jcr:content/metadata should have the property approved(Boolean)=true then only the asset should be published otherwise it should show an error popup. Can we customize the existing publish functionality or we have to create a custom workflow? If the solution is custom workflow then still publish menu is allowed to publish.

Views

1.2K

Likes

0

Replies

1
Likes from