Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

SOLVED

AEM 6.5 issue

rohand104
Level 2
Level 2

I'm trying to run AEM 6.5 and this is what i am getting

com.day.cq.dam.commons.util,version=[1.50,2) -- Cannot be resolved

There is no content

1 Accepted Solution
Umesh_Sondhi
Correct answer by
Community Advisor
Community Advisor

You can add the maven dependency in your pom.xml and build and install the code in AEM

<dependency>
  <groupId>com.day.cq.dam</groupId>
  <artifactId>cq-dam-commons</artifactId>
  <version>5.6.6</version>
  <scope>provided</scope>
</dependency>

check if the issue still persist.

View solution in original post

4 Replies
Umesh_Sondhi
Correct answer by
Community Advisor
Community Advisor

You can add the maven dependency in your pom.xml and build and install the code in AEM

<dependency>
  <groupId>com.day.cq.dam</groupId>
  <artifactId>cq-dam-commons</artifactId>
  <version>5.6.6</version>
  <scope>provided</scope>
</dependency>

check if the issue still persist.

View solution in original post

jbrar
Employee
Employee

Uber jar for 6.5 should already have "com.day.cq.dam" embedded. I would recommend using uber-jar instead of adding manual dependencies. More details at [1]

[1]  How to Build AEM Projects using Apache Maven

ronnyfm
Level 4
Level 4

I agree, but even using the dependecy returned by depfinder,

<dependency>

    <artifactId>cq-dam-commons</artifactId>

    <version>5.12.54</version>

    <groupId>com.day.cq.dam</groupId>

    <scope>provided</scope>

</dependency>

I am getting the same exception.

Ankur_Khare
Community Advisor
Community Advisor

Could you please check the version of com.day.cq.dam coming from uber jar (check uber jar for 6.5).

And also check in your pom.xml files anywhere you might have added dependency for com.day.cq.dam the version for com.day.cq.dam should be same as uber jar.