Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

SOLVED

AEM 6.1 Tree Activation

Avatar

Level 8

Wondering where I can find Tree Activation within AEM 6.1?

1 Accepted Solution

Avatar

Correct answer by
Level 8

We still see the issue with every new instance of AEM 6.1 we start.  I have a package that i took from another instance that contains the tree activation page.  If you shoot me a private message, i can forward the package over to you.

View solution in original post

15 Replies

Avatar

Level 6

Hi Lee,

From miscadmin console, select replication. Once it is expanded double click on "Activate tree" option.

From their we can activate entire tree structure.

Avatar

Employee

Verify using crxde that the following renderer JSP is present & not blank:

/libs/cq/replication/components/treeactivation/treeactivation.jsp

Sometimes cleaning up /var/classes may also help. Because tree activation is at the same place as in earlier AEM versions:

https://docs.adobe.com/docs/en/aem/6-1/author/page-authoring/publishing-pages.html#Activating a complete section (tree) of your website

Avatar

Level 8

Agreed in every other version, however, in 6.1 the option isn't available.  See attached screen.

[img]NoTreeActivation.jpg[/img]

Avatar

Level 6

I can able to see activate tree option in 6.1.

Once you posted in forum , i started my AEM6.1 instance and opened activate tree console, performed few dry run.Everything is working fine,Then i posted in forum.

Anyhow , are you logged with ADMIN id?>


 

Avatar

Level 8

Yes, I am logged in as admin.

I have 3 author instances with all hot fixes installed for 6.1 and none of them have Tree Activation.

Avatar

Employee

Hi Lee,

in my 6.1 local instance I just opened: http://localhost:4502/miscadmin#/etc/replication and "Activate Tree" is present. 

I take it you can't see it at http://localhost:4502/crx/de/index.jsp#/etc/replication/treeactivation

What version of AEM is shown in the welcome screen?

Regards,

Opkar

Avatar

Level 1

Hi,

 

were you able to resolve your problem ? I also have an Author instance in AEM 6.1 SP1 with cq-6.1.0-hotfix-8651-1.2, cq-6.1.0-hotfix-8651-1.2 & cq-6.1.0-hotfix-9104-1.0

the link Activation Tree doesn't appear. 

In crxde, under replication, there isn't the link..

If I try to copy/paste the url of the replication tree page from another AEM 6.0, it doesn't work...

 

Kind regards

 

Yannick 

Avatar

Correct answer by
Level 8

We still see the issue with every new instance of AEM 6.1 we start.  I have a package that i took from another instance that contains the tree activation page.  If you shoot me a private message, i can forward the package over to you.

Avatar

Level 1

I've just found the solutoin in another post.

I've created a new node in crx/de with its properties & it works..

 

kind regards

Avatar

Level 2

We had the same issue and found that when 6.1 is installed with nosamplecontent runmode, activate tree functionality is missing. We can package these nodes from another instance (without nosamplecontent runmode) and install it to get it working.

Avatar

Level 4

Hi Ashok,Could you please share the list of filters that need to make this available?

Avatar

Level 1

Just to confirm the solution explicitly to those who are seeing this (as I did) - the root cause is that /etc/replication is missing the 'treeactivation" folder. If you export/import from a working 6.1 instance (or simply recreate the folder in CRX with correct props), the problem goes away.  See attached screenshot for desired state in JCR.

Avatar

Employee

You are right in observing this. Apologies for hitting a known issue.

CQ-45211 - "Activate Tree" is not shown on the instance with nosamplecontent run mode

Workaround is pretty straightforward for it: manually create the missing node at /etc/replication/treeactivation:
{
jcr:primaryType: "sling:Folder",
jcr:title: "Activate Tree",
title: "Activate Tree",
sling:resourceType: "cq/replication/components/treeactivation"
}


This will solve the problem.

Avatar

Level 5

Does anybody have a complete solution/know that this issue got solved in later versions (AEM 6.3.3) ?

Avatar

Employee Advisor

localhost:4502/libs/replication/treeactivation.html is available on my local AEM 6.4 SP2