Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
BedrockMission!

Learn More

View all

Sign in to view all badges

Unable to login to admin ui in AEM Forms 6.5 JEE

Avatar

Avatar
Validate 10
Level 4
Bibhu_Bikash_Na
Level 4

Likes

37 likes

Total Posts

630 posts

Correct Reply

46 solutions
Top badges earned
Validate 10
Validate 1
Give Back 10
Give Back 5
Give Back 3
View profile

Avatar
Validate 10
Level 4
Bibhu_Bikash_Na
Level 4

Likes

37 likes

Total Posts

630 posts

Correct Reply

46 solutions
Top badges earned
Validate 10
Validate 1
Give Back 10
Give Back 5
Give Back 3
View profile
Bibhu_Bikash_Na
Level 4

06-04-2021

Hello All,

We have 6.5 AEM Forms JEE + Weblogic + MS SQL Server. Frequently we are unable to login to admin ui using administrator and password. After restarting the managed server, admin server and node manager it works. But it happens mostly on a daily basis. Any idea?

Replies

Avatar

Avatar
Give Back 3
Level 2
SameerDhawan
Level 2

Likes

8 likes

Total Posts

11 posts

Correct Reply

4 solutions
Top badges earned
Give Back 3
Give Back
Boost 5
Boost 3
Boost 1
View profile

Avatar
Give Back 3
Level 2
SameerDhawan
Level 2

Likes

8 likes

Total Posts

11 posts

Correct Reply

4 solutions
Top badges earned
Give Back 3
Give Back
Boost 5
Boost 3
Boost 1
View profile
SameerDhawan
Level 2

06-04-2021

Hi @Bibhu_Bikash_Na ,

Please confirm if this is Cluster/standalone Environment.

If this Cluster Setup,

a) Please confirm which caching mechanism we are using 

> TCP

> UDP

 

b) There should not be any time difference between the Cluster Nodes

c) Share the Error that you are getting in the logs when trying to login to /adminui

 

Regards

Sameer Dhawan

 

 

 

Avatar

Avatar
Validate 10
Level 4
Bibhu_Bikash_Na
Level 4

Likes

37 likes

Total Posts

630 posts

Correct Reply

46 solutions
Top badges earned
Validate 10
Validate 1
Give Back 10
Give Back 5
Give Back 3
View profile

Avatar
Validate 10
Level 4
Bibhu_Bikash_Na
Level 4

Likes

37 likes

Total Posts

630 posts

Correct Reply

46 solutions
Top badges earned
Validate 10
Validate 1
Give Back 10
Give Back 5
Give Back 3
View profile
Bibhu_Bikash_Na
Level 4

06-04-2021

Hi Sameer,

 

Thanks for your quick response. It's an un-clustered server. We are getting the below error while we try to login.

 

####<Apr 5, 2021 1:54:32,790 AM EDT> <Error> <com.adobe.idp.docmanager.service.DocumentManagerServiceImpl> <rpc15030.corp.ncr.com> <DEV63> <purgeDeletionLoop> <<anonymous>> <BEA1-10430FC818DB69C13B23> <8038c75e-fa71-4021-b6fd-d077a31f0725-00000008> <1617602072790> <[severity-value: 8] [rid: 0:145] [partition-id: 0] [partition-name: DOMAIN] > <BEA-000000> <Error in batch-delete!
java.lang.RuntimeException: java.sql.SQLException: Attempt to set connection harvestable to false but the connection is already closed.


Caused By: java.sql.SQLException: Attempt to set connection harvestable to false but the connection is already closed.

 

Thanks,

Bibhu.

Avatar

Avatar
Give Back 10
Employee
PulkitJain
Employee

Likes

30 likes

Total Posts

31 posts

Correct Reply

13 solutions
Top badges earned
Give Back 10
Establish
Boost 25
Give Back 5
Give Back 3
View profile

Avatar
Give Back 10
Employee
PulkitJain
Employee

Likes

30 likes

Total Posts

31 posts

Correct Reply

13 solutions
Top badges earned
Give Back 10
Establish
Boost 25
Give Back 5
Give Back 3
View profile
PulkitJain
Employee

06-04-2021

@Bibhu_Bikash_Na 

Based on the log[0] shared, please check the value of "enable Test Connections On Reserve" under Admin Console -> Navigate to the Data Source's Configuration -> Connection Pool -> (Advanced) -> check "Test Connections On Reserve"

Restart the node/admin server and monitor for any further issues. 

 

[0] - ... Caused By: java.sql.SQLException: Attempt to set connection harvestable to false but the connection is already closed.

 

Avatar

Avatar
Validate 10
Level 4
Bibhu_Bikash_Na
Level 4

Likes

37 likes

Total Posts

630 posts

Correct Reply

46 solutions
Top badges earned
Validate 10
Validate 1
Give Back 10
Give Back 5
Give Back 3
View profile

Avatar
Validate 10
Level 4
Bibhu_Bikash_Na
Level 4

Likes

37 likes

Total Posts

630 posts

Correct Reply

46 solutions
Top badges earned
Validate 10
Validate 1
Give Back 10
Give Back 5
Give Back 3
View profile
Bibhu_Bikash_Na
Level 4

06-04-2021

Hi Pulkit,

 

We have made the changes. As it is an intermittent issue, we have kept a tab on it to check this. Though there is another issue. While invoking any service that needs PDF operation such as generatePDF through output service we are getting the below error for the first time invocation. However, it works fine while we invoke it 2nd time.

 

####<Apr 6, 2021 12:47:17,538 AM EDT> <Error> <com.adobe.service.ProcessResource> <rpc15032.corp.ncr.com> <AEM65> <[ACTIVE] ExecuteThread: '28' for queue: 'weblogic.kernel.Default (self-tuning)'> <<anonymous>> <BEA1-1D43CE0E532C58315DF7> <cc5e9581-738e-4615-88c5-7184e8db49c4-00000400> <1617684437538> <[severity-value: 8] [rid: 0] [partition-id: 0] [partition-name: DOMAIN] > <BEA-000000> <ALC-BMC-001-031: An unexpected CORBA exception occurred while allocating a connection by service XMLFormService
org.omg.CORBA.COMM_FAILURE: Attempt to send message on closed socket vmcid: 0x0 minor code: 0 completed: No

 

Caused By: java.io.EOFException: Attempt to send message on closed socket

Avatar

Avatar
Validate 10
Level 4
Bibhu_Bikash_Na
Level 4

Likes

37 likes

Total Posts

630 posts

Correct Reply

46 solutions
Top badges earned
Validate 10
Validate 1
Give Back 10
Give Back 5
Give Back 3
View profile

Avatar
Validate 10
Level 4
Bibhu_Bikash_Na
Level 4

Likes

37 likes

Total Posts

630 posts

Correct Reply

46 solutions
Top badges earned
Validate 10
Validate 1
Give Back 10
Give Back 5
Give Back 3
View profile
Bibhu_Bikash_Na
Level 4

06-04-2021

Hi @PulkitJain 

 

We have made the required changes suggested by you and will keep you informed on the errors. We are also getting below error in the server logs as well intermittently as well.

 

####<Apr 6, 2021 1:01:47,706 AM EDT> <Error> <com.adobe.service.J2EEConnectionFactoryManagerPeerImpl> <rpc15032.corp.ncr.com> <AEM65> <[ACTIVE] ExecuteThread: '28' for queue: 'weblogic.kernel.Default (self-tuning)'> <<anonymous>> <BEA1-2A74CE0E532C58315DF7> <cc5e9581-738e-4615-88c5-7184e8db49c4-00000007> <1617685307706> <[severity-value: 8] [rid: 0:134:1:3] [partition-id: 0] [partition-name: DOMAIN] > <BEA-000000> <ALC-BMC-001-001: Unexpected exception while getting connection
org.omg.CORBA.COMM_FAILURE: Attempt to send message on closed socket vmcid: 0x0 minor code: 0 completed: No

 

 

Caused By: java.io.EOFException: Attempt to send message on closed socket

 

Thanks,

Bibhu.

Avatar

Avatar
Validate 10
Level 4
Bibhu_Bikash_Na
Level 4

Likes

37 likes

Total Posts

630 posts

Correct Reply

46 solutions
Top badges earned
Validate 10
Validate 1
Give Back 10
Give Back 5
Give Back 3
View profile

Avatar
Validate 10
Level 4
Bibhu_Bikash_Na
Level 4

Likes

37 likes

Total Posts

630 posts

Correct Reply

46 solutions
Top badges earned
Validate 10
Validate 1
Give Back 10
Give Back 5
Give Back 3
View profile
Bibhu_Bikash_Na
Level 4

07-04-2021

Hi Pulkit, We have implemented the same and observing it. Till now we have not faced the similar issue. Thanks for your quick help.

Avatar

Avatar
Give Back 10
Employee
PulkitJain
Employee

Likes

30 likes

Total Posts

31 posts

Correct Reply

13 solutions
Top badges earned
Give Back 10
Establish
Boost 25
Give Back 5
Give Back 3
View profile

Avatar
Give Back 10
Employee
PulkitJain
Employee

Likes

30 likes

Total Posts

31 posts

Correct Reply

13 solutions
Top badges earned
Give Back 10
Establish
Boost 25
Give Back 5
Give Back 3
View profile
PulkitJain
Employee

07-04-2021

No problem Bibhu! In case this issue persists, please raise a support ticket so that i can review the problem over a screenshare session.

Avatar

Avatar
Give Back 10
Employee
PulkitJain
Employee

Likes

30 likes

Total Posts

31 posts

Correct Reply

13 solutions
Top badges earned
Give Back 10
Establish
Boost 25
Give Back 5
Give Back 3
View profile

Avatar
Give Back 10
Employee
PulkitJain
Employee

Likes

30 likes

Total Posts

31 posts

Correct Reply

13 solutions
Top badges earned
Give Back 10
Establish
Boost 25
Give Back 5
Give Back 3
View profile
PulkitJain
Employee

27-04-2021

@Bibhu_Bikash_Na  I don't see any new reports of this issue so please confirm, if the issue is resolved. Otherwise, please raise a support ticket to discuss the issue over a screen share session.

 

Regarding the other issue reported, error msg points to WebLogic level socket connection timeout exception which needs to be increased incrementally.

- In console: click server, then protocols tab, then general sub-tab, then in advanced options try to increment Idle Connection Timeout parameter (ideally its 65 let's make it 100) and also try boosting all of these timeouts in WebLogic:

1) Stuckthead timeout

2) message timeout

3) output timeout

4) JTA timeout.