Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

SOLVED

Unable to initiate process in HTML form

Avatar

Level 2

Hi Mayank Gandhi,

I am facing problem invoking process while invoking sub-process while rendering HTML forms. We have AEM 6.4 on Forms (JEE) setup and creating forms through workbench/designer. I carried out following steps but unable to initiate the process:

1. Created xml schema

2. Created xdp form in livecycle designer. In XDP form, created data connection for sub process and bind fields on the form.

3. created 2 processes. one is for Main process. another one is sub process.

4. In Main process, configured workspace start process activity, xdp form should be render as HTML.

5. I deployed the application and tried to invoke the sub process from workspace. but it does not work for me.

Kindly suggest if you have any pointers.

Regards,

Sunder S

1 Accepted Solution

Avatar

Correct answer by
Employee

Aem Forms Samples

Look for ore populating mobile form

i still think you can achieve your use cases using OSGI

we can have a discussion if you need

View solution in original post

6 Replies

Avatar

Employee Advisor

Hi Sunder,

Please tell me the role of sub-process here and when does this get called?

Thanks,

Mayank

Avatar

Level 2

Hi Mayank,

Details are as follows:

Role - To pull the employee email ID from the database

Activity Trigger - It has only one SQL query execute activity.

Regards,

Sunder S

Avatar

Correct answer by
Employee

Aem Forms Samples

Look for ore populating mobile form

i still think you can achieve your use cases using OSGI

we can have a discussion if you need