Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

SOLVED

Signature step not showing pdf

Avatar

Level 3

I have setup scribble signature on my adaptive form and also a signature step just below the scribble signature component.

The scribble signature works well in preview, but the signature step isn't show the pdf, it just says loading...

Any reason why the pdf isn't showing? i am using chrome and also have installed the chrome pdf viewer, still no luck.

1 Accepted Solution

Avatar

Correct answer by
Level 3

'Signature Step' should be the only component in a panel. You should not have any other field with it. Generally its used in child panel of a panel having wizard layout, hence the name 'Signature Step'.

PS: https://helpx.adobe.com/aem-forms/6-3/signing-forms-using-scribble.html 

View solution in original post

16 Replies

Avatar

Correct answer by
Level 3

'Signature Step' should be the only component in a panel. You should not have any other field with it. Generally its used in child panel of a panel having wizard layout, hence the name 'Signature Step'.

PS: https://helpx.adobe.com/aem-forms/6-3/signing-forms-using-scribble.html 

Avatar

Level 3

i have set it to what you suggest, its still not rendering the pdf. See screenshot

Avatar

Level 3

Then please check your error logs , to see if there is any exception.

Avatar

Employee

Just to make sure- you have SSL configured on your aem server?

Avatar

Level 3

Yes i have configured ssl successfully , as in when someone hits 4502 it will redirect to https 5443

I will check the error log shortly

Avatar

Level 3

Yes, I have.

I am following the instructions on a doc and a package zip from adobe, maybe you can pass me your email and i can mail it to you, this forum does not allow uploading of zip files.

The error i got was this:

Caused by: com.adobe.document.xmlform.RenderException: IDL:com/adobe/document/xmlform/RenderException:1.0

Avatar

Employee

What is your server OS? Also are you able to preview DOR associated with AF in the edit mode

Avatar

Level 3

the server os is windows 10, i was able to preview the dor fine in edit mode, it failed in preview mode.

Avatar

Employee

are you able upload a xdp and then preview the xdp as HTML ?

Avatar

Level 3

it wouldn't preview, throws an error:

Internal Server Error

Cannot serve request to /content/dam/formsanddocuments/temp.xdp/jcr:content in /libs/xfaforms/render/GET.jsp

Exception:

com.adobe.forms.service.LCFormsServiceException at com.adobe.forms.service.impl.LCFormsOsgiServiceImpl.render(LCFormsOsgiServiceImpl.scala:92) at com.adobe.forms.service.impl.LCFormsServiceImpl.render(LCFormsServiceImpl.java:68) at org.apache.jsp.libs.xfaforms.render.GET_jsp._jspService(GET_jsp.java:124) at org.apache.sling.scripting.jsp.jasper.runtime.HttpJspBase.service(HttpJspBase.java:70) at javax.servlet.http.HttpServlet.service(HttpServlet.java:725) at org.apache.sling.scripting.jsp.jasper.servlet.JspServletWrapper.service(JspServletWrapper.java:502) at org.apache.sling.scripting.jsp.jasper.servlet.JspServletWrapper.service(JspServletWrapper.java:449)

Avatar

Employee

So it looks like your installation is not proper. Are there any spaces in the path of your installation directory? How did you start your server? Did you use a batch file? Or double clicked the jar file? Are all your bundles in active state?

Avatar

Level 3

nope, no spaces : D:\AEM6.3

started as a windows service

bundles all active