Highlighted

Read Only AdaptiveForms User on Author

Avatar

Avatar

Maruan_Sahyoun

Avatar

Maruan_Sahyoun

Maruan_Sahyoun

22-10-2018

Hi,

we are looking to allow forms testers read only access to Adaptive Forms on an author instance but struggling to get the correct settings. Either we have no access, missing content or too many capabilities such as being able to edit the form.

What we tried so far is setting up a special group forms-testers with similar capabilities forms-users would have on a publish instance. Unfortunately that doesn't work. Being logged in as admin and impersonating into a user being a member of the group everything looks fine. But as soon as we log into the system as a member of the forms-tester group and using the URL under /content/dam/formsanddocuments ...  "no resource found".

Trying another path /content/forms/af/ ... (as suggested in another thread) gives the same result. In addition even being logged in as an admin using the /content/forms/af path the adaptive form is only partially rendered.

Is there a guide or some material to get a better idea which folders/resources need to be accessed?

Thanks

Maruan

Replies

Highlighted

Avatar

Avatar

Mayank_Gandhi

Employee

Avatar

Mayank_Gandhi

Employee

Mayank_Gandhi
Employee

22-10-2018

Can you try adding below OOTB  groups to the user you are creating and test the form.

  • forms-submission-reviewers
  • forms-users

Highlighted

Avatar

Avatar

Maruan_Sahyoun

Avatar

Maruan_Sahyoun

Maruan_Sahyoun

22-10-2018

Thanks for the hint. Unfortunately I had no success with these settings. Could it be that running on JEE makes a difference as I'm struggling to add users using the ./lc based UI versus ./adminui. Uisng ./lc I can create a user but am unable to login using that user. Creating the user using /adminui works fine and I can log on.

Avatar

Avatar

Mayank_Gandhi

Employee

Avatar

Mayank_Gandhi

Employee

Mayank_Gandhi
Employee

22-10-2018

Hi Maruan,

Are you trying to bring in the User created in AdminUI to OSGI side?

Also, are you using lc/useradmin to add the user and groups?

Highlighted

Avatar

Avatar

Maruan_Sahyoun

Avatar

Maruan_Sahyoun

Maruan_Sahyoun

23-10-2018

I tried  both - adding the user in /adminui as well as /lc/useradmin using different user names between both to make sure that they don't inherit.

/adminui: I can log in with that user but can't choose the groups you are mentioning

/lc/useradmin: I can choose the groups but am unable to login.

BTW. we are on 6.4.2