Expand my Community achievements bar.

Enhance your AEM Assets & Boost Your Development: [AEM Gems | June 19, 2024] Improving the Developer Experience with New APIs and Events
SOLVED

Missing js files after AEM 6.5 upgrade

Avatar

Level 2

Hi All,

My customized js which renders a logo is not showing up when I inspect the page under sources. But when I am opening the metadata node, I can see the js is available and the logo is also popping up.  Any idea what could actually cause this? /apps/XXXX/clientlibs/actions and actions is of type cq:ClientLibraryFolder is showing up in source when I inspect, but then /apps/XXXX/clientlibs/admin   again type cq:ClientLibraryFolder is not showing in source. 

1 Accepted Solution

Avatar

Correct answer by
Level 2

Hi @SameerDhawan the comparison did not yield any solution. I had tried it. However, the issue was with JS minify. It is solved now. Thanks all

View solution in original post

4 Replies

Avatar

Employee Advisor

@dheerajs7745023  What's the aem forms cfp version? A quick hack, try to package your client libs, delete the node client libs from crx and reinstall the pkg you created earlier. Leave the mapping to form container as is. 

Avatar

Level 2
@Mayank_Gandhi I tried this already and it did not help in anyway. We are upgrading from 6.4.8 to 6.5. I can see the JS pops up for one page and does not for another.

Avatar

Employee

Hi @dheerajs7745023 ,

Have you tried re-building[1] the Client Libs. Can you please give a try and see if that makes any difference.

 

[1] : http://localhost:4502/libs/granite/ui/content/dumplibs.rebuild.html?invalidate=true

 

Regards

Sameer Dhawan

Avatar

Correct answer by
Level 2

Hi @SameerDhawan the comparison did not yield any solution. I had tried it. However, the issue was with JS minify. It is solved now. Thanks all