Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
BedrockMission!

Learn More

View all

Sign in to view all badges

Issue with generating a PDF by requesting from AEM 5.6 to forms 6.4

Avatar

Avatar
Validate 1
Level 2
lksfjhadfas
Level 2

Likes

3 likes

Total Posts

19 posts

Correct Reply

1 solution
Top badges earned
Validate 1
Boost 3
Boost 1
Applaud 5
Affirm 1
View profile

Avatar
Validate 1
Level 2
lksfjhadfas
Level 2

Likes

3 likes

Total Posts

19 posts

Correct Reply

1 solution
Top badges earned
Validate 1
Boost 3
Boost 1
Applaud 5
Affirm 1
View profile
lksfjhadfas
Level 2

31-08-2018

Hey Guys,

We are currently performing migration from 5.6 to 6.4 but we need to support an application in AEM 5.6 to send a request to Forms 6.4 to generate a PDF. Initially we were generating using 6.2 but now we are moving to 6.4.

I am able to generate a PDF if i request it from AEM 6.4 but i am getting an error if i request it from AEM5.6

Below is the error. Any help would be appreciated.

Thank you,

~Swetha

31.08.2018 13:23:48.540 *ERROR* [RequestProcessor-1] com.adobe.document.XMLFormService ALC-XTG-001-021: [13544] XMLForm, load : 12309, XFA data Model is empty.

31.08.2018 13:23:48.540 *ERROR* [127.0.0.1 [1535736228295] POST /aem-services/fundstory HTTP/1.1] com.adobe.forms.aem.impl.XFANativeServiceImpl <?xml version="1.0" encoding="UTF-8"?>

<status

><messages

><m mid="12309" tid="13544.23404" sev="f" d="2018-08-31T13:23:48.536-04:00"

>XMLForm, load : 12309, XFA data Model is empty.</m

></messages

><validationWarnings

/><validationErrors

/></status

>

Accepted Solutions (1)

Accepted Solutions (1)

Avatar

Avatar
Validate 1
Level 2
lksfjhadfas
Level 2

Likes

3 likes

Total Posts

19 posts

Correct Reply

1 solution
Top badges earned
Validate 1
Boost 3
Boost 1
Applaud 5
Affirm 1
View profile

Avatar
Validate 1
Level 2
lksfjhadfas
Level 2

Likes

3 likes

Total Posts

19 posts

Correct Reply

1 solution
Top badges earned
Validate 1
Boost 3
Boost 1
Applaud 5
Affirm 1
View profile
lksfjhadfas
Level 2

12-10-2018

This issue was resolved. I had special characters in the json which was creating the issue. It was painful to find it!

Answers (4)

Answers (4)

Avatar

Avatar
Validate 1
Level 2
lksfjhadfas
Level 2

Likes

3 likes

Total Posts

19 posts

Correct Reply

1 solution
Top badges earned
Validate 1
Boost 3
Boost 1
Applaud 5
Affirm 1
View profile

Avatar
Validate 1
Level 2
lksfjhadfas
Level 2

Likes

3 likes

Total Posts

19 posts

Correct Reply

1 solution
Top badges earned
Validate 1
Boost 3
Boost 1
Applaud 5
Affirm 1
View profile
lksfjhadfas
Level 2

12-10-2018

We are currently migrating and still have to support the existing application for our customer base.

Avatar

Avatar
Give Back 5
Employee
kjaeggin
Employee

Likes

17 likes

Total Posts

110 posts

Correct Reply

11 solutions
Top badges earned
Give Back 5
Give Back 3
Give Back 10
Give Back
Boost 5
View profile

Avatar
Give Back 5
Employee
kjaeggin
Employee

Likes

17 likes

Total Posts

110 posts

Correct Reply

11 solutions
Top badges earned
Give Back 5
Give Back 3
Give Back 10
Give Back
Boost 5
View profile
kjaeggin
Employee

07-09-2018

It sounds to me that the you are not passing in all the inputs necessary to render the PDF (dynamic or flat?). How are you calling either the Forms or Output API?

Avatar

Avatar
Springboard
Level 10
Mayank_Gandhi
Level 10

Likes

309 likes

Total Posts

1,131 posts

Correct Reply

184 solutions
Top badges earned
Springboard
Establish
Validate 1
Contributor 2
Ignite 5
View profile

Avatar
Springboard
Level 10
Mayank_Gandhi
Level 10

Likes

309 likes

Total Posts

1,131 posts

Correct Reply

184 solutions
Top badges earned
Springboard
Establish
Validate 1
Contributor 2
Ignite 5
View profile
Mayank_Gandhi
Level 10

31-08-2018

Also, why would you run and support an application on a version(5.6) which is even end of extended support[1].

[1] All Apps Help | Products and technical support periods

Avatar

Avatar
Springboard
Level 10
Mayank_Gandhi
Level 10

Likes

309 likes

Total Posts

1,131 posts

Correct Reply

184 solutions
Top badges earned
Springboard
Establish
Validate 1
Contributor 2
Ignite 5
View profile

Avatar
Springboard
Level 10
Mayank_Gandhi
Level 10

Likes

309 likes

Total Posts

1,131 posts

Correct Reply

184 solutions
Top badges earned
Springboard
Establish
Validate 1
Contributor 2
Ignite 5
View profile
Mayank_Gandhi
Level 10

31-08-2018

Swetha,

Can you please give detail on how you are invoking the PDFG service from 5.6 and 6.4? Also, Did it worked previously when you invoke the d same service from 5,6 to 6.2?