Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
BedrockMission!

Learn more

View all

Sign in to view all badges

SOLVED

Forms Theme Editor Errors

jetate
Level 4
Level 4

I'm running Adobe Experience Manager 6.5.10.0 and getting the following errors in the console when I try to edit a Forms Theme.

 

It shows the loading graphic, downloads the jcr_content and throws the following errors. 

 

jetate_0-1631542693926.png

 

I'm also seeing the following errors when trying to edit a form. The loading animation runs but the form editor never loads. 

 

jetate_1-1631542815158.png

 

Then if I try to load a form in a page, I get "org.apache.sling.api.SlingException: Cannot get DefaultSlingScript". We were having issues on a previous service pack (6.5.7 and possibly 6.5.4) with the Forms Theme Editor just downloading the jcr_content, which isn't much of an issue in the long run and I worked around it, but now the forms won't load at all. 

 

Is there anything I can do to fix this short of rolling back the SP?

 

1 Accepted Solution
Kosta_Prokopiu1
Correct answer by
Employee
Employee
6 Replies
PulkitJain
Employee
Employee

@jetate 

I am unable to replicate the issue in-house. Which theme you're trying to edit?

Please check if all the aemds* and aemfd* packages are of the right version as per 6.5.10.0 patch level and in installed state.

This should resolve the issue with jcr_content getting downloaded. 

jetate
Level 4
Level 4

I am using the OOTB Forms, not the Add On. Are there still additional packages that should be installed for Forms to work?

 

I haven't ever been able to edit a theme without the Forms Add On. The theme is one that was created, which worked fine to create on 6.5.4 and 6.5.7 but would download jcr_content on edit. I've built the styles I need externally to the theme, but with 6.5.10, I can't even load a form that was created previously.

GirishBedekar
Level 9
Level 9

You need to install AEM forms add on package which needs a license

jetate
Level 4
Level 4

Previously, and according to the Forms docs, I should be able to get some level of functionality with OOTB forms. I was able to build the forms I have with OOTB forms on 6.5.7.

 

jetate_0-1631650256470.png

 

Kosta_Prokopiu1
Correct answer by
Employee
Employee
jetate
Level 4
Level 4

I understand the difference. I've built forms with the OOTB components previously. My issue is that it's not working since I updated the Service Pack. I can't open the forms that were created last week on a previous service pack. Reading about the difference between paid Forms and OOTB forms doesn't solve that issue. I've built a custom clientlibs to style my forms outside of the theme editor. I've modified the OOTB components where I needed to for certain style requirements. Today, after upgrading from 6.5.7 to 6.5.10, I get JavaScript errors in the console and can no longer view, edit, or embed my forms in a page. Why?