since ‎04-01-2018
‎06-08-2020
jetate
Level 3
Re: AEM 6.5 SAML Default User Group Login 404 Error jetate - Adobe Experience Manager
The user is getting created. We suspect this is an issue with our load balancer where the user is logging on to one pub but hitting another before the user info is synced, as @nupurjain said. We had sticky sessions on our 6.3 instance but do not have that on the new one.
28
Views
0
Likes
0
Comments
Re: AEM 6.5 SAML Default User Group Login 404 Error jetate - Adobe Experience Manager
After some testing, this is exactly what I think is happening. We have a dispatcher with a load balancer and 3 publishers, and I believe that our user is logging in to one pub and hitting another while the attributes are being synced. On our old instance, we had sticky sessions which are no set up on the 6.5 instance. Sync is working properly, and we did some tests with only one active pub and did not have the login issue. We're going to work with the instance team to set up some cookies to try ...
28
Views
0
Likes
0
Comments
AEM 6.5 SAML Default User Group Login 404 Error jetate - Adobe Experience Manager
I have SAML set up to create new users with a default access group on creation. When new users log in to the site, their user account is created but they hit a 404 error on page load. We have a CUG enabled on the top level site page for the default user group that the user is added to on first log in. If the user refreshes the page, it will load, but no matter what, users hit a 404 on first log in.We had a similar setup with a different user group name on our old 6.3 instance and never had this ...
115
Views
0
Likes
7
Answers and Comments
Re: SAML Custom AuthenticationHandler Can't Get User Info jetate - Adobe Experience Manager
Thanks! That first link might be useful. I hadn't come across that one yet.
32
Views
0
Likes
0
Comments
Re: SAML Custom AuthenticationHandler Can't Get User Info jetate - Adobe Experience Manager
So I have one attribute that comes in as a list, and when I set addGroupMemberships to true and set that attribute name as groupMembershipAttribute, none of the groups in the list are added.
40
Views
0
Likes
0
Comments
Re: SAML Custom AuthenticationHandler Can't Get User Info jetate - Adobe Experience Manager
The way our groups are coming in is multiples in an array or string in two different attributes, some of which need to be assigned and some of which don't. We were working with an Adobe consultant on how to process those attributes as user groups, and these are the solutions we were provided. So I have one attribute that comes in as a list, and when I set addGroupMemberships to true and set that attribute name as groupMembershipAttribute, none of the groups in the list are added. My other attrib...
47
Views
0
Likes
0
Comments
SAML Custom AuthenticationHandler Can't Get User Info jetate - Adobe Experience Manager
I have SAML set up and working correctly. I am receiving and storing attributes from SAML into user profile nodes. I am currently using an AuthenticationInfoPostProcessor to turn the profile nodes into user groups however this process runs asynchronously to the AuthenticationHandler methods so new users which haven't had their groups set up are logged in before their groups can be set. When CUGs are enabled for the basic access group, the new users hit an error because they don't have authentica...
75
Views
0
Likes
6
Answers and Comments
Re: DAM Asset Timeline Error jetate - Adobe Experience Manager
Oh, that's awesome. Thank you SO much. I removed the workflows using the ACS Commons Workflow Remover tool, and now the timeline is working again.
63
Views
0
Likes
0
Comments
DAM Asset Timeline Error jetate - Adobe Experience Manager
When I go to the DAM to look at the revision history of any asset, I'm getting an error. The page spins for a while and then throws a 500 error on status.html and events.provider.html.The following are showing in my error log (truncated due to message size). I have no idea what's causing this or how to solve the issue, but the timeline is a hugely beneficial aspect of the DAM for our users. I saw one post that said this is a bug and to increase the query limits to get around it for now as well a...
74
Views
0
Likes
2
Answers and Comments
Re: Default Node Depth for Site Search jetate - Adobe Experience Manager
By default, the cqPageLucene oak:index only indexes 4 nodes deep (*/*/*/*). To increase the node depth for search, you can add additional includes under oak:index/cqPageLucene/aggregates/cq:PageContent with additional levels. By adding include4 (*/*/*/*/*) and include 5 (*/*/*/*/*/*) to my aggregates, my nested components began producing search results.
136
Views
1
Like
0
Answers
Re: Dispatcher 403 error for Asset Share Commons Modal jetate - Adobe Experience Manager
Unfortunately, I'm still getting the 403 error on the partial modal despite being able to access the URL directly.
137
Views
0
Likes
0
Comments
Default Node Depth for Site Search jetate - Adobe Experience Manager
In using the core Search component, I have discovered that content nested in 2 levels of Layout Containers is not showing in my search results while content in only one Layout Container does show.Is there a default setting that can be modified to pull back search results from within two nested Layout Containers or possible deeper? EDIT - Answer marked correct is not the solution.By default, the cqPageLucene oak:index only indexes 4 nodes deep (*/*/*/*). To increase the node depth for search, you...
276
Views
0
Likes
2
Answers and Comments
Re: Dispatcher 403 error for Asset Share Commons Modal jetate - Adobe Experience Manager
I've added this filter rule prior to posting, but I'm still getting the 403 error. As I initially asked, I'm wondering if my rule is incorrect or if there is something else I need to do to allow the partial. /assets/actions/*.partial.html is actually under my content node at /content/*/assets/actions/*.partial.html where assets and actions are part of the page structure. I shouldn't have to specify the full path to the file in the dispatcher when that location could be changed, should I?
257
Views
0
Likes
0
Comments
Dispatcher 403 error for Asset Share Commons Modal jetate - Adobe Experience Manager
I have Asset Share Commons set up as part of a site, and everything is working as expected except for the modal functionality. When a modal button is clicked on the dispatcher, there is a 403 error on the file at /content/*/assets/actions/*.partial.html. The page will open without error if I put the full URL into the browser, with and without partial. The modal works correctly on the publishers and author. I installed the Asset Share Commons content as a test and had the same error for the modal...
274
Views
0
Likes
4
Answers and Comments
Re: Core Search Content Fragments in Pages jetate - Adobe Experience Manager
This is not solved.
214
Views
0
Likes
0
Comments
Re: Core Search Content Fragments in Pages jetate - Adobe Experience Manager
They appear to be the same. I see references to /oak:index/cqPageLucene, /oak:index/lucene, and /oak:index/damAssetLucene. I noticed that the OOTB Content Fragment component under General adds a text node to the content fragment node under the page. This node does not exist when using the Core Content Fragment component. If I add this node to the content fragment node under a page, the contents of that node will show in my search results.
308
Views
0
Likes
0
Comments
Re: Core Search Content Fragments in Pages jetate - Adobe Experience Manager
Thanks. I set up the logs, but they are huge. I'm not sure what I'm looking for, but I'm not seeing any red flags. Nothing in search related to content fragments.I came across this yesterday for OSGi configs for Content Fragments -- https://docs.adobe.com/content/help/en/experience-manager-65/developing/extending-aem/content-fragments-config-components-rendering.html#osgi-service-content-fragment-component-configuration -- after finding older information for a deprecated setting that was not set...
331
Views
0
Likes
0
Comments
Core Search Content Fragments in Pages jetate - Adobe Experience Manager
I am working on rebuilding a site that was originally set up in 6.3. I've run into an issue with the Search feature where it's only searching the metadata for the page and not including the Content Fragments in the search. I've overlaid the Search and Content Fragment components from the Core Components bundle. On our 6.3 instance, search is returning pages based on Content Fragment content but it is not on our 6.5 instance. The original site was built roughly 3 years ago, and I don't know if an...
410
Views
0
Likes
5
Answers and Comments
Re: Core Component Breadcrumb Title jetate - Adobe Experience Manager
This is great, thank you! I had a little trouble with the Lambok setup but found that I needed to add some dependencies for biz.aQute.bnd. Now I just need to update it to still allow for fallback from the Page Title for the title if it exists so that I'm just skipping the Navigation Title.
469
Views
0
Likes
0
Comments
Core Component Breadcrumb Title jetate - Adobe Experience Manager
Is it possible to override the Breadcrumb or Page List component to use a different page title than the Navigation Title? I have a requirement where I need to use a shorter title in the Breadcrumb component than in the Page List Component, however, both are using the Navigation Title. If there is a way that I can use one title type for one component and another for the other component, that would be ideal. I'm a relative beginner with Java and don't entirely understand how the Delegation Pattern...
538
Views
0
Likes
3
Answers and Comments
Re: Overlay not working for Asset Toolbar Buttons jetate - Adobe Experience Manager
I don't know if this is the correct way, but in order to get the base.jsp overlay working, I had to overlay the entire /libs/dam/gui/coral/components/admin/contentrenderer/base/ folder and update the references in the files in /apps/dam/gui/coral/components/admin/contentrenderer/base/init/ to point to the apps overlays instead of the libs files. I also had to update the references in the overlays I had under /apps/dam/gui/coral/components/admin/contentrenderer/ in the card, column and row files ...
2351
Views
1
Like
0
Replies
Re: Overlay not working for Asset Toolbar Buttons jetate - Adobe Experience Manager
I've added the new button successfully, but I can't it to display without adding it to the base.js file. This isn't working in the overlay but does work if I put it in the libs file which isn't the correct way to do it.
2351
Views
0
Likes
0
Replies
Overlay not working for Asset Toolbar Buttons jetate - Adobe Experience Manager
I am trying to add custom buttons to the Asset Toolbar in 6.3 to trigger Delete and Publish workflows specific to our content administrators. I have been able to successfully create the button to trigger the specified workflow as desired, but I can't get the button to show when overlaying /libs/dam/gui/coral/components/admin/contentrenderer/base/base.jsp to apps.I have already overlaid other customizations for showing custom meta fields on the card, list and column views under /apps/dam/gui/cora...
2468
Views
0
Likes
3
Replies
Re: Saving forms to database jetate - Adobe Experience Manager Forms
Thanks, everyone, for the replies. I figured out how to achieve what we're looking for with the drafts and submissions data in order to create some reporting on our drafts information by parsing the XML in the data field of the data table. That maintains my drafts and still gives me access to my data.Saving straight from the form was never my main issue, just trying to maintain my current solution while providing access to reporting.
1289
Views
0
Likes
0
Answers
Re: Saving forms to database jetate - Adobe Experience Manager Forms
How would you pull it back out for updating later? Or would it be possible to submit to the database alongside the drafts submission but with just the form data?
1287
Views
0
Likes
0
Answers
Saving forms to database jetate - Adobe Experience Manager Forms
I currently have some forms set up that are saving to MySQL with the Drafts and Submissions process successfully. For our currently purposes, we are needing to keep these forms available as drafts for users to continually update relating to the progress of varying projects.However, we are also trying to do some reporting based on the data in these form drafts. Is there a way to simultaneously store the forms data to a separate table in the database that we can run reports from? Or is there anoth...
3978
Views
2
Likes
10
Answers and Comments
Re: Touch UI Dialog full screen by default. jetate - Adobe Experience Manager
Exactly what I was looking for! Thanks, akashs51893872!
1592
Views
1
Like
0
Answers
Re: Hosting Static HTML in the JCR jetate - Adobe Experience Manager
Have you made any progress with this?
1577
Views
0
Likes
0
Answers
Re: Linking Adobe Captivate Project in Adobe Experience Manager jetate - Adobe Experience Manager
Unfortunately, Scott, that webinar just Adobe Asset Link which doesn't appear to work with Captivate. We're wanting to be able to run Captivate interactive training modules through AEM if there's a way to set it up.
1858
Views
0
Likes
0
Replies
Re: Linking Adobe Captivate Project in Adobe Experience Manager jetate - Adobe Experience Manager
Were you able to solve this problem? We've just been asked if we can manage Captivate content on our AEM site, and there's very little information available that I can find to tell me if this is even possible. Your post saying it did at one point work with the html folder structure is the most encouraging information I can find, but seeing that you were facing issues recently sets me back.If you can tell me if/how you were able to overcome this issue, I would be very appreciative!!
1858
Views
0
Likes
2
Replies